
LOFTSMAN

Version 8

Program and Documentation Copyright Peter Garrison 1989-2022
All Rights Reserved







LOFTSMAN began in 1989 as FLOFT, a DOS lofting program for aircraft fuselages. 
FLOFT went through several revisions, the last of which broadened its range of 
application to include some elementary marine lofting. Because the F in FLOFT didn't 
have any obvious connection to boats, FLOFT became LOFTSMAN early in 1994. In 
1995, LOFTSMAN swallowed up FLOFT's sister program, WLOFT, in order to provide 
both wing and body lofting facilities in a single application. The Windows version 
appeared in 1997.

I have endeavored to correct errors in LOFTSMAN and to provide adequate 
documentation and product support. Nevertheless, LOFTSMAN, like any other large 
program, is bound to have bugs; in fact, it is likely to have more than most because, unlike
most large programs, it is the work of a single author with no training in programming. It 
is a work in progress, and I welcome bug reports, criticisms, and suggestions.

There is some risk with any computer software that its users will suppose that, because 
they are using a computer, their work will naturally be of a superior quality. In fact, just as
a word processing program cannot ensure that writing done on it, although neat, will be 
graceful or even meaningful, LOFTSMAN cannot guarantee that users will produce 
satisfactory designs. You have to study the documentation, and understand what the 
program does, what it cannot do, and what you must do yourself. Otherwise you may 
discover only at the mockup stage that what you designed is different from what you 
imagined.

Properly used, LOFTSMAN can help to design beautiful and efficient shapes and to bring 
them into being in the shop. LOFTSMAN is not, however, any more than a pencil or 
French curve is, a guarantee of good design.

Peter Garrison

peter@aerologic.com
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Section One

1. Introduction

LOFTSMAN is a program for developing shapes for streamlined bodies, such 
as aircraft fuselages, canopies, nacelles and fairings; boat hulls; and lifting 
and control surfaces and keels, which will be referred to collectively as 
"wings." Its function is to define geometries and to export points, lines and 
wireframes in various formats.

LOFTSMAN is not a drawing processor or CAD program. It should be used 
before a CAD program, to define shapes in the first place. It is generally not 
especially convenient to create shapes with a CAD program and then try to 
import them into LOFTSMAN in order, for instance, to generate meshes. 
Nevertheless, previously defined shapes can usually be recreated in 
LOFTSMAN with good fidelity.

LOFTSMAN is supplied in two versions, a standard version and an enhanced 
version called LOFTSMAN/P. LOFTSMAN/P provides additional facilities for 
automatically generating formatted surface patches and complete input files 
for Pmarc-12, CMARC, and VSAERO1.

Users unfamiliar with classical lofting techniques may at first find some 
aspects of body lofting and curved-wing lofting confusing, particularly if they 
rely on the industry-standard procedure of using the program first to 
accomplish some urgent project and only consulting the documentation later. 
Defining arbitrary three-dimensional shapes is bound to be complicated, and 
LOFTSMAN does not entirely take over the job of designing things; it just 
facilitates it. As strong as the temptation to plunge straightaway into one's 
own project may be, users should study at least Section Two of this manual, 
and work through some of the example cases in Section Four, before 
beginning.

1  VSAERO is a product of Analytical Methods Inc, 2133 152nd Ave NE, Redmond, WA  
98052.
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The inevitable legal excursus

LOFTSMAN and its support programs are copyrighted but in some cases may 
not be copy protected. This means that, as grammatically finicky parents tell 
their children, you can make copies of the programs, but you may not, except 
for purposes of backup. The copy of LOFTSMAN that you purchased should 
be used by one person on one computer at a time; you may place a copy on a 
desktop and another on a laptop, however. If you want several users to run 
LOFTSMAN on different machines at the same time, you must buy a copy of 
the program or a license for each machine. Discounts are provided for 
multiple copies and for site licenses.

This manual may be copied for personal, academic or professional use, but 
not for commercial distribution.

Executable file name

LOFTSMAN comes in three versions:

a basic version providing lofting services only;

a version that includes meshing functions for creating CFD input files;

and a demonstrator that is fully functional but will not save anything.

The respective executable files for these three versions are called LM.EXE, 
LMP.EXE, and LMDEMO.EXE. In this document, however, the executable file 
is generically referred to as LMP.EXE.
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2. Installation

LOFTSMAN is a Windows application, and should run properly under any 
Windows OS since Windows 98. Toolbars and other fixed screen displays are 
designed for at least 1024 x 768 resolution and a full-screen display; lower 
resolution or partial-screen windows may cause some parts of the display to 
misbehave. On the other hand, a magnifying glass may be required to see the 
icons on screens with extremely high resolution.

Required files

Only LMP.EXE is required for basic operation. Upon startup, however, 
LOFTSMAN looks for a configuration file called LM.INI, and if it does not find 
it creates one using defaults. LM.INI is placed in the same directory as the 
LOFTSMAN executable and is automatically updated.  LM.INI is a plain text file 
and may be edited directly by the user, provided that its syntax is respected. 

If LM.INI becomes corrupted and LOFTSMAN will not start, erase LM.INI, which will be
found in the same folder as LMP.EXE.

Directories and paths

LOFTSMAN remembers the most recent directory used, and also remembers 
the location of the library of wing section data files and of most "build" files. 
When loading wing (.WI) files it first looks for specified airfoils in the same 
directory as the wing file, and then in the library directory.

Information on directories in use and also on various defaults and constants 
is stored between sessions in LM.INI. 
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Importing foreign bodies

Lines and solids created in LOFTSMAN can be exported to other programs, 
such as CAD or rendering programs, in various formats, but bodies created in 
other programs cannot be automatically imported. The reason is that 
LOFTSMAN stores shapes in the form of parameters and rules for generating 
their shapes using a particular polyconic procedure. These rules cannot be 
deduced from a list of coordinates in any general way, and so for the most 
part files generated by other software cannot be imported into LOFTSMAN.

There are a few exceptions. Two-dimensional lines, filed as lists of coordinate 
pairs, can be incorporated as segments in body or curved wing definitions, 
and LOFTSMAN of course does import externally defined airfoils. By and large,
however, the intended sequence of work is to define shapes in LOFTSMAN and
export them to other software, not the reverse.

Bitmap files -- photographs, three-view drawings, sketches, etc -- can be used 
as underlying guides for developing lofts of existing geometries. 
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3. Using this manual

The manual is in four sections.

The first, which you have nearly finished reading, provides some basic 
information about setting up LOFTSMAN on your computer.

The second introduces you to the lofting concepts on which LOFTSMAN is 
based and describes the procedures used in defining various types of bodies 
and wings and in creating the data files that describe bodies and wings to 
LOFTSMAN. It also explains the basic data file formats.

The third section describes all of LOFTSMAN's operations and output and 
explains how to obtain various types of information, modify shapes, construct 
bodies out of multiple components, and so on. This section includes an index.

The fourth section is a tutorial using demo files supplied with the program.

Once again, it is strongly recommended that you read Section Two thoroughly,
and work through the examples in Section Four, before undertaking any 
serious work with LOFTSMAN.
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Section Two

I. Body data files

There are two approaches to creating an initial design with LOFTSMAN. One 
is to begin with some kind of rough sketch, from which you scale certain 
measurements and compile a written input file. The other is to start with an 
existing design or with an embryonic shape that LOFTSMAN generates 
automatically, and then modify it on-screen using graphical editing 
procedures. In the second case, you don't have to create the input file; 
LOFTSMAN does it. In either case, however, the final form of your design is 
contained in an .LFT or .WI file.

The basic idea

LOFTSMAN uses a type of curve called a second-degree conic to create body 
shapes. The conic family includes such distinguished members as circles, 
ellipses, parabolas and hyperbolas, as well as a few degenerates like straight 
lines and points. To design with LOFTSMAN, you need to think of all curves 
as composed of one or more conic segments.

Many of the bodies for which LOFTSMAN will be used will be bilaterally 
symmetrical. LOFTSMAN can also design bodies that aren't symmetrical, but 
to start with we'll assume that we're dealing with symmetrical bodies and 
therefore only have to design one side, of which the other will be a mirror 
image. LOFTSMAN's convention is that the right side of a body, looking 
forward, has widthwise coordinates of positive sign. Since right and left are 
confusing terms when you are looking at something head-on, however, the 
pilot's right side will be called the starboard side and the pilot's left the port. 
When we design one side of a symmetrical body, it is the starboard side.
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The first step in design is to decide what kind of cross-sections the body will 
have. Boats may have sections like these,

whereas airplanes are more likely to have sections like these:

Dimensioning terminology

Dimensions running fore and aft are labeled FS, for fuselage station or frame 
station. Vertical dimensions are labeled WL, for waterline. Breadth-wise 
dimensions are labeled BL, for buttline or buttock line. 
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Measurements are taken from a point called the datum, which is the origin of 
the body's coordinate system. The placement of the datum is up to the 
designer. Usually, FS 0.0 is placed ahead of the foremost point on the body, 
and WL 0.0 below the lowest point on the body, in order to avoid confusion by 
keeping all dimensions positive. Some designers prefer to place WL 0.0 on a 
propeller axis or other medial line through the body. BL 0.0 is normally on the
plane of symmetry, if there is one.

You can change the location of the datum after designing the body. For 
example, you can design a single nacelle for a twin-engine airplane and 
afterwards move it to positions on the two wings. 

Units

Any unit may be used, but LOFTSMAN assumes that units will be either 
inches, millimeters or meters, and sets some default parameters, such as 
number of places to the right of the decimal point, accordingly. These may be 
reset by the user. If units are inches or millimeters, large areas like wing areas
are reported as square feet or square meters.

If the unit is "inch", the date is given in month/day/year format; otherwise in 
day/month/year.

Segment frames

To define curved lines with LOFTSMAN, you first break them down into conic 
segments. Next, you add a tangent line at each break point; the meeting 
points of successive tangent lines form, in the case of closed sections, a 
circumscribing polygon. Each portion of this line or polygon lying between two
points of contact with the curve is called a segment frame.

To describe a conic segment, you define its segment frame with three pairs of 
coordinates: those of its points of tangency with the section and of its vertex 
or corner. In addition, a single number called the K Factor defines how closely
the curve approaches the frame.  

Thus, LOFTSMAN uses seven numbers to define each conic curve: X,Y 
coordinate pairs for three points, and a K Factor. Complex lines and three-
dimensional shapes may be built up out of any number of such segments.
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K Factor

If you add two lines to a segment
frame to create a parallelogram
and then inscribe in it a diagonal
intersecting the conic, the K factor
is the fraction of the length of that
diagonal that lies on the far side of
the curve from the original frame.
Thus, if ABC is the frame and
ABCD is a parallelogram, then for
a conic of K = 0.7 intersecting BD
at P, PD/BD = 0.7.

K must be greater than zero and less than or equal to 1.0. Usually, however, K
lies between 0.5, which produces a straight line from one end of the frame to 
the other, and 1.0, which produces a line coinciding with the frame. The K 
factor of a circle or ellipse is 0.707106781, that is, sin(45˚) or half the square 
root of two.

With K < 0.5, the curve generated is identical to a curve of 1.0 - K inscribed 
within the opposite or mirrored side of the parallelogram.

K factors should be expressed with a number of significant digits consistent 
with the desired precision in view of the unit in use, eg three or four decimal 
places for millimeters or inches and seven or eight for meters. 

A-type and B-type bodies

The generally oval cross-sections of many aircraft fuselages can be inscribed 
within a rectangle; LOFTSMAN calls these B-type (for "box") bodies. Each side 
of the section consists of two conic segments, an upper and a lower. B-type 
bodies are always symmetrical with respect to their own plane of symmetry.

Boat hulls, on the other hand, typically have some sharp corners, and their 
segment frames may lie at random angles; LOFTSMAN calls these A-type (for 
"arbitrary") bodies. A-type bodies can be defined with any number of moldlines
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and need not be symmetrical. Of course, an airplane's fuselage may be an A-
type body, and some boats, such as submarines, might have B-type hulls.

Note that "symmetry" here refers to the symmetry of body cross-sections with 
respect to their own plane of symmetry. There is no requirement that the 
plane of symmetry of a symmetrical body by at BL 0.0 in the global coordinate
system. 
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2. Designing a B-type body

Body file format

Body files have the extension LFT. They begin with a header containing 
remarks, the date of creation or of the most recent modification, the unit of 
measure being used, and, if the definition is "A" type, the number of strips 
between moldlines and whether the body is symmetrical or not. This header 
information is followed by a series of basically similar data blocks defining 
moldlines and control lines.

Defining a shape

In most cases you will select Edit > New to create a generic body and then 
massage it to the desired shape. The following discussion assumes, however, 
that you are initially sketching your design on paper and creating a 
written .LFT file. This is the old way and is seldom used now, but it is the 
more systematic and therefore the more instructive approach. Once you 
understand how to loft a design with pencil and paper, doing so on the 
computer screen is easy. 

The basic side and top views of a body consist of the profiles of its highest, 
lowest, and widest contours. The coordinates of the box enclosing a cross-
section at any station are the
coordinates of the bottom, top, and
side contours at that station. A
fourth value, the vertical position,
or WL (waterline), of the point of
maximum breadth, is needed to
locate the break between the upper
and lower curves.

The cross-section at any point is
therefore defined by six values.
Four of them are dimensions;
LOFTSMAN calls these BW (the WL
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of the bottom), TW (WL of the top), and MB (maximum breadth measured from
the plane of symmetry), and WW (the waterline at the point of maximum 
breadth). Each section consists of two curves, one above and one below the 
WW; and each curve has a K Factor, called BK (bottom) or TK (top). K Factors 
are not dimensions, but rather parameters or coefficients defining the 
eccentricity of curves.

LOFTSMAN adds one more dimension to define a box frame: the buttline of 
the plane of symmetry, or POS. In most cases this is zero. A box frame is 
therefore defined by seven dimensions in all, and seven longitudinal lines 
must be designed to establish values for these dimensions at each point along
the body. (The fact that the number of lines required to define a B-type body is
the same as the number of values required to define a conic is merely 
coincidental.)

Note that while BW, WW, and TW are absolute values, MB is measured not 
with respect to the datum but with respect to the plane of symmetry. 
Normally, the datum will lie on the plane of symmetry, and so the MB has the 
same value it would have if it were a BL rather than a dimension. But in the 
case of bodies lying off the plane of the datum, such as a tip tank or wing-
mounted engine nacelle, the distinction is important.

Longitudinal lines

The shapes and positions of cross-sections at several points along the body 
are determined by the contents of the body, such as the engine, pilot and 
passengers, structural requirements, and so on. You then join these points 
with a smooth envelope in side and top views. 

All longitudinal lines must start and end at the same stations, and must 
progress in a positive direction along the X axis. 

Suppose we're designing a two-seat pusher airplane. Starting with a profile 
view of the occupants and engine, we sketch something like this:
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The first sketch can be very rough. For a body like this, which is about 20 feet
long, a 1/20 scale freehand drawing is fine. 

So far we have just two lines, the top and bottom profiles. We must now break
them down into conic segments. This involves some skill and luck, but there 
are a few basic rules to remember:

--  Place breaks at the beginning and end of any straight segment.
--  Place a break at any change in the direction of curvature.
--  Place a break at the flattest point between two sharper curves.
-- When the radius of curvature does not vary much, breaks can be placed 

anywhere.

The first line to deal with is the BW. It begins with a small radius of curvature 
but ends with a long, nearly straight contour. This won't work as a single 
conic, so try a breakdown like this:

With a scale, measure the FS and WL of each segment break and corner, 
using some convenient point as the datum, and mark down these 
measurements on the drawing. There is no need to be especially precise, since
these points are approximate to begin with.

Next, using an ASCII text editor, open the template file BOXDATA.FRM or any 
existing B-type LFT file. To begin with, save it with a new file name; let's use 
BTEST.LFT. (If you don't give it a new name right at the start, you may forget 
later and accidentally overwrite the template file.) The file name must have 
a .LFT extension. To persuade some editors to respect your choice of an 
extension rather than force their own beloved “.TXT” upon you, you may have 
to place the file name in quotation marks.
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You don't need to enter any descriptive text at the File label if you don’t want to, 
but you must enter a date at Last revision. Use any numerical format, such as 8/15/00. 
LOFTSMAN uses 2-digit years and makes no assumptions about the century.

The BW in this case consists of three segments; type 3 beside Segments:. 
Then type in the coordinates of the foremost point alongside the Fore end 
label. There must be two coordinates separated by a comma; the first 
coordinate is the FS, the second the WL. No spaces are required in addition to 
the comma.

Now go down to the Aft end label and type in the coordinates of the end of 
the first segment. Then insert a tab or a few spaces and type in the 
coordinates of the end of the second segment, followed by another space and 
those of the end of the third segment.

Now drop down to the Corner label and type in the coordinates of the 
corners of the conic frames.

Note that it was unnecessary to put the coordinates of all of the segment 
breaks in the Fore end line, because all but the first would duplicate the 
information in the Aft end line. Only the first coordinate pair needs to 
appear in the Fore end line.

On the last line for the BW block you must put a Curvature for each conic 
segment. In this context, curvature means exactly the same thing as K Factor;
a different term is used just to avoid confusion between the K Factors of 
cross-sections and the K Factors of segments of longitudinal lines.

LOFTSMAN includes a facility for getting the K Factor of a known line. For a 
first draft, however, it's easier just to enter 0.75 for all Curvatures. In fact, you
don't even have to type 0.75; just put in an asterisk, and LOFTSMAN will 
understand what you mean.

The BW block now looks like this:

BOTTOM WATERLINE

Segments: 3

Fore end  0,-11.5
Aft end  17,-17 116,-16 232,10
Corner  0,-14.5  69,-25    173,-5
Curvature    *         *         *
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It isn’t necessary to arrange the numbers in neat columns. The only 
formatting requirement is that you retain the colon (:) that appears after each 
occurrence of the word Segments and that you place at least one space 
between coordinate pairs.

Repeat the procedure for the TW. Then draw a plan view of the body and 
repeat the procedure again for the MB.

Now sketch cross-sections of the body at a few strategic locations; these might
be the base of the windshield, the shoulders of the occupants, and the rear 
cylinders of the engine. You can superimpose these sections on your profile 
view. Mark on the profile view the WL of widest point, and draw a fair line 
more or less through these points -- it's more important that the line be 
smooth than that it pass exactly through all the points. This is the WW; break
it into segments, if necessary, as you did the other lines and enter it in the 
file.

The dimensions of the boxes for all frames along the body are now 
established. Still missing is the variation of top and bottom K Factors from 
nose to tail.

Graphing K Factor

On a separate piece of graph-ruled paper, create a graph whose horizontal 
axis represents fuselage station and whose vertical axis represents K Factor 
over a range of 0.5 to about 1.2. Enter on it the desired values of the bottom K
Factor at two or three locations. These might be determined by clearance for 
the pilot's feet, or for some protruding portion of the engine; the K Factor at 
the spinner bulkhead has to be 0.7071. Then draw in a fair line from nose to 
tail, passing through those locations. The line looks something like this:
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Break it down into conic segments just as if it were any other line and enter 
their coordinates in the file. Then do the same for the TK.

Note that for the K Factor graphs as for any other longitudinal curve, it's 
essential to use smooth, fair lines. Any sharp break in any longitudinal line 
will appear as a kink in the smooth surface of the body. Of course, you may 
want a kink. In this example, there is an intentional kink in the TW at the 
base of the windshield.

Straight Segments

For a straight segment, there is no corner -- only a starting and an ending 
point. To indicate a straight segment, place the letter S on both the Corner 
line and the Curvature line. This is the procedure for any straight segment, 
including one that is part of a longer line containing other segments either 
straight or curved.

Adding the Plane of Symmetry

As is usually the case, the POS is simply a straight line. The block will look 
like this:

BUTTLINE AT PLANE OF SYMMETRY 

Segments: 1

Fore end 0,0
Aft end 232,0
Corner S
Curvature S 

As a shortcut, you can in some basic cases assign a segment count of zero to 
any moldline except the first in any file and omit the rest of the block. For 
surface-contour moldlines, LOFTSMAN will supply coordinates for a straight 
line having a BL or WL of zero or, in the case of K Factor lines, a value of 
0.7071.
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Thus, the Plane of Symmetry block could be written this way:

BUTTLINE AT PLANE OF SYMMETRY 

Segments: 0

Copying lines

Sometimes moldlines have identical dimensions, or are mirror-images of one 
another. To indicate that a moldline is identical to a previously defined one, 
place an '=' sign after Segments: followed by the name of the line to be copied. 
If you insert a minus sign ('-') between '=' and the name, the line will be 
mirrored about the appropriate zero plane or, in the case of a TW mirroring a 
BW or an MB copying a TW or BW, about the nose waterline of the WW. (The 
colon after “Segments” must be retained.) The rest of the data block for the 
line may be omitted. This shortcut may be used for both A-type and B-type 
bodies. For example:

Top Waterline

Segments: =-BW

Lines that are copies of other lines remain linked to them. When a line is 
edited, lines that are copies of it are changed as well. On the other hand, if 
you edit a line that is a copy of another line, the linkage between them is 
broken. If several lines are copies of one line, identify them all in terms of the 
first line, not of one another successively.

Viewing the body

The data file for the body is now complete, and you can display it. Start 
LOFTSMAN, select File > Open data file, and retrieve the file.
 
It is possible that you will have made errors in typing out the file. The next 
section discusses how to debug a .LFT file. For the time being, however, let’s 
assume that LOFTSMAN has accepted your input file without complaint. 
Nothing appears on the screen until you request some sort of display.
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Select

Body >Normal section

LOFTSMAN displays the shape as a
series of normal cross-sections or
“slices.”

Finding errors in .LFT
files

When you load an .LFT file for the first time you may get an error message 
indicating that there is something wrong with it. Some common errors are 
typing a comma for a decimal point or a period for a comma, and failing to 
match the segment count in any block with the number of coordinates 
actually defined. (These problems do not arise if you create the geometry 
interactively on the screen and LOFTSMAN writes the file.)

LOFTSMAN provides a hint about where the error occurred; sometimes, 
however, the error will be found a block or two before the point reported. The 
only errors LOFTSMAN will detect are those of formatting. A correctly 
formatted file may still produce an unintended shape.

When LOFTSMAN detects a formatting error, it creates a file called LFT.ERR 
that lists the numbers it has read so far from the data file. By comparing 
LFT.ERR with the data file, you may be able to locate the problem. If no error 
is detected, LOFTSMAN writes the input data, as read, into a file called 
LFT.RED. Normally, there is no reason to consult this file, but in cases of 
persistently mystifying input anomalies it may prove helpful.

Moldlines, control lines and strips

The BW, WW, TW and MB lines are called "moldlines." They lie on the surface 
of the body and represent the breaks between the conic segments that make 
up the cross-sections. 
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Another category of line is the "control line." Control lines help determine 
shape, but they do not lie on the surface. The K Factor graphs are examples of
control lines. A line running through all the top corners of the segment frames
would also be a control line, but we haven't had to deal with it explicitly 
because when B-type frames are used, the height and width of the boxes 
imply the coordinates of the corners of box frames. When we use A-type 
frames, however, the corner control lines will have to be explicitly specified.

A portion of the body between two longitudinal moldlines is called a strip. All 
strips must run the entire length of the body, even though in some places 
they may have zero height or width.

The term band is used to distinguish a circumferential belt of body surface 
from a lengthwise strip.

Two rules regarding corner point control lines should be kept in mind. First, a
corner point may not coincide with either of its two associated moldlines, 
unless the strip has zero width. Second, a corner point may not lie on a 
straight line between its associated moldlines.

The second rule may seem difficult to implement, since some control lines 
may pass through a plane between their moldlines, and therefore at some 
point will lie exactly on a straight line between them. As long as you do not 
request a cross-section at that precise point, however, no problem will arise.

Filed segments

Any segment of a moldline or control line can consist of a set of previously 
filed points rather than a conic or straight line. Thus, known coordinates of an
existing body can be used as moldlines or parts of them, as can airfoil 
coordinates, etc.

To indicate that a segment should be defined by filed points, replace the 
Corner coordinates for the segment with the letter F followed by the file
name:

Fore end  0,-11.5
Aft end  17,-17 116,-16 232,10
Corner  0,-14.5  F bw_seg.ml  173,-5
Curvature    * *

Omit the Curvature entry for a filed segment.
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If the filename of a filed segment contains spaces and it is not the final entry 
on the Corner line, place a semicolon after it.

A filed segment must consist of at least four points defined in "plain" ASCII 
format, that is, without hidden formatting codes or delimiters other than 
spaces (between coordinates) and linefeeds (between points). Points may have 
two or three coordinates. For example:

    17.0000  0.0000  -17.0000
    21.0000  0.0000  -18.4449
    43.0000  0.0000  -20.5223
    55.0000  0.0000  -25.8601
    .....
    116.0000  0.0000  -16.0000

The points should be arranged in fore-to-aft order without any reversals of 
direction or vertical jumps. The spacing of points is unimportant, since 
LOFTSMAN always interpolates values for desired stations anyway. 
LOFTSMAN will also automatically determine whether the Y or Z coordinates 
in the file are appropriate to the line of which the segment is a part.

If the filed line does not have the same length as the gap it is supposed to fill, 
or if its first point does not coincide with the fore end of the segment, 
LOFTSMAN will scale and translate the filed line as necessary to fit into the 
segment. If the Y or Z value of the aft end does not then coincide with the last 
point in the filed line, however, LOFTSMAN will not attempt to reconcile them,
since that would require changing the shape of the line.

Filed segments may be used in A-type or B-type bodies, but they should be 
used only when the smoothness of the filed data set is assured. A set of points
measured from a drawing is unlikely to be smooth. Note, also, that 
LOFTSMAN does not ensure smooth continuity between filed segments and 
other (ie conic or straight) segments.

If you precede the name of a filed segment with a minus sign, the line will be 
mirrored about the appropriate zero plane. For example:

Corner  0,-14.5  F -bw_seg.ml  173,-5
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3. Designing an A-type body

The next body to design is a powerboat hull. We want it to look something like
this:

Load the template ARBDATA.FRM and save it using the name ATEST.LFT.

You must first count the number of strips that the body will require. Different 
stations along the body may be of different kinds of shapes and may require 
different numbers of conic segments; but since all strips must run the full 
length of the body, the number of strips for the file must be equal to the 
greatest number that any station will require. 

Thus, although sections close to the bow are triangular in shape and involve 
only two segments, those farther aft require three. So we enter 3 at the Strips 
label.

The next label allows you to select a symmetrical or asymmetrical body. If the 
body is symmetrical, you define one side and LOFTSMAN supplies the other. If
not, you must supply a complete, closed group of segments. This body is 
symmetrical, so we enter the letter Y at the Symmetrical label.
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Now examine a typical cross-section with the segment frames sketched in. It 
looks like this:

Two moldlines, plus a control line for the frame corner and a control line for 
the K Factor, define each strip. The K Factor control line is a two-dimensional 
line, but the other three are three-dimensional; that is, they will look different 
in side view and top view.

As with a B-type body, we begin by sketching all moldlines in side and top 
views to scale. Whereas on B-type bodies the moldlines always coincide with 
the outlines of the body in side or top view, with A-type bodies this needn't be 
the case. For example, in a top view of our hull the sheer line is also the 
outline of the body, but the chine moldline is not. 

Since the corner control lines are invisible, we determine their location by 
drawing two or three cross-sections with their segment frames, locating the 
corners, transferring those points to the side and top views, and then adding 
fair lines through them.

We start at the bottom, entering the BL of each line first, then the WL. Each 
entry is labeled with an identifying code consisting of an M, C, or K (standing 
for moldline, control line, or K Factor) followed by a number and an optional 
final letter. The number is the number of the strip of which the line is a 
member, counting clockwise from the bottom center in a front view. The final 
letter is B or W, meaning buttline (top view) or waterline (side view); it is 
omitted from K Factor codes.
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Each 3D moldline or control line is described twice, first in top view and then 
in side view: M1B and M1W are two views of the same moldline. The 
segmentations of the two views of the same line are completely independent; 
they can have different numbers of segments and breaks at different stations.

Since the second moldline of each strip is the same as the first moldline of the
next, to avoid redundancy each strip is defined by its first moldline and its 
corner and K Factor control lines. At the end of the file the first moldline of an 
imaginary additional strip is provided to close the final strip. Thus, the data 
blocks for top center moldline of a 3-strip body are headed M4B and M4W, 
and they are the last blocks in the file

The strips are numbered consecutively, entering BL coordinates first, then 
WL. The first line defined is M1B, and represents the top view of the bottom 
centerline, or keel line, of the hull. It is a single-segment straight line similar 
to the POS line in the first example.

The next line is M1W. Enter it just as you would the BW on a B-type body.

Now jump ahead to M2B and M2W. These lines appear to begin aft of the 
extreme bow of the vessel. But because LOFTSMAN requires that all lines 
extend the full length of the body, they must be thought of as merging into 
M1B and M1W and continuing to the bow. 

If M1W were a continuously curved line, it would be difficult at this stage to 
know the exact coordinates of the point where M2W meets it. To avoid this 
problem, put a segment break in both lines at the point where they meet.

When the keel and chine moldlines have been defined, go back to the corner 
control lines for the first strip, C1B and C1W. Like M2B and M2W, they 
initially coincide with M1B and M1W, and break away at the same point. C1B 
runs roughly halfway between M1B and M2B, and C1W lies closer to M2W 
than to M1W. With these relations in mind, we can insert a fair line whose 
segment frames will resemble those of its neighbors.

The data blocks for the first strip look like this:

M1B
Segments: 1
  Fore end       0,0
   Aft end       310,0
    Corner       S
  Curvature        S
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M1W
Segments: 3
  Fore end      0,65
   Aft end     28,33.8     156,0     310,0
    Corner      S      58.3,0    S
  Curvature      S      0.75    S  

C1B
Segments: 2
  Fore end       0,0
   Aft end      28,0    310,19.8
    Corner         S    145,19.8
  Curvature         S              0.75

C1W
Segments: 2
  Fore end      0,65
   Aft end      28,33.8     310,6.5
    Corner      S     117,9.1
  Curvature      S              0.75

K1
Segments: 1
  Fore end       0,0.8
   Aft end       310,0.7
    Corner          S
  Curvature         S

The same procedures are used for the two remaining strips.

Getting K Factors

LOFTSMAN will find the K Factor or Curvature that best matches a given 
frame and line segment.

When you select Misc > K Factor, LOFTSMAN prompts you for pairs of 
coordinates locating the fore and aft ends of the curve and the intersection of 
two straight lines constructed tangent to the curve at its ends. 

You may then enter up to 10 points lying along the desired curve. Generally, 
from one to three points are enough; ones located nearest the middle of the 
frame have the most influence. LOFTSMAN marks each location that you 
specify. When you have finished entering points, select OK. LOFTSMAN then 
reports the K Factor best matching the points. 



2.20

If you cannot get a good match to all of your points, then the curve doesn't 
sufficiently resemble a conic: you have chosen your segment breaks badly. 
Revise the segment breaks until you are able to get reasonably good matches 
to all segments.

Interpolating coordinates

In order to ensure continuity between neighboring segments of any curve, the 
straight lines forming the segment frames must meet without inflection at the 
tangent points:

BD must be a straight line if the transition between AC and CD is to be 
smooth.

We ignored this requirement in designing the pusher airplane and the 
powerboat, and simply entered measured coordinates in every case. In fact, 
however, LOFTSMAN allows you to omit certain coordinates, which it supplies
by interpolation, ensuring that all frame lines that should be straight are. This
is not merely a crutch for lazy people; it is the preferable way to define a line, 
since it ensures that lines that should be straight will be. (LOFTSMAN also 
allows smoothing fully-defined lines after the fact.)

To indicate that you want LOFTSMAN to supply a coordinate, place an 
asterisk (*) in the file in its place. To define a moldline, for example, the 
simplest procedure is to define its start and end points and all of the 
intervening corners, and then supply only one coordinate, normally the FS, for
the desired tangent points, replacing the other with an asterisk. LOFTSMAN 
supplies the missing coordinates.

You can also enter *,* for a corner and let LOFTSMAN supply it, provided that 
the two line segments forming it are sufficiently defined. Two points are 
required to fully define a straight line.
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The above line can be defined in several different ways. BE is a straight line, 
as is FG. BE is not necessarily parallel to the ordinate. The entire line can be 
defined by giving X,Y coordinates for A, B, E, and G only, and only X 
coordinates for C, D, and F. On the other hand, you could fully define A, B, D,
F and G, give only an X coordinate for C, and give no coordinates at all (ie *,*) 
for E.

Interpolation in cross-sections of A-type bodies

Moldlines, control lines, and cross-sections are analogous to one another, in 
that they are all constructed in the same way out of conic segments defined by
frames and K Factors. The same considerations of smoothness at tangent 
points apply to cross-sections as to longitudinal lines, and LOFTSMAN can 
interpolate entire moldlines and control lines just as it can interpolate single 
points along a moldline.

To understand this very powerful facility, look at the sample file called 
ARB.LFT, which is supplied with LOFTSMAN. (You may wish to print a copy of
it so that you can examine it more conveniently.) It represents a generic body 
whose cross-section looks like this:

The body consists of four strips, two of which -- bottom and sides -- are flat. 
There are 22 lines (the number of lines in an A-type body is always two more 
than five times the number of strips). Because of the flat, sloping sides, it 
would be impossible to design this shape with a rectangular frame.

Only the starting and ending moldlines (M1 and M5) and two corners (C2 and 
C4) are fully defined. The remaining points of tangency are defined by only 
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one coordinate; in general you can use either one, provided that it contains 
sufficient information to permit deriving the omitted coordinate. Thus, M2B is 
defined, but M2W is not, because M2W can be inferred from M1W and C2W if 
M2B is given, whereas M2B could not be inferred if only M2W were given.

To indicate that a complete line is to be interpolated, place an asterisk after 
the Segments label. Omit the data block (see the sample file ARB.LFT).

Strips 1 and 3 are flat, and therefore don't have corner control lines or K 
Factors. To indicate this, an S is placed after the Segments label for each of 
these control lines. Omit the data blocks for those lines (see ARB.LFT).

The K Factor for any strip that has one is defined by a single control line. You 
must provide it, since it cannot be interpolated from other information.

The size of potential errors in scaling from your original drawing should be 
taken into account in deciding which view of a line to omit. In general, a 
surface slope of 45 degrees or more indicates that the WL should be defined 
and the BL interpolated. For example, M3 is defined by its WL rather than its 
BL because the surface slope at M3 is quite steep, and so any error in 
specifying M3W produces a relatively smaller error in M3B.

Note that this half-section is geometrically similar to the line on page 2.16, 
and the same principles of interpolation apply to both. 

Proportional interpolation of moldlines

When interpolating a moldline that lies on a straight line between two control 
lines, it may be convenient to define its position as a constant fraction of the 
distance between the control lines. To do this, place an equals sign 
immediately after the asterisk indicating interpolation, and supply a fraction 
between zero and one. For example:

Segments: *=0.15

This technique cannot be used for the first or last moldline in the body 
definition, or between control lines in flat strips (that is, ones defined with 
Segments: S).
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Asymmetrical bodies

Cross-sections of B-type bodies are by definition symmetrical. Those of A-type 
bodies need not be.

If an A-type body is defined as symmetrical in the data file, LOFTSMAN 
assumes that the first moldline defines the plane of symmetry and that the 
port side will be a mirror image of the starboard. If it is defined as non-
symmetrical, mirroring does not take place.

Generally, the last moldline in an asymmetrical body will be the same as the 
first. It doesn't have to be; a body could be open like a canoe. If it is, however, 
the Settings > Body depiction > Solid command will not work, because it relies 
not on mathematical hidden-line removal but on the expedient of flooding the 
inside of each cross-section with the background color after it has been 
drawn.

Order of coordinates

Moldlines in A-type bodies are generally ordered bottom to top, or, in the case 
of asymmetrical bodies, beginning at the lowest point and proceeding around 
in a clockwise direction, as viewed in the positive direction along the X axis, 
until returning to the starting point.

Moldlines in B-type bodies are ordered BW, WW, TW, MB, BK, TK, POS.

Points along moldlines, conic frames and stored segments are ordered nose to 
tail, that is, in a positive direction along the X axis.
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4. Compound bodies

LOFTSMAN allows you to assemble "compound" bodies from up to ten 
separate .LFT files. B-type and A-type bodies may be mixed. The files currently
in use can be seen by selecting File > List current data files, and this list may be 
edited to add or remove bodies. The files in the list are re-loaded when you 
close the dialog.

Fairing compound bodies

In some cases, no attempt need be made to join compound bodies seamlessly; 
for example, an air intake along the side of the fuselage of a jet airplane may 
intersect the body along a visible longitudinal seam. On the other hand, you 
may wish to eliminate some seams, especially circumferential ones, such as 
the joint of a canopy and a turtledeck.
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In order to eliminate seams, the segment frames and surface slopes of the 
mating bodies must be identical along the seam. LOFTSMAN will provide 
surface slopes at any point on a body. The second sample case in Section 
Four of the manual provides an example of fairing a windshield into a fuselage
in such a way that the aft edge of the windshield blends perfectly.

You can fair B-type and A-type bodies, but you must ensure that their 
moldlines coincide at the seams. To extrapolate a segment frame line from one
body to a point on another, use LOFTSMAN’s extrapolation and line 
intersection routines.

To obtain a longitudinal joint of a desired shape between two bodies -- for 
instance a straight line to allow a canopy to be piano-hinged along one edge --
the most direct and reliable approach is to use an A-type body and make a 
moldline coincide with the desired line. You can then guarantee the shape of 
the surface contour by your definition of the moldline. With B-type bodies, the
only lines that can be reliably controlled are the BW, WW/MB, and TW.

Handy hints

Some basic rules to bear in mind are:

1. Be lazy. Keep the number of segments in a line to a minimum, use B-type 
bodies if you can, and rely as much as possible on LOFTSMAN's moldline 
copying and interpolation services.  Start with a rough model and refine it on 
screen.

2. Avoid kinks in moldlines, including K Factor moldlines, unless you intend a
visible kink in the surface of the body.

3. Take care to match both values and slopes of all exposed moldlines and 
control lines at stations where a smooth transition occurs from one element of
a compound body to another.

4. Use the Line > Radii display when editing moldlines in order to ensure 
smooth transitions between conic segments.
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 5. Wing data files

LOFTSMAN gets wing data from two types of files, having extensions of .WI, 
and .SD. The .SD ("Section Data") files contain airfoil coordinates; the .WI 
("Wing") files contain surface planform, twist, and other geometry information.
Like .LFT files, both types of wing data files are pure ASCII text files and 
should contain no hidden formatting codes.

A collection of all published NACA (TR 824) and Wortmann sections, as well as
a few others, is included for convenience. These sections are stored in .SD 
format. As it is possible that data entry errors have gone undetected, you 
should examine large-scale plotted versions of these sections for waviness 
before using them. Waviness caused by data entry errors should be obvious to
the eye.

Two non-airfoil sections are included: CIRCLE.SD and LINE.SD. Applications 
for these are left to the ingenuity of the user.

Section data files

LOFTSMAN uses 30 stations for internal storage of normalized airfoil 
coordinates; they are spaced along the abscissa, or chordwise axis, according 
to a cosine progression, at smaller intervals near the leading and trailing 
edges and larger ones mid-chord.

The format, which is similar to that used for .BLD files, looks like this:

@crd
1.000000
@tcrat
0.120000
@coords
1.000000  0.002000
0.997069  0.002688
0.988310  0.004766
...
@end

Labels announcing the category of upcoming data are preceded by @. Labels 
and their associated data may occur in any location in the file. Points in the 
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normalized coordinate list must start at the upper surface trailing edge, move 
forward around the leading edge, and return to the lower surface trailing edge.

Different SD files may contain different information, depending on their 
purpose. Flap sections designed by LOFTSMAN, for instance, may contain 
information about hinge line and slot lip locations and the ratio of the flap 
chord to the main section chord. Any information may be included in an SD 
file, provided that it is preceded by a label that is distinct from other labels. 
Programs reading SD files take only the information that they need and ignore
the rest. 

The chord line is always horizontal, and lies between the trailing edge and the 
most distant point at the leading edge. Leading and trailing edge coordinates 
are always [0.0,0.0] and [1.0,0.0] respectively. Ordinates are measured at a 
right angle to the chord line. Section incidence may be specified in the .WI file 
and/or the .SD file, but is not reflected in the normalized coordinates.

When LOFTSMAN reads an SD file for a profile with a finite-thickness trailing 
edge, it shifts the X coordinates of the trailing-edge points slightly in order to 
make the blunt edge normal to the camber line. Note, however, that for 
CMARC analysis a finite-thickness trailing edge is converted to a wedge 
shape, because the wake must be attached to a single panel edge.

Making .SD files

To create an .SD file from an arbitrary coordinate list, first create a file 
containing the points that you have. They should start at the trailing edge and
proceed along the upper surface, around the leading edge, and back to the 
trailing edge. It is not necessary for the points to be spaced in any particular 
way; for the upper and lower surfaces to use the same stations or even the 
same number of points; or for the chord length to have any special value.

Save this file with any name you care to give it. In LOFTSMAN, select

Edit > Profile

Identify the file you have just created in the file selection dialog. Its profile will 
appear briefly on the screen, followed by a dialog box. In the group headed 
Format, select Create .SD file from points. At the top of the dialog box is the 
name the new file will have. You can use the same name as that of the input 
file, but the new version of it will have an .SD extension.
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Ruled and curved wings

Two types of wing definitions are supported: ruled and curved.

The more basic is the ruled surface, which has been historically prevalent 
both because of the use of metal as a skinning material and because of the 
simplicity of its definition and tooling. A ruled-surface wing consists of two or 
more break stations between which the wing surface is defined by linear 
interpolation.

It should be noted parenthetically that not all ruled surfaces are developable 
-- that is, they cannot necessarily be constructed by wrapping a flat sheet 
around the specified end ribs. With composite structures, however, and even 
with metal wings whose skins consists of a number of pieces, strict 
developability is not required.

Alternatively, a wing surface can be curved. Some familiar examples of curved 
wings are the cranked wing of the F4U Corsair, the semi-elliptical wing of the 
Spitfire, the ogival wing of Concorde, various kinds of fancy wingtips, and 
practically any propeller blade. Modern numerically-controlled milling 
techniques make it possible to create arbitrarily curved wing tooling from 
computed geometries. The definition of a curved wing in LOFTSMAN 
resembles that of a ruled one in that root and tip breaks are defined; for the 
curved wing, however, additional information is provided to define the 
curvature between the end points.

LOFTSMAN stores both types of wing geometry information in files with a .WI 
extension. In the interactive wing line editing procedure, ruled wings may be 
converted into curved ones and vice versa.

Panels and breaks

A ruled wing consists of one or more panels arranged in order, starting at the 
root. Each panel is a spanwise portion of the wing in which chord, airfoil 
section, incidence and so on vary in a linear fashion. (Actually, angular 
incidence varies in a non-linear fashion, but the variation of the slope of the 
incidence is linear.) Positive spanwise dimensions indicate a starboard wing or
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an upright fin or dorsal; negative ones a port wing or an inverted or ventral 
fin. 

The dividing plane between two panels of a ruled wing is called a "break." A 
break is any discontinuity in the wing geometry; at the very least, there are 
breaks at the root and tip of the wing. A break intermediate between root and 
tip may represent a change in rate of twist, in airfoil section, planform, etc. In 
the demo file C1.WI, for example, there are three breaks, representing the 
root, the tip, and an intermediate point near the root; but a wing may contain 
any number (limited only by available memory) of spanwise breaks.

A break can be thought of as an airfoil section floating in space. The airfoil 
section, which is represented by a list of 59 points with a cosine spacing, is 
identified by the name of the SD file in which its normalized coordinates are 
stored. The surface of a ruled wing is defined by LOFTSMAN as a set of 
straight lines connecting the corresponding points on successive break ribs.

Breaks may be rotated for cant first and then for incidence. The result is that 
in front view a break always appears as a line with zero thickness.

The numbering of breaks begins with the innermost end of the wing panel. 
The innermost break need not be on the airplane centerline, but no point on it
may lie on the port side of the centerline. LOFTSMAN will extrapolate airfoil 
sections for ruled panels – but not curved ones -- beyond the end breaks, if 
they are needed.

Wing geometry (WI) files

The basic format of WI files is a list of "breaks" representing spanwise 
discontinuities. At a minimum, a wing must have two breaks, a root and a tip.
Breaks must be listed from the root station outward toward the tip. The file is 
an ASCII text file and may be manually created and edited. It looks like this:

Date: 5/3/08
Unit: inch
Type: Ruled
Breaks: 2

Break 1

Axis: 120,25,-14.2230
Axis/chord: .34
Chord: 48.25
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Incidence: 2
Cant: 3.0626
Section file: N747A315
Thickness: 1.0
Spars: 2
Spar 1: 0.4
Spar 2: 0.728
Panel rib angles: 3.0626,999.0,0.0

Break 2

Axis: 120,210,-4.325
Axis/chord: .34
Chord: 20.00
Incidence: -0.83
Cant: 3.0626
Section file: N64-412
Thickness: 1.0
Spars: 2
Spar 1: 0.339
Spar 2: 0.7

The "Unit:" line is optional. Otherwise, the order of data items, and the use 
and location of colons (:), must be preserved. A convenient way to create a new
.WI file is to take an existing one and change the data in it, leaving the labels 
and other text unchanged. All blocks are similar in format except the last, 
from which the panel rib angles are omitted (because there are no panel ribs 
outboard of the last break).

If the unit is "inch", the date is given in month/day/year format; otherwise in 
day/month/year.

Required data in the .WI file

The planform of a ruled wing is defined in terms of the true chord and an 
imaginary line called the axis. The exact location of the leading and trailing 
edges at any spanwise station is constrained by the axis, the chord, and the 
incidence.

Some of the items in each data block are self-explanatory, but some require 
definition:

Axis:  A point on the chord line, selected by the designer, about which the 
break rib pivots in order to provide it with non-zero incidence. You can put 
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the axis anywhere on the chord line that you like; it can even be on the 
extended chord line ahead of the leading edge or behind the trailing edge. 
Typically, however, it is placed on a straight spar, on a hinge line, or at the 
trailing edge.

An imaginary spanwise line, consisting of straight or curved segments 
connecting the axis points of successive breaks, is called the "axis line."

Axis/chord:  The location of the axis point along the chord line, expressed as 
a fraction of the chord length.

Chord:  The absolute length of the chord line. If incidence is non-zero, the 
chord is not equal to the difference between the FS of the leading and trailing 
edges. The chord of an airfoil is defined as the longest straight line that can be
drawn between the leading edge and the trailing edge. If the trailing edge is of 
finite thickness, the chord line must lie on the point intermediate between the
upper and lower surfaces.

Incidence:  Incidence in degrees is measured with respect to the orthogonal 
axes, regardless of dihedral angle; the panel rotates and/or twists about the 
axis line.

Cant:  The tilt in degrees of the break rib about the X axis with respect to an 
orthogonal plane. Ribs parallel to the plane of symmetry have a cant of zero. 
The right-hand rule applies: positive cant produces clockwise rotation of the 
rib when it is viewed from the front. Thus, cants in vertical fins are around 
90.0, cants in ventral fins are around –90.0.

Thickness:  The nominal thickness/chord ratio of the airfoil. (LOFTSMAN does
not currently use this parameter, and so it need not be accurate.) If the value 
is larger than 0.7 and the wing type is ruled, LOFTSMAN interprets it as a 
multiplier. Thus, if the section file is a NACA 0012 and the thickness 
parameter is 0.9, the t/c ratio of the lofted profiles will be 0.12 x 0.9, or 0.108.

Section file:  The name of the airfoil section file for this break. The file path 
and .SD extension need not be included.

Spars:  For convenience, you can enter any number of chordwise stations as 
percentages of chord. These are displayed, solely as an aid to visualization, as 
vertical webs in some graphics depictions of the complete wing, and are 
marked on plotted sections. They would normally represent the planes of 
spars. If you do not wish to display any spars, enter zero. Spars in curved 
wings are not displayed.

Panel rib angles:  The default cants for ribs in the panel immediately outboard
of the break. When you ask LOFTSMAN for a "default" rib at a certain buttline 
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in a ruled panel, it uses these angles. If you do not wish to specify particular 
panel rib angles, enter an asterisk; ribs will then be normal to the axis line. 
Default ribs normal to the axis line will not necessarily be parallel to the 
direction of flight.

Specified and unspecified rib angles

Only two angles of rotation need to be given to fix a rib in space. In general, 
the rotation most nearly in the plane of the shear web is unspecified. For 
typical wing ribs, rotations about the X (roll) and Z (yaw) axes are specified 
and rotation about the Y (pitch) axis is unspecified. For vertical tail ribs, 
rotations about the X and Y axes are specified and rotation about the Z axis is
unspecified.

An upright wing rib parallel to the plane of symmetry has X and Z rotations of 
zero and an unspecified Y rotation. X rotations control the tilt of the rib (upper
edge to port is positive), Z rotations control the direction it points (nose to port
is positive). The horizontal rib of a vertical fin has an unspecified Z rotation, 
an X rotation of 90 degrees, and a Y rotation of zero degrees. A nose-up Y 
rotation is positive.

The unspecified panel rib angle is indicated with the number 999.0. Thus, an 
unswept wing with 3.21 degrees of dihedral might have an entry on the Panel 
rib angles line of 3.21,999.0,0.0.

Data interpolation

When initially designing a wing it may be convenient to make use of 
LOFTSMAN's interpolation service. On wings having more than two breaks, 
you can replace any numerical value in an intermediate break (other than the 
number of spars) with an asterisk (*). In most cases, LOFTSMAN will 
interpolate the missing value by assuming a straight-line variation between 
the immediately preceding value and the corresponding value in the next 
break in which a numerical value, rather than an asterisk, appears. The one 
exception is incidence. Because the incidence and the location of the leading 
and trailing edge points are mutually dependent, and in ruled wings the 
incidence must be known in order to calculate the leading and trailing edge 
points, it is not possible to make a linear interpolation of incidence. An 
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asterisk therefore causes the incidence at a break to be set to the value of the 
incidence at the preceding break.

The meaning of the asterisk with respect to cants and panel rib angles is 
slightly different from its meaning with respect to other values. Cants and 
panel rib angles can be replaced with asterisks in any break, including the 
ends. LOFTSMAN will place end breaks at right angles to the adjoining axis 
line, and will cant intermediate break ribs in such a way that the slopes of 
their normals are equal to the arithmetic average of the angles of the 
neighboring axis lines. Panel rib angles are set normal to the axis line 
immediately outboard of the break. 

IMPORTANT

If you wish to replace one or more of the three panel rib angles with an 
asterisk, you must replace all of them with a single asterisk. You cannot 
specify some and leave others to LOFTSMAN.

Curved wing panels

A wing may take the form of an arbitrarily curved rather than a ruled or "flat-
wrapped" surface. If any portion of a wing is curved, the entire wing should be
defined as a curved panel. Defining a wing in two separate .WI files, with a 
ruled inner panel and a separate curved tip, is possible, but it can be tricky to

match the two files at their joint.

In a curved wing, parameters such as axis position, incidence, etc. that define 
sections within the panel may vary in a nonlinear way. They are defined by 
seven mold or control lines formed, like the lines in the definition of bodies, of 
conic segments. These definitions are placed in the WI file in a block having a 
format similar to that of a B-type .LFT file. This block is separated from the 
basic wing definition block (described above) by a row of at least five asterisks.
The "Type" line at the head of the file must also read "Curved."
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Curved wing panels have only two breaks, root and tip. A curved wing file 
looks, in abbreviated form, like this:

WING LOFT
Date: 7/16/09
Unit: inch
Type: Curved

Breaks: 2

Break 1
Axis: 24.0000,20.0000,-4.0000
...

Break 2
Axis: 30.0050,82.0000,4.5000
...

*************

Axis WL 

Segments: 2

Inboard end      20.0000,-4.0000 45.0000,3.2865 
Outboard end      45.0000,3.2865    82.0000,4.5000 
   Corner       24.8590,7.1935 66.0353,-0.7940 
Curvature            0.7071               0.7071 

...

Thickness 

Segments: 1

Inboard end       20.0000,1.0000 
Outboard end       82.0000,1.0000 
   Corner               S 
Curvature             S

Note that the Type specifier is "Curved" rather than "Ruled," there are only two
breaks, and a row of at least 5 asterisks separates the curved wing data block 
from the basic break data.
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The curved wing definition block

Some of the parameters defined by the control lines are the same as or similar
to those in the break definitions. They are the axis position in the airplane 
coordinate system; the incidence; the airfoil section. Rather than absolute 
thickness, (which in implicit in the profile), curved wings provide a thickness 
modification factor, which is seldom used.

Each control line consists or one or more conic segments, just like the 
moldlines or control lines in a .LFT file.

Whereas in the ruled type of wing the location of the leading and trailing edges
is controlled by the axis location in space and along the chord line and by the 
chord length and incidence, in the curved wing the planform is directly 
defined, just as though the leading and trailing edges were moldlines in a 
body. The axis line is independent of the planform definition; it is not defined 
as a fraction of the chord. The axis line determines the dihedral of the surface 
and provides (as in a ruled wing) the pivot about which incidence angles are 
defined. 

Only the leading edge, trailing edge and axis lines are actual physical lines. 
The leading and trailing edges are two-dimensional lines, defining the 
planform of the surface. The axis line is defined in three dimensions. 
Incidence, airfoil and thickness are graphs of varying values, analogous to the 
K Factor graphs used in .LFT files. In every case, the X coordinate of the graph
is the spanwise measurement along either the Y or the Z  axis, depending on 
the general orientation of the panel. If an imaginary straight line through the 
axis points at the two ends of the curved panel slopes more than 45 degrees 
from the horizontal, use Waterline for the spanwise measurement; otherwise 
use Buttline.

Dimensions are in the global coordinate system.

The first item in the curved panel data block is either Axis WL or Axis BL. The 
label refers to the value being defined in the ordinate, or Y direction. If the 
reference spanwise axis is the BL (that is, the surface is a wing, canard or 
horizontal stabilizer), the label would be Axis WL, because you are defining 
WL dimensions at various points along a horizontal reference line. On the 
other hand, if the reference axis is vertical (for instance for a fin) you would 
use the Axis BL label, because you are defining BL dimensions at points along
a vertical reference line. Usually the choice is obvious, but some wings 
consisting of components with widely varying dihedral angles may present 
ambiguities, and in instances like a wing with a winglet it may be preferable to
define the two as separate surfaces. It is essential that this first label be 
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correct, since it controls the way in which LOFTSMAN interprets the axis 
coordinates.

The full curved panel definition block looks like this:

Axis WL

Segments: 2

Inboard end 0.0,0.0
Outboard end 67.0,* 115.0,33.0
Corner   40.0,0.0 97,31.5
Curvature *           *

Axis FS

Segments: 2

Inboard end 0.0,0.0
Outboard end 41,* 115,120
Corner    10,31.5 115,64
Curvature *          *

Leading edge

Segments: 1

Inboard end 0.0,0.0
Outboard end 115.0,0.0
Corner    S
Curvature S

Trailing edge

Segments: 2

Inboard end  0.0,91.0
Outboard end 60.0,* 115.0,0.1
Corner    7.0,67.5 115.0,48.0
Curvature *               *

Incidence

Segments: 1

Inboard end  0.0,0.0
Outboard end 115.0,-5.0
Corner    70.0,0.0
Curvature  *
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Airfoil

Segments: 1

Inboard end 0.0,1.0
Outboard end 115.0,3.0
Corner     85,0.8
Curvature  *

Thickness

Segments: 1

Inboard end  0.0,1.0
Outboard end 115.0,1.0
Corner S
Curvature S

Curved wing mold and control lines

Axis coordinates

Since moldlines and control lines are by definition two-dimensional lines, two 
lines are needed to define a three-dimensional axis line. The first line, labeled 
Axis WL or Axis BL, defines the rear view of the axis, that is, a projection on 
the YZ plane with positive dimensions increasing upward and to the right. The
first, or X, coordinate represents a location along the orthogonal axis more 
nearly parallel to the axis of the surface; thus, for an essentially horizontal 
panel, such as a wing, the X values are BLs and the Y values are WLs. For an 
essentially vertical panel like a fin, the X values are WLs and the Y values are 
BLs. This line controls dihedral.

The second line, labeled Axis FS, defines a top or side view, that is, a 
projection of the axis on the XY plane for a predominantly horizontal surface 
or on the XZ plane for a vertical one. X values are BLs or WLs, as appropriate, 
and Y values are FSs. This line controls sweep.

If the axis definition in the "Breaks" portion of the file does not agree with that
in the curved panel data block, that in the curved panel data block takes 
precedence. If you save the file, the "Breaks" portion will be modified as 
necessary to agree with the curved panel data.
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Leading edge and trailing edge

The planform of the surface, divided into leading edge and trailing edge, is 
defined as a projection upon the XY or XZ plane. For non-zero incidences, 
actual chord lengths will differ from the projected distance between leading 
and trailing edges.

Note that the leading and trailing edge lines define only planform, that is only 
two of the three dimensions of a wing or fin. The third dimension (WL for 
wings, BL for fins) is supplied by the axis, through which the chord line 
passes,  and by the incidence.

A curved wing must have a finite tip chord. It may be extremely small, eg .001 
in., but it cannot be zero. In other words, the tips of the leading edge and 
trailing edge lines must not coincide exactly.

As with body lines, a conic segment may not have zero length, because the 
same station along the wing cannot have, for example, two different chord 
lengths. To model a sudden discontinuity, such as a sawtooth leading edge, 
define a segment whose ends are at two BLs a very short distance apart.

Incidence

The fifth line, labeled Incidence, controls the spanwise variation of incidence. 
Its function is slightly different from that of the Incidence entry in the data 
block for a ruled wing. In a ruled wing, the variation of the tangent, or slope, 
of the incidence is linear between breaks, whereas the variation of the angle of
incidence is not linear. In a curved wing, the local angle of incidence at any 
station is directly controlled by the Incidence parameter. 

Airfoil

The Airfoil line can be thought of as a graph, with span on the X axis and 
state of airfoil transition on the Y axis.

If more than two (root and tip) sections are used, the comma-separated names
of all sections except the last should be listed after the Section file: label in the
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first break definition; the last section should be listed with the second break 
definition. For example:

Break 1
...
Section file: N747A315, N66-215
...

Break 2
...
Section file: N64-412
...

The Airfoil line controls the rate at which each profile is transformed into the 
next. Each airfoil's Y-axis value is represented by its list position given as a 
real (non-integer) number, eg 1.0 for the first, 2.0 for the second, and so on. 
The simplest case is a straight-line variation from the root airfoil to the tip, 
but in the following example the variation is non-linear, accelerating as it 
nears the tip:

Airfoil

Segments: 1

Inboard end 0.0,1.0
Outboard end 115.0,3.0
Corner 85,1.8
Curvature *

Any intermediate profile is defined by linear interpolation between two given 
profile coordinate sets. For example, a value of 1.63 would produce the section
that would appear at 63% of span on a ruled wing with #1 (N747A315) and #2
(N66-215) at the root and tip respectively. Note that the spanwise locations of 
the listed profiles are not specified; they are determined by the points at which
the continually rising control line crosses their ordinal values.

Note that it is illogical for any Y axis value in a segment of the airfoil control 
line to lie outside its bounding integers. For example, no Y axis value between 
airfoil 1 and airfoil 2 should be less than 1.0 or greater than 2.0.

If any value in the airfoil control line is greater than the number of profiles 
listed, LOFTSMAN detects an error and stops reading the WI file. 
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Thickness

The Thickness line controls a multiplier that permits you to distort the 
thickness of the airfoil if you want to. (Reasons for doing this might be to 
maintain a straight line at some point along a curved panel for a spar or an 
aileron hinge, or to provide a local bulge for some internal object. Another 
application might be to model an inflatable surface, like a parasail.) Thus, if 
the local value of Thickness is 1.05 and the basic local airfoil section is 11% 
thick, the final thickness will be 11 x 1.05, or 11.55%.

If no modification is required, as is usually the case, the Y value should be 1.0
and should not vary. In any case, thickness modifications should be applied 
with awareness that they may alter airfoil characteristics 

Rib cants in curved panels

The default alignment of intermediate ribs in a curved panel is parallel to the 
appropriate orthogonal plane. Their cant is normal to the projection of the 
axis line on the YZ plane. Thus, the Panel rib angles entry in the general data 
block will not apply, and if you enter a value on that line it will be ignored. 
Nevertheless, the label and its colon must be present.

Except in the case of an inboard break located on the plane of symmetry, the 
cants of the end ribs of a curved wing cannot be overridden by the break 
definitions in the general data block. End rib cants will always be normal to 
the local axis, regardless of the cant values in the WI file, except at the plane 
of symmetry, where the cant is automatically set at zero for wings with 
dihedral angles of less than 45 degrees.

Remember that cant applies only to rotation about the chord line. In curved 
panels, all ribs are by default aligned chordwise, regardless of the shape of the
axis line. 
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Special requirements for wingtips

All WI files must end with a final break rib. A break rib may not have zero 
length. For a curved panel, the tip break rib must be fully defined as an airfoil 
in the .WI file and given a finite chord length, however small. 

Limitations of curved panels

Some procedures available for ruled surfaces are not provided for curved 
panels. Canted ribs are not supported, nor are intersections with other wings.

Order of coordinates

Wing breaks are ordered from root to tip.

Points in ribs are ordered from the trailing edge forward along the upper 
surface, and returning to the trailing edge along the lower surface. In patches 
for CMARC, however, section point order is reversed.
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Section Three

1. System setup

Directory structure

LMP.EXE and LM.INI are in one directory, but groups of files related to 
different projects should be placed in subfolders to reduce clutter. 

When LOFTSMAN creates data files, such as .LFT, .WI or .SD files, it places 
them in the currently selected directory. In general, LOFTSMAN assumes that 
all data and output related to a single project will be in the same directory. As 
you move from project to project LOFTSMAN remembers your most recent 
directory choices.

LOFTSMAN automatically searches the permanent .SD directory as well as the
current one when looking for airfoil data.

Using the menus and dialogs

By and large, command selections must be made using the mouse; except in a
few special cases, there is no support for keyboard commands.
 
Some parameters, such as the STEP and INCREMENT, can be set from within a 
number of different dialogs. In some cases, however, the change applies only 
to the current operation. Use the Settings > Constants dialog to set permanent 
defaults, which are written into LM.INI and return unchanged with each new 
invocation of LOFTSMAN.
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If you have changed the START FS or STOP FS and want to restore them to their
default values (that is, the fore and aft ends of the model), you can either 
select Settings > Range reset or else blank their fields in the Settings > Constants 
dialog. If no values are provided, LOFTSMAN will automatically restore the 
default values.

You can repeat the previous command by tapping the spacebar.

Selecting data files

Many operations, especially meshing operations, require importing filed data. 
When file names are required in a dialog box, a configuration like this may 
appear:

                      

You have three options for supplying the data described by the caption, in this
example Lower edge.

1. You can type a file name in the box. If the file is in the current working 
directory, then you do not need to type the full path, only the file name. To 
be safe, or if LOFTSMAN does not find a file that you know is there, type 
the full pathname including the extension.

2. You can bring up the standard Windows file-opening dialog and pick a file 
from it. Press the button with the question mark to display the dialog box.

3. You can retrieve a file that you have “kept” – that is, stored with a 
nickname just for the duration of this run of LOFTSMAN. If kept files exist,
the name of one of them may already appear in the box, and the complete 
list of kept files will be displayed if you click on the  “drop-down” button at 
the right end of the box.
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Coordinates and units

The nose-tail (roll) axis is X, and
measurements along it are labeled
FS for Fuselage Station or Frame
Station. The vertical (yaw) axis is 
Z, labeled WL for Waterline. The
transverse (pitch) axis is Y, labeled
BL for Buttock Line or Buttline. All
measurements are in relation to a
datum point selected by the
designer, with values increasing
upward, aft, and to the pilot's
right, or starboard, side.

LOFTSMAN's output may be in
either English or SI units, and the
basic SI unit may be either the
meter or the millimeter. The basic English unit is the inch. The type of units 
to be used is specified in the LM.INI file, but can be changed from the 
keyboard, either temporarily or permanently, while LOFTSMAN is running.

In general, LOFTSMAN does not use feet; but in a few instances, such as 
listings of wingspan or wing area, feet or square feet are used because they 
are the conventional unit for those items.

In hydrostatics calculations, tons are used for some items such as 
displacement. They are long tons, equal to 2,240 pounds.

Job timer

The pane at the right hand end of the status bar contains a timer that begins 
running when LOFTSMAN is launched. It is intended to assist in keeping 
track of work time for billing purposes.

To reset the timer to zero, select

File > Reset timer



3.4

Misc and hotkeys

Hitting the [Spacebar] repeats the previous command.

File > Open recent displays a list of recently used data files. To select one or 
more, highlight them and then click outside the box.

r has the same effect as File > Open recent.

s saves the most recent on-screen result.

S saves the current data files.

Quitting

To leave the program, select

File > Exit

If you have changed a data file and not saved the new version, LOFTSMAN 
reminds you. Settings of the STEP, INCREMENT, and various other values, as 
well as the list of data files in use, are saved for the next session.
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2. Data files

Loading data files

To load data from a .LFT or .WI file, you can either select the file from a 
directory listing or type in its name after clicking on File > List current data files.

To use the standard Windows file-opening dialog, select File > Open. You can 
select several files at once by holding down the <Ctrl> key while making your
selections.
 
Files that you select are added to the current list, up to a total of ten wings 
and ten bodies. To clear out the current list before selecting new data, click 
File > Discard current data.

If you use the File > List current data files option, LOFTSMAN presents a form 
with ten lines for body files and ten for wing files. Files may be listed in any 
order and on any lines; LOFTSMAN loads the data files in top-down order, 
ignoring empty lines. It is not necessary to type either the pre-selected 
directory path, if any, or the .LFT or .WI extension.

When more than one body file is in use, separate bodies are combined for the 
purposes of most operations into a single "compound" body. Most output -- 
sections, areas, volumes, etc. -- applies to the entire compound body. There 
are some exceptions, however. For example, editing commands and 
commands involving single moldlines apply only to the first body loaded.

Build files

You can save and restore the working environment for a project by creating a 
“build” (extension BLD) file. The format of the file, which lists the components 
of the model currently in use, is basically as follows, though the number and 
types of categories may vary:
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@body
c1
c2
c3
@rem Remarks are ignored
@wing
c1
c1ht
@currdir
\lm\c1\
@unit
English
@end
This is a build file; since this comment is after the @end token, it 
is ignored

When LOFTSMAN arrives at the @end line, it stops reading the file. Any 
remarks or reminders you add after @end are ignored.

There are several ways to create a build file. The most straightforward and 
quickest is to load all the components of a model and then select

File > Save project

and type in the name for the file. The file will normally be placed in a build file
directory (which must already exist), but you can place it anywhere you like. 
LOFTSMAN remembers the default location of build files.

Alternatively, you can create the file by hand as a simple text file. Empty lines 
may be inserted for clearer formatting if you wish. Different classes of items 
may be listed in any order.

The Windows editor "Notepad" has the obnoxious habit of adding a “.txt” 
extension to the filename you give for any text-only file, even if it already 
includes an extension. To prevent this, put the file name into quotation 
marks.

To load a project from a build file, select

File > Load project

or click on the leftmost button on the toolbar.
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Changing the primary file

When several body files are combined to form a compound body, some 
operations, such as editing, apply only to the first listed body only. To change 
the body that is in the first position, select File > Set primary and pick the file 
name. The file you pick will swap positions with the one currently first.

The same dialog allows you to change the wing file currently in use. Selecting 
a different wing file from the current list causes that file to become active in 
place of the current wing. Unlike bodies, wings do not form “compounds,” and
operations can be performed on only one wing at a time.

Converting between B-type and A-type files

It is sometimes useful to remove some of the constraints of the B-type format, 
for example that the body must be symmetrical or that the segment frames 
must be rectangular.

To convert an existing B-type file to A-type format, first enter the 
moldline/control line editing procedure (Edit > Body lines) and then, under the 
Body heading, select Save as A-type.

A-type files for symmetrical bodies, like files for B-type bodies, define only the 
starboard side of the body, which is assumed to be mirrored across the plane 
of symmetry. To remove this constraint, the body must be fully defined. To 
convert the currently loaded primary body from a symmetrical to an 
asymmetrical format, in the main window (not the Edit window) select

File > Save primary body as bilateral

The body will still be geometrically symmetrical, but it will be defined by a full 
set of moldlines and you will be able to edit the port and starboard lines 
independently of one another and to modify the lines that formerly defined the
plane of symmetry.

The symmetry-removing operation can only be performed on bodies that are 
defined as A-type. If you wish to remove symmetry from a B-type body, you 
must first convert it to A-type format.



3.8

3. Basic operations

Display

LOFTSMAN displays objects on the screen in various forms:

--  Views of cross-sections.
--  Plan views and elevations.
--  Graphs of area distribution, K Factor, and local curvature.
--  Perspective views of bodies and wings.

When the screen is blank and you initially call for some object, LOFTSMAN 
automatically scales the screen to accommodate the requested image. This 
scaling persists until you request a different one with Zoom in or Zoom out, 
explicitly reset the START FS, STOP FS, START BL or STOP BL, or reset the view 
area, all of which are options under the Display and Settings menus. Scaling is 
also automatically reset when you call for a display that logically requires a 
different type of scaling than the current one. 

To produce an appearance of solidity in a body when using the Body >Slices 
choice, check Solid. Solid is on by default.

Save

Two distinct categories of saving are used: saving the data file and saving 
coordinate data calculated by LOFTSMAN’s operations.



3.9

File > Save current result  sends calculated output to a disk file. The item saved 
is generally the one most recently added to the screen display. The same 
command is also executed by the blue floppy-disk icon near the right-hand 
end of the toolbar.

Several formatting options are possible, namely DXF polyline; IGES (3D lines 
only, stored as generic B-spline curves); IBL (for use with ProENGINEER); 
plain unpunctuated listing; .SD (for normalized airfoils); CMARC, PANAIR and
VSAERO2 formatted patches (LOFTSMAN/P only), or ready-to-run Cmarc 
input files using the patches displayed on the screen. Some screen displays, 
such as Area distribution, cannot be saved. Some, such as wing outlines, that
are not body moldlines, intersections, patches, etc., get a generic TXT 
extension.

Saving current data files

Select File > Save > Save current data files.

You can save one or more of the current data files. If you select Save as, 
LOFTSMAN prompts you for a file name, offering the name of the currently 
selected file as a default. 

When several wing data files are currently in use, only the first in the list can 
be saved, because it is the only one that can be altered by editing. If you edit a
wing and then select a new primary without first saving, the changes you 
made will be lost. When you have made changes to a wing and want to retain 
them, be sure to save immediately.

List/Edit

Edit  > List/Edit displays output from the most recent operation in text form -- 
that is, as scrollable lists of numbers on the screen. More than one line 
segment may be displayed, separated by empty lines. A scratch-pad pane is 
provided alongside the work pane; Copy/Paste operations can be used to 
move text from one pane to the other.

2  VSAERO is a product of Analytical Methods Inc, 2133 152nd Ave NE, Redmond, WA  
98052.
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The list may be edited. The edited version of the list replaces the most recent 
output, and if you save, print, plot or display immediately after editing listed 
output, you will get the edited version, not the previous one. To retrieve the 
original version, you must repeat the command that created it in the first 
place. With the exception of the Get button (see below) any editing command 
applies to the pane in which the cursor is currently located.

Basic editing operations are controlled by hot keys. The commands are:

Ctrl-C Copy
Ctrl-V Paste
Ctrl-X Cut
Ctrl-Z Undo (applies only to hot-key operations)

The Delete, Backspace and Enter/Return keys have their expected effects.

In addition to the basic editing commands, several operations are controlled 
by buttons:

Reverse reverses the order of lines in the display.

Mirror changes the sign of the Y coordinate in 3D lines, creating a reflection 
across the plane of symmetry.

Swap exchanges the contents of the two editing panes.

Get reads the contents of a file into the scratch pane. Anything already in the 
pane is overwritten.

Save stores the content of either pane in a file.

Cancel discards any changes you have made.

OK replaces the displayed line or lines with the edited version.

The List/Edit dialog can be opened even if there is no result currently displayed
on the screen In that case, both panes are empty and the data to be edited 
must be imported from a file. 
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Print

File  > Print data sends text to the text printer. Most printed output is 
automatically labeled and dated, and LOFTSMAN sends a page feed command
to the printer at the end of each listing.

File  > Print screen causes the client area of the screen – that is, the drawing 
area excluding toolbar, status bar, etc – to be printed. What is printed is not 
necessarily a snapshot of the screen, however; it is a repetition of recent 
display commands, such as would occur if you zoomed or changed the 
viewpoint.

Plot

File  > Plot sends the current screen display to a plotter or to a printer. The 
basic difference between screen prints and plotted output is that plotted 
output is dimensionally accurate and is scalable, whereas printed output is 
merely sized to fit on a sheet of paper.

Keep

To “keep” a line is to save it as a disk a file, but with two differences.

First, the file created exists only as long as LOFTSMAN is operating; when you
quit the program, the files you have kept are erased.

Second, the name you give a kept line does not have to be a legal file name or 
to follow LOFTSMAN’s file-extension conventions. Usually the names of kept 
items are brief descriptions like "in," "out", "top" or "bottom."

To convert a kept item to permanent storage, select File > Save > Save "kept" 
item. The file extension appropriate to the item type is automatically added to 
the new file name. 
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Using lines stored with Keep and Save

Stored lines are used in a number of meshing operations, including those for 
wing and body bounded regions, transitions, and diaphragms. Depending on 
their eventual usefulness, lines may have been stored with either the Keep or 
the Save command.

Setup dialogs for operations involving stored lines provide three different ways
of recovering the lines:

1. You can simply type the name of the line in the field provided. If the line 
was saved, you must type the full file name, including the extension, eg 
TW.ML. File names are not case-sensitive. If the line was kept, type the 
name you gave it. Note that lines must have been stored before they can be
used; you cannot, for example, get the Top Waterline by entering TW as the
line name, without storing the line first.

2. If the line was kept, you can select it from a list of lines kept during the 
current session by clicking the drop-down arrow beside the edit field. To 
hide the drop-down list, click on a point outside it.

3. If the line was saved, you can locate and select it with the standard file-
selection dialog. Click on the button with the question mark.

Misc

Hitting the [Spacebar] repeats the previous command.

File > Open recent displays a list of recently used data files. To select one or 
more, highlight them and then click outside the box. 
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4. Managing the graphics screen

Clearing and redrawing

To clear the graphics screen, select Display > Clear.
 
To return to default scaling, in which all parts of the model are visible, select 
Display > View area reset. After zooming in or out, clicking the left and right 
mouse buttons at the same time returns the screen to the default scaling.

To remove the last item added to the display, hit <Esc>. This may be done 
repeatedly, until only the first item placed on a cleared screen remains.

Automatic scaling

The graphics window automatically scales itself to accommodate what you put
on it. It retains that scaling until you either change it (see below), select 
Display > View area reset, or call for a display that requires a different type of 
scaling. Display categories that imply different types of scaling are:

3D (including orthogonal) rotations
2D true views, airfoil profiles, etc.
Graphs of curvature, area distribution, etc. 

User scaling

You can override automatic scaling either by setting the START FS and STOP FS 
or START BL and STOP BL (select Settings > Constants) before calling for the 
object, or by using the Zoom in or Zoom out options in the Display submenu.

After zooming in or out, clicking the left and right mouse buttons at the same 
time returns the screen to the default scaling.
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Axes and grids

Orthogonal (ie, side-, top- and front-view) graphics displays can include ruled 
vertical and horizontal axes and labels to clarify what the axes represent, as 
well as a grid of dotted lines to make positional relationships clearer. When 
you turn the grid on, the axes are automatically turned on as well; but the 
axes may remain on when the grid is off. To turn axes and grid lines on or off, 
use Settings > Options.

Axes and grid lines do not appear in perspective views. 

Locating points

The world coordinates of the cursor are continually displayed on the status 
bar. If a side or top view of a model is displayed, the status bar displays three-
dimensional coordinates of the indicated point on the nearer surface when the
cursor is over the model.

The accuracy of displayed cursor coordinates is a function of the scale of the 
screen image and the pixel size. For greater resolution, use Display > Zoom in to
enlarge the area you are looking at. When something is displayed at actual 
size, the precision on a 1024x768 screen is about .01 inch (.25 mm). 
Coordinates taken from perspective displays are meaningless.

To save the coordinates of a point from an orthogonal view, select 

Display > Locate

A crosshair appears. Move the crosshair to the desired point and click the left 
mouse button. Then select

File > Keep temporarily

and assign a name to the selected point.

To erase the crosshairs, either hit <Esc> or click the left mouse button.
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Measurements normally increase upward and to the right. Therefore, the 
"correct" orientations for orthogonal views are Port for elevations, Top for plan 
views, and Rear for what are usually called "front views."

Measuring distances

To measure the scaled distance between two points on the screen, select

Display > Ruler

Move the crosshairs to a point and click the left mouse button. The point is 
marked with a cross. Henceforth the scale distance between the crosshair 
location and the marked point is displayed, along with the coordinates of the 
crosshair, in the upper left hand corner of the screen

A second click of the left mouse button cancels the operation.

Measuring angles

To measure the angle of a line in the display, select

Display > Angle

Move the cursor to the point at which the angle is to be measured. 
Coordinates of the cursor are continuously displayed on the status line. Click 
the left mouse button. Now drag out a line and rotate it to the desired 
position. The angle of the line to the vertical axis is continually displayed. To 
end the procedure, click the left mouse button a second time.

Zooming in and out

To zoom in on a portion of an image, select 

Display > Zoom in
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Move the cursor to any corner of the area that you want to enlarge. Hold down
the left mouse button while dragging the mouse toward the opposite corner. 
When the rectangle outlines the desired area, release the mouse button. If you
wish to abort the zoom procedure before rescaling the screen, hit <Esc> 
before releasing the mouse button.

To zoom back from an image, select

Display > Zoom out

The size of the display window is doubled, but the aim point remains 
unchanged.

Moving the image

To change the position of the image on the screen (“pan”), click at any point in
the drawing area with the right mouse button. Holding the button down, drag 
the image.

Line colors

The color of most types of body lines can be changed between successive 
commands. Select

Display > Colors

The change will not be visible until the next line is drawn.

Displaying filed lines

You can add filed coordinate sets to an existing display. Files must be in 
either “plain”  (that is, lists of points with two or three coordinates each, 
separated by linefeeds), LOFTSMAN patch (.PCH), or Panair format. 
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Select

File  > Import object

and select the file. You can also enter the name of a line that has been stored 
with the Keep option.

Graphics coordinates

The point of view from which a model is seen is controlled by two angles, an 
azimuth and an inclination.  To understand how these work, imagine the 
model suspended at the center of a large transparent sphere marked, like a 
globe, with lines of latitude and longitude. The viewer lies on the surface of 
the sphere looking inward, with his head normally toward the north pole. 
Azimuth, or X rotation, corresponds to longitude, that is, to east-west motion 
of the viewer. Inclination, or Y rotation, corresponds to latitude, that is, to 
north-south motion. A third value, called the twist or Z rotation, rotates the 
image on the screen without changing the location of the viewer; the effect is 
as if the viewer, while continuing to lie on the surface of the globe, rotated 
about his own nose. The origin of the azimuth/inclination coordinate system 
is at the intersection of the equator and the negative extension of the X axis. 
When azimuth and inclination are zero, the airplane is seen from head on.

Setting rotation angles

Move the mouse with the left button depressed to rotate the model. The 
mouse performs only X and Y rotations -- that is, the gravity vector of the 
model always points downward -- unless both the right and left buttons are 
held, in which case it produces only Z rotations and responds only to 
horizontal movement.

To record a model position in order to be able to return to it later or to place 
another item in the same position, select

Display > Rotations > Slew
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Rotate the model as usual. When you release the button(s), a dialog box 
appears displaying the present rotations.

The default rotations are X=40, Y=-160, Z=0.

The rate of rotation is sufficient to allow the model to make more than one 
complete revolution when the mouse is moved the full length or height of the 
screen.

To obtain orthogonal views, select

Display > Rotations > Orthogonal

You can then choose Top, Bottom, Port, Starboard, Front or Rear views.

Alternatively and much more conveniently, orthogonal views may be selected 
by means of the x/X, y/Y and z/Z keys, which produce front/rear, 
port/starboard, and top/bottom views respectively. In each case, the 
unshifted key produces the view as seen from the positive toward the negative 
end of the corresponding axis.

Other options in the Rotations submenu are Default, which restores the 
starting values, and Previous, which restores the last non-orthogonal rotation 
you selected.

Two default rotations can also be obtained by hitting the upper- or lower-case 
P keys. In this case P stands for “perspective,” not “previous.”

Setting the viewpoint

An alternative method of specifying the viewer's position is with three 
coordinates representing the offsets, in the X, Y, and Z axes, of the viewer's 
eye from the origin of the model coordinate system. Since perspective 
convergence is not used, the absolute values of these coordinates, which 
LOFTSMAN normalizes, are not important; what matters is their relative sizes.
Thus, an eye position entered as -10,4,-3 would be reported as -1, .4,-.3, and 
would show the model as it would be seen from ten units in front of it, four 
units to its right, and three units below it. An eye position of -20,8,-6 would 
produce the same image. 

To directly set the viewer's location in the object's coordinate system, select
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Display > Rotations > Viewpoint 

The entire image can be rotated by setting the twist. A positive value of twist 
turns the image in a counterclockwise direction. It may be necessary to set 
the eye position, inspect the result, and then set the twist with a second call 
to Display > Rotations > Viewpoint.
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5. Settings

Station and coordinate spacing

The interval between body stations is called the STEP. The spacing of 
coordinates along a frame is called the INCREMENT. To set them, select

Setting > Constants

The initial default for STEP is 1.0 inch or 25 mm. That for INCREMENT is 0.1 in.
or 2.5 mm. 

Coordinate spacing on cross-sections normal to the longitudinal axis is 
optimized to provide the maximum detail. On oblique sections, however, no 
such optimization occurs, and you may need to set the INCREMENT to a small 
value to provide satisfactory smoothness and detail, especially on bodies with 
relatively flat bottoms or tops.

In general, if you set too small a value for the INCREMENT LOFTSMAN will warn
you before executing a Print or List command, or even displaying an object, 
because listings would be inconveniently long, and screen displays would be 
slow to generate and their precision would outstrip the resolution of the 
display. Save commands, on the other hand, will work with arbitrarily small 
INCREMENTs, limited only by the capacity of your storage media to contain the 
resulting file. A file containing a cross-section of 100-inch circumference with 
an INCREMENT of .0001 will be about three megabytes in size.

Range of stations or buttlines

Actions can be limited to a range of stations on a body or wing. Select

Settings > Constants
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and set the START FS and STOP FS  or START BL and STOP BL to the desired 
values.

LOFTSMAN initially sets these values to coincide with the limits of the bodies 
or wing loaded when you first invoke the program. Loading a new data file 
resets the range limits.

Number formats, precision and tolerance

You can specify both the field length and the number of digits to the right of 
the decimal point in saved, listed or printed output. You can also set the
TOLERANCE used internally for certain converging operations, such as finding 
intersections. Select

Settings > Constants

The default precision is three places for millimeters, four places for inches, 
and five places for meters. The default field length is 10 characters. The 
default TOLERANCE is 0.0001 inch,  0.0025 mm, or 0.0001 meter. Note that 
the TOLERANCE for objects scaled in meters is relatively larger than for those 
scaled in smaller units.

Precision in LFT, WI and other data files, including nondimensional items like 
K factors, should be consistent with the TOLERANCE in use. Thus, if you have 
set the TOLERANCE at 0.000001 for a circular body dimensioned in meters, its 
cross-sectional K factors should be given as 0.707107, not just 0.7071.

Other default variables

Several other settings with special meanings are listed in the Settings > 
Constants dialog box. They are discussed elsewhere in this section and in 
Section Two. 
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Other Options

Under Settings > Options, the following selections are available:

Show axes Scaled axes are displayed in orthogonal views.

Show grid A grid of fine lines is displayed in orthogonal views.

Mark points Points defining lines are marked.

Load data files on startup When starting, LOFTSMAN reloads the data files 
used during the last session.

Auto-correct profiles SD files are adjusted to place the leading and trailing 
edges (or midpoint of a finite-thickness trailing edge) at 0.0,0.0 and 1.0,0.0.

Use alternate section calc An alternative method of calculating body cross-
sections is used. On rare occasions it may work better than the default 
method.

Opaque meshes Meshes are shown as opaque surfaces rather than a 
wireframe.

Number patches When patches are compiled into a CMARC input 
file, they are given sequential numbers.

Wing hi/lo lines The loci of highest and lowest points on the wing
surface are shown.

Display file paths Dialogs include directory paths in file names.

Preserve breaks in wing patches When a ruled wing is meshed, spanwise 
section spacing is adjusted to preserve planform breaks.

Verbose Auto-mesh Certain messages and queries appear during the 
automatic meshing procedure. This option should be used at least during 
initial creation of a paneled model.

Patch format Patches may be saved in CMARC or VSAERO format.
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6. Editing objects

Editing body dimensions and position

You can move the model about with respect to the coordinate system or 
distort it along any of the three orthogonal axes. 

To move the body, select Edit > Body size/position and enter the displacement(s) 
for the datum point. Note that to move the body downward, you move the 
datum upward, that is, in a positive direction along the Z axis.
 
To alter the body shape by a fixed factor along any of the three orthogonal 
axes, enter the multiplying factor for that axis. A factor of 1.0 leaves the shape
unchanged in that axis. LOFTSMAN will not accept scaling factors of zero or 
less. To scale the entire model, enter the same factor for all three dimensions.
 
Points defining moldline frames may be rotated about the orthogonal axes. 
When a B-type body is rotated about the X axis, it is converted into an 
asymmetrical A-type body. Rotations about the X axis require replacing all 
moldlines except K Factor control lines with filed segments.

After a body's dimensions have been edited, that new version becomes the 
current data file and can be used for other operations, such as meshing. 
Unless it is saved (File > Save > Save current data files), however, it will 
disappear when the program terminates or if data files are re-loaded (File > List
current data files > OK).

The [Spacebar] can be used to save the primary wing and body files after 
editing.



3.24

Editing wing dimensions

Wings may be shifted with respect to the datum as bodies can, and can also 
be scaled in span or chord or both. Select Edit > Wing size/position. Factors of 
zero or less are ignored.

Wings can also be mirrored about the buttline or waterline plane. Check the 
Mirror box and enter the location of the plane about which the surface will be 
mirrored. Mirroring about the WL plane is intended for vertical surfaces; it 
does not truly mirror generally horizontal surfaces, because the airfoils 
defining the wing breaks are not inverted.

Wings may also be rotated. The center of rotation is the inner end of the axis 
line. Rotation about the X axis changes the dihedral angle and the cants of all 
break sections, including that at the root. If the root is on the plane of 
symmetry, the WI file should be edited to return the cant of the root rib to 
zero.

Rotations about the Y and Z axes have affect only the angles of incidence of 
breaks, and only for generally horizontal or generally vertical surfaces, 
respectively.

After a wing's dimensions have been edited, that new version becomes the 
current data file and can be use for other operations, such as meshing. Unless
it is saved (File > Save > Save current data files), however, it will disappear when 
the program terminates or if data files are re-loaded (File > List current data files 
> OK).

Changing units

Select

Edit > Change units

Select the desired unit and check Convert data.

All data files currently loaded are converted to the new unit. To make the 
change permanent, you must save the files as a separate step.
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Interactive translating  and scaling

A body or wing may be repositioned or rescaled graphically. The object to be 
modified is the latest one added to the display.

Adjustments can be made only in an orthogonal view. To move a body or wing,
first select the appropriate view with the X, Y or Z key; place the cursor over it,
hold down the [Ctrl] key and the left mouse button, and drag its outline 
with the mouse. To rescale, hold down the [Ctrl] key and the right mouse 
button and move the cursor to the right to increase size and to the left to 
reduce it. (In resizing, vertical movement of the cursor has no effect.) When 
you release the mouse button, the dimension/position dialog appears with the
shifts or scaling changes shown. These can be edited and accepted or 
discarded in the usual way.

The modified body continues to be the currently active body, but until you 
save it it has no permanent existence. You must explicitly save the modified 
geometry (File > Save > Save current data files) under either the same name or a 
new one. If you do not do so, the next time you load it into LOFTSMAN it will 
still be in its original form; the changes will have been lost.

Editing body lines

Moldlines can be edited using a graphical procedure, and new models can be 
created by modifying existing ones rather than by creating a new text data file.
In addition to the generic prototype files provided, LOFTSMAN will create
bodies of revolution of arbitrary numbers of strips to use as starting points.

If several bodies are currently loaded when you begin to edit an existing body, 
the first loaded is the one edited. Changes may be saved either during editing 
or after, and either with the current name of the body file or with another 
name. Changes to a current body are retained after you leave the editing 
procedure even if you do not save the data file; but they are lost if you leave 
LOFTSMAN without saving them, or if you discard the body to load another.

Before you create a new body with the graphic editing procedure (as opposed 
to editing an existing one), you must discard currently loaded bodies.
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What body parts can be edited

Only moldlines can be directly edited; cross-sections are changed by changing
the associated moldlines. You can edit only one moldline at a time. To start 
out or to edit a different moldline than the one you are currently editing, 
select

 Display > Select line

Moldlines are identified by their abbreviated names, eg BW, WW, TK, etc., for 
B-type bodies, and M1B, M1W, C2W, K3, and so on for A-type bodies.

When you edit a moldline, you are changing the parameters of its segment 
frames. You can add or delete frames, change curvatures, change straight 
lines into frames and frames into straight lines, insert filed segments, and so 
on. You can also move segment frames around quite freely, so that it is easy 
to make your way from one shape to another. But you cannot edit a moldline 
that is defined by interpolation between two others.

The four broad classes of editable items are segments, tangents, corners and 
lines. In the context of the menu options, a segment is a portion of a line 
controlled by a single segment frame, and terminating at each end in a 
segment break. (This terminology is more fully explained in the portion of 
Section Two of this manual dealing with body lofting concepts.)

A tangent is a line between two segment frame corners. It touches the surface 
of the body at at least one point, namely the break point between two 
neighboring segments. Usually tangent lines are straight from the corner of 
one segment frame to the corner of another; but they do not have to be.

A corner is the point of inflection of a segment frame.

A line is any complete moldline or control line.

Display controls

Display > Zoom in and Display > Zoom out behave in the same way as elsewhere 
in the program.
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Display > Stretch Y increases only the vertical dimensions, so that the contours 
of shallow curves are more apparent. Holding the Shift key reverses the 
operation.

Display > Reset redraws the display with the original scaling.

Display > Hide lines allows you to simplify the editing display by selecting which
mold or control lines will be visible.

Tracking curvature and section shape

The variation of radius of curvature of any moldline with fuselage station (that
is, the second derivative of the curvature of the moldline) and/or of the shape 
of the cross-section at any station may be tracked simultaneously with the 
editing of the moldline. Select Display > Radii on/off or Display > Section on/off. 
The section or graph appears superimposed on the editing profile and varies 
as you modify the moldline.

The radii display is helpful for smoothing moldlines. They should be free of 
kinks, particularly in the forward portion. The Tangent > Rock, Tangent > Pivot 
and Segment > Curvature procedures are particularly useful for smoothing 
segment breaks.

Editing an existing body

To edit an existing body, load the body (File > Current data or File > Open). If 
several bodies are loaded concurrently, only the first one in the list is edited.

Select Edit > Frames, and identify the moldline you want to edit by its standard
abbreviation. LOFTSMAN displays the appropriate view with the moldline you 
want to edit highlighted and the segment frames shown.
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Creating a new body

First, discard currently loaded files (File > Discard current data). Then select Edit 
> New body. Pick the file type, that is, A-type or B-type, and enter the nose and
tail stations. If you selected A-type, enter the number of strips; otherwise, 
ignore the entry in that box.

LOFTSMAN displays a body of revolution. Several initial shapes are available 
for B-type bodies; the default for A-type bodies resembles an elongated 
football. Each moldline consists of one or two curved segment.

One option for a B-type body is to define its profile as an airfoil from an 
existing file. LOFTSMAN places the scaled points defining the profile in a new 
file having the airfoil name and a .SEG extension. Filed segments cannot be 
edited, but other moldlines (WW, BK, TK and POS) can.

Creating a model from given cross-sections

If a geometry is available in the form of a series of cross-sections defined by 
point lists, it may be possible to convert it into an LFT file with reasonable 
accuracy, provided that the cross-sections are B-type -- that is, formed of 
upper and lower conic segments inscribed within a rectangle -- and the body 
does not have "compound" elements, such as scoops, canopies, cowl cheeks, 
etc.

The cross sections must be filed in the format LOFTSMAN uses to store 
multiple cross-sections, that is, 3D coordinate lists beginning at bottom 
center and progressing starboard side first. Section lists should be separated 
by one or more linefeeds. The file name should be of the form name.CS.

Beginning with a blank screen, import the CS file (File  > Import object). The 
cross sections are displayed.

Select

Misc > Lines and points > Get frames

LOFTSMAN finds the locations of the standard moldlines (BW, WW, TW, MB, 
POS) and K factors of the upper and lower segments. For each moldline, it 
stores a list of the values at the stations of the given cross-sections and then 
creates a body geometry in which the moldlines are stored as filed segments. 
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The moldlines and the derived cross-sections appear on the screen  
superimposed on the given cross-section for comparison.

If the match to the original sections is satisfactory, save the body geometry.

If you wish, you can now replace the filed segments with conic approximations
by editing them. LOFTSMAN displays each filed line as an "underlayer" 
template which you can approximate with one or more conics.

Selecting the segment or tangent to edit

After selecting an editing operation involving a segment or tangent, eg Segment
> Delete, move the mouse horizontally. As the cursor moves, segment frames 
or tangents, depending which category you have selected, are highlighted. 
Click the left mouse button to select the highlighted item.

Adding a segment

To add a segment, LOFTSMAN splits an existing one, preserving the existing 
contour of the moldline. Select Segment > Add and, if the line consists of more 
than one segment, identify the segment to split.

Deleting a segment

To delete a segment LOFTSMAN combines it with the segment ahead of it, 
unless the selected segment is the foremost segment, in which case it is 
combined with its aft neighbor. The new segment frame corner is the point of 
intersection of the projected outer arms of the two segments being combined. 
Select Segment > Delete and identify the segment to be deleted.

If there is only one segment in a moldline, you cannot delete it.
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Adding an S Curved Transition

When a moldline segment requires a curve that reverses direction in an S 
shape, for example in a cusped tail cone, you can first any curve or straight 
line in its place. Then select Segment > S curve and click on the segment that 
is to be replaced with an S curve. 

There are a number of conditions under which this operation cannot be 
performed. The most general requirement is that the frame legs preceding and
following the segment to be replaced, if extended to the point of their 
intersection, not intersect between the ends of the segment to be replaced. 

Changing the curvature of a segment

Identify a segment.  The portion of the moldline in that segment is highlighted.
Place the mouse cursor on the moldline and hold down the left button while 
moving the mouse vertically to change the curvature. 

You then have the option of accepting the new curvature, entering a different 
value, or canceling the whole operation.

Getting coordinates

To view the coordinates of the end and corner points of a moldline segment, 
the curvature, and the slopes of the frame arms, select Segment > Numbers and
identify a segment.

Moving tangents

Several options are provided for moving tangents and tangent points. Select 
Tangent, then one of the following choices. In each case, move the mouse to 
highlight the tangent point you want to move; then press the left mouse 
button to "grab" the point.
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Drag Moves the tangent point to any new location, under certain 
logical constraints; for example, the point cannot be moved past the frame 
corners of neighboring segments. The moldline contour changes. To change 
the station of the nose or tail, use Body > Move end (see Moving the ends of the
body below).

Rock Moves the tangent point along the moldline while preserving 
as closely as possible the original shape of the line. The slope of the tangent 
line changes. The action is similar to that of rocking a straightedge on the 
surface.

Pivot The tangent point remains in the same location but the slope 
of the tangent changes, as does the contour of the moldline.

Slide The slope of the tangent line remains unchanged, but the line 
moves inward or outward. The contour of the moldline changes.

Align The tangent point is relocated to place it on a straight line 
between the corners of the neighboring segment frames. The station of the 
point remains unchanged. This step is usually required to ensure surface 
continuity after corners have been moved.

Copy point The Y coordinate (either BL or WL) of the currently selected 
tangent point (the source) is copied to another moldline (the destination), 
provided that a tangent point exists on the destination whose FS is within a 
specified tolerance of that of the source. The tolerance can be set under 
Settings > Constants in the main menu. The most usual function of this option 
is to re-align two or more originally coinciding points after one of them has 
been moved.

Blend The coordinates and slope of either the fore or aft end of the 
selected moldline are forced to match those of a second body at the same 
station. The usual application is to ensure a seamless joint between two 
bodies, such as a canopy and a fuselage. When prompted, give the name of 
the body file and identify the moldline that you want to match the present 
moldline to.
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Modifying frame corners

Select Corner, then one of the following choices. To Add, Remove or Align, 
simply select the segment to be modified; to Drag, move the mouse cursor to 
the corner, then press and hold the left mouse button while dragging the 
corner to a new location.

Add Changes a straight segment, which has no corner and no 
curvature, into one with a corner and a curvature. The initial corner location 
and the curvature are arbitrary and are intended to be changed in subsequent
operations.

Remove Changes a curved segment into a straight one by removing its 
curvature and corner coordinates. (Though they look the same, a straight 
segment is preferable to a curved segment with a curvature of 0.5, or a curved
segment with the corner on a straight line between the two ends.)

Align Places the segment corner in order to obtain straight 
alignment of the tangent at either the fore or aft end of the segment, or both. 
The K Factor of the segment is not changed, and so the contour changes when
the point moves.

Drag Moves the corner point to any new location under certain 
logical constraints; for example, the point cannot be moved past the frame 
ends. The moldline contour changes.

Moving an entire moldline

Select Line > Move. Move the mouse cursor to any point on the current line 
and press the left button to grab the line. Vertical movement of the mouse 
moves the entire line. Lines cannot be moved horizontally, because the 
foremost and aftmost points of all moldlines must always be at the same 
stations.
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Scaling a moldline

Select Line > Scale. Move the mouse cursor to any point on the current line 
and press the left button to grab the line. Vertical movement of the mouse 
moves the entire line closer to or farther from a straight line joining its ends. 
The character of the line is preserved.

Using stored curves as segments

Any moldline or moldline segment can be replaced by a set of previously filed 
coordinates. Select Segment > Filed points. Select the segment to be replaced. 
Enter the name of the file containing the coordinates of the filed line. There 
must be at least five points in the line.

LOFTSMAN scales the stored line to the length of the segment and places its 
foremost point at the fore end of the segment. If the fore end of the following 
segment (if any) does not coincide with the aft end of the stored line, it is 
moved. 

Using stored curves as guides

A stored segment can be used as a template or guide for building up one or 
more conic segments. Select Segment > Template. Select the segment you want 
to modify. After you enter the name of the file containing the line you want to 
use as a template, LOFTSMAN positions the stored line just as if you were 
incorporating it into the moldline. In this case, however, the stored line is 
merely superimposed on the moldline to provide you with a guide for 
manipulating the segment frame or frames.

When using a stored line as a template, you must begin by inserting it in a 
single segment, but you can then create as many segments as you like to 
match it.

A stored line or group of lines, previously filed as a list of coordinates, may 
also be displayed as a background for the editing operation in order to allow 
you to match one body to another (eg the inner surface of a scoop to the outer)
or to build a body meeting certain constraints (eg a cowling around an 
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engine). Select Display > Underlayer and give the name of the file to be used as a
background. If a section of the current body is already being displayed, 
LOFTSMAN assumes that you are trying to match it to a stored section and 
draws the stored line with the same position and scale as the already 
displayed section. Otherwise, the position and scale of the stored line match 
those of the complete body.

Duplicating existing geometries

It is sometimes desirable to create a LOFTSMAN loft for an existing aircraft or 
hull for which only three-views, photographs, or napkin sketches are 
available. This can be done with reasonable (but not absolute) accuracy by 
importing orthogonal views of the geometry into LOFTSMAN’s line editing 
screen as an underlayer and building up conic frames on top of them. Views 
must have been stored as bitmaps (BMP file extension). These may be of any 
size, resolution or number of colors.

Empty the body list and select Edit > New body. Assign appropriate coordinates
to the nose and tail points if you know them; otherwise, assign arbitrary ones 
and rescale later. Pick a moldline with which to begin.

Now select Display > Underlayer and identify the BMP file to be used. The 
bitmap image will appear with the initial generic conic frames drawn over it.

The first step is to align the conic frames with the underlayer and establish a 
coordinate system. To do this, drag the underlayer by moving the mouse while
holding the right button down, and change its size (independently of the 
overlying conic frames) by pressing the + and – keys on the numeric keypad. 
If the keyboard does not have a numeric keypad, bB (bigger) and sS (smaller) 
may be used instead. When the underlayer and the conic frames are properly 
aligned, hit <Enter> to make this the default position. 

You can change the scale of the conic frames by selecting Display  > Match scale
to bitmap. Holding the right mouse button, move the bitmap to make one end 
of the model coincide with it; then left-click on the other end of the bitmap 
image.

Note that the bitmap itself has no inherent scale. The axes and scales 
displayed are those of the conic frames. 
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If the axis of the bitmap image is not perfectly horizontal, you can adjust it 
after you have made the loft by pitching or yawing the entire loft and by 
scaling its dimensions (Edit > Body dimensions in the main menu).

Generate the loft lines in the usual way, with the underlying image as a guide 
for tangent points, angles and curvatures. 

Copying one moldline to another

Select Line > Copy to or Line > Copy mirrored to and enter  the name of the 
destination line. A mirrored line has the signs of its Y or Z dimensions 
reversed. In the case of MB dimensions in a B-type body, the line is mirrored 
across the plane of symmetry.

Making moldlines coincide at tangent points

To copy the offset of a tangent point from one moldline to another, select 
Tangent > Copy point, identify a tangent point, and then select the destination 
moldline from the list presented. LOFTSMAN searches for a tangent point on 
the destination moldline whose FS is within the TOLERANCE of that of the 
selected point; if it finds one, it copies the corresponding point.

This procedure is principally intended to make the ends of moldlines coincide 
after editing.
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Blending moldlines in compound bodies

To blend one element of a compound body, such as a canopy, into another, 
such as a turtledeck, corresponding moldlines, including K Factor lines, must 
match in location and slope at the blend station. Begin by lofting a canopy (for
example) that is approximately the right size and shape. Display the line to be 
edited in the moldline editor and then select

Tangent > Blend

The blend can occur only at the fore or aft end of the canopy, but at any point 
on the body. Move the cursor to the end of the moldline at which you want the
blend to occur and click the left mouse button. Then pick the names of the 
body file and the moldline on that body that you want to blend with. The 
canopy file is automatically modified to blend with the body.

Moving the ends of a body

Select Body > Move end. Drag either end to a new location. All other moldlines 
will be modified accordingly.

This procedure should be used with caution. It will not work properly if any 
moldline has a filed segment at the end that you want to move. Adjacent 
corners and tangents may need to be adjusted after an end has been moved. 
Finally, the Undo command cannot be used to reverse a Move end operation.

Scaling and translating

Select Body > Dimensions. Scaling and datum-shifting operations are identical 
to those performed by the Edit > Body size/position selection in the main menu.

Undoing changes
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To undo the most recent change, select Line > Undo last.

Saving

To save the current state of the moldlines, select Body > Save data. You can 
save either to the current file or to a different one. It’s a good idea to save 
frequently during the editing process.

A B-type moldline set can also be saved as an A-type file. Select Body > Save as
A-type. The A-type version of the model will be identical in shape to the 
original, but the file format gives greater latitude in adjusting shape by 
removing the constraint of rectangular cross-section frames.

Quitting the editing procedure

When you have finished editing, select Display > Done to return to the main 
menu. Remember that if you have not saved changes while in the editing 
menu, the changes that you have made will be lost if you discard the first of 
the current data files, or if you quit LOFTSMAN without saving.



3.38

7. Body lines

Moldlines

To display one or more moldlines or control lines, select

Body > Lines

and select the line or lines to be shown. 

Moldlines may be saved singly or all at once. By default, the point spacing is 
at equal intervals of the STEP. If you check Bunch MLs in the Save form, 
however, the points are spaced in inverse proportion to the local curvature of 
the moldline. The total number of points saved is the same as if you were 
using equal spacing. Proportional spacing helps to preserve accuracy in areas 
of large curvature without unduly inflating the total number of points saved. 

The degree to which spacing is influenced by curvature is controlled by the 
bunching parameter, which may be set in the Settings > Constants dialog.

Assessing continuity between conics

In order to provide  good
streamlines from nose to tail,
the radii of longitudinal
curvature should match where
adjoining conic segments
meet. It is also desirable that a
graph of the variation of radius
of curvature along a line form
not only a continuous but also
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a smooth profile. LOFTSMAN provides graphs of moldline curvature to assist 
you in editing the data set.

Select

Body > Radii

and pick a line. (To see all lines together, pick ALL.) LOFTSMAN draws a 
graph of curvature for the selected line or lines. Color codes identify the 
moldlines of B-type bodies; dotted lines crossing the horizontal axis indicate 
segment breaks. No distinction is made between convex and concave 
curvatures. The base line of the graph represents no curvature, ie a straight 
line.

The farther a point on a graph is from the baseline, the more rapid is the 
curvature of the moldline at that station. The numbers at the left side of the 
screen (10, 100, 1000) represent a nondimensional logarithmic gauge of 
radius of curvature as related to body length. The smaller the radius, the 
sharper the curve; hence the smaller numbers are farther from the baseline.

To inspect the transition between two bodies, such as a canopy and a 
turtledeck, first load the data set for the longer body and position it on the 
screen to allow space for the other. Display its radii, then load the second 
body and display its radii without clearing the screen. 

The Radii display applies only to the first named data set in a compound body.

You can zoom in on a portion of the radii display to examine a transition more
closely. If you are interested in knowing the actual radius of curvature at any 
point, however, you can get it by selecting Body >Information  > Section data.

Finding the best conic fit to a given curve

Given a certain frame, to obtain the K Factor of the conic curve that most 
closely approaches one or more given points select

Misc > K Factor

LOFTSMAN prompts for the coordinates of the frame, and then for up to 10 
points along the desired conic. Hit Calc K to recompute the K Factor after you 
have added as many points as you wish.
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Once a K Factor has been computed, you can enter any X value within the 
segment and obtain the corresponding Y coordinate.

Because points near the ends of a conic would otherwise have a 
disproportionate influence upon its shape, the points you enter are 
exponentially weighted, with the ones near the middle having more influence 
and the ones near the ends progressively less. 

Normal sections

Normal sections -- that is, ones at a right angle to the X axis -- may be 
computed singly, in groups at specified stations, or as “slices,” that is, at 
stations spaced in various ways. The “slices” option is useful for getting a 
sense of the shape of the body as a three-dimensional solid.

Normal cross-sections lie in the YZ plane. Coordinate lists begin at the bottom
centerline and run up the starboard side to the top centerline. First the BL
coordinate increases by the requested INCREMENT until the slope of the 
contour reaches -45 degrees; then the WL increases by the INCREMENT until 
the slope reaches 45 degrees, whereupon the BL begins to decrease by the 
INCREMENT. Save commands can be executed with arbitrarily small values of 
INCREMENT, limited only by available disk space, but LOFTSMAN warns you 
before displaying the section and before executing a Print or List command if 
the requested INCREMENT is very small.

To obtain a single cross-section or several specified ones, select 

Body >Normal section

Click on the Selected station(s) button and enter one or more stations. If you 
enter several stations, they should be separated by commas but no spaces.

To obtain a series of regularly spaced slices, select a spacing type in the Slices
group.

Show frames causes the section frames to be displayed along with the cross-
sections themselves.
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Janus refers to a special display of cross-sections, commonly used in marine 
lofting, in which front views back to the midpoint of the body are placed on 
one side of the plane of symmetry and rear views on the other. In this case, 
the spacing of sections is determined by LOFTSMAN based on the Count, 
which is the total number of sections displayed.

Outline components separately provides the outline of each element of a 
compound body, not just the so-called "outer hull."

In addition to displaying sections at regular intervals or at specified stations, 
you can display any B-type section defined by parameters entered at the 
keyboard. Click User-defined section. The section that you define is given an 
FS of 0.0; this will affect its position on (or off) the screen if you do not clear 
the screen before displaying the user-defined section.

Alternative method of section calculation

LOFTSMAN provides two methods for computing cross-sections of compound 
bodies. The faster one, which is the default, has three disadvantages: it does 
not locate points of intersection between bodies precisely; it inserts spurious 
lines between bodies that are not physically connected, or across certain 
kinds of valleys; and it fails to locate surface points that are hidden in side 
and top views. Nevertheless, it is quite satisfactory for most purposes.

If it misbehaves you can select the more exact method by checking Use 
alternate sections calc either in the Normal Sections dialog or under Settings > 
Options. The latter selects the slower method until you change it or quit 
LOFTSMAN; the former affects only the next section or set of slices calculated.

Oblique sections

Oblique cross-sections are cuts through the body by planes normal to the XY 
(Waterline) plane or the XZ (Buttline) plane, but inclined with respect to the 
XZ (Longitudinal station) plane. Sections normal to the Waterline plane rotate 
about the Z axis (like the door of a room); those normal to the XZ plane rotate 
about the Y axis (like the lid of a box).



3.42

Oblique cross-sections are specified by the three coordinates of some anchor 
point in the plane of the section, and the angle of rotation about either the Y 
or the Z axis. The angle in question is the angle of the intersection of the 
oblique plane with the appropriate orthogonal plane, measured with respect to
an orthogonal axis. A normal cross-section would have an angle of 90 degrees,
but the Oblique section option will not compute it (unless it is a curved 
section -- see Curved oblique sections below); for sections tilted 90 degrees to 
the WL or BL planes, use Normal section(s) instead. Planes parallel to the 
waterline or buttline planes have rotations of zero. 

Oblique sections may be canted about the Y or the Z axis, but not about both 
at once, or about the X axis. 

Oblique sections can be displayed either in the body coordinate system or in a
true view. True views are dimensioned S,Y or S,Z, with S representing stations
along the section, and Y and Z representing Buttline and Waterline 
respectively. To get a true view, check the box captioned True.

Curved oblique sections

The transoms of sailing boats are often both raked and curved; that is, they 
represent the intersection of the hull surface with the surface of a cylinder 
whose axis is slanted with respect to the coordinate system.

To obtain such a section, click the Curved radio
button in the Section type box. For a curved
section of constant radius (ie, a portion of the
surface of a circular cylinder), enter the desired
radius as the X radius, and leave the Y radius
zero.  LOFTSMAN automatically converts a null Y
radius to the same value as the X radius. The
axis of the defining cylinder passes through the
anchor point, and the tilt is always about the Y
axis.

The defining surface may also optionally be that
of an elliptical cylindroid; in this case, enter both
X and Y radii for the defining ellipse. The X
radius is the one parallel to the X axis; the Y
radius is parallel to the Y axis.
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Selecting True with a curved oblique section yields the unrolled shape of the 
transom. For the greatest accuracy, the unrolled shape should be taken with 
a small value of the INCREMENT, such as .01 or .001 units.

Contours

Contour maps consist of groups of equally-spaced sections parallel to the XY 
or XZ plane. 

Select

Body > Contours

To produce a single contour line,
select Body > Oblique section with
an angle of zero.

The spacing of contours is
controlled by the STEP, while the 
INCREMENT controls the density of
points along the contour lines.

Skin or “wetted” area of bodies

Select

Body > Information  > Surf/vol

The surface area and volume of the current body in the current FS range are 
displayed, together with their respective centroids.
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Bulkhead area

Select

Body > Information  > Section data

Enter the desired FS. LOFTSMAN displays the conic parameters for the 
section, together with local slopes with respect to an orthogonal plane, and 
local radii of curvature. Perimeter and area are presented for both the primary
body and for the entire compound body, if any.

Ring frame area

Select

Body > Information  > Section data

Enter an FS and a ring width. The approximate area of the ring is reported.

Distribution of cross-sectional area

For a simple graph of cross-sectional area against FS, select

Body > Information  > Area distribution > Below waterline

In this case, area below a given WL is reported. To obtain the area distribution
of the complete body, enter a WL value above the top of the body.

Alternatively, the area distribution can be displayed as the profile of a body of 
revolution having the same area distribution as the current body. Select

Body > Information  > Area distribution > Body of revolution

Finally, you can include wings in order to assess the Whitcomb area ruling of 
the complete aircraft. Select

Body > Information  > Area distribution > Include wings
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The lower portion of the plot is the body area; flying surface cross-sectional 
areas are added above it. The inmost break in the .WI file should coincide as 
closely as possible with the fuselage surface, since the calculation neither 
deducts embedded areas nor supplies omitted ones.

Hull hydrostatics

Select

Body > Information  > Hydrostatics 

LOFTSMAN prompts for waterline and CG heights and for angles of heel and
pitch. You may omit values for some or all of these. Information on the
waterplane and the submerged portion of the hull, including displacement for 
salt and fresh water, wetted area, center of buoyancy, and fore, aft, and total
prismatic coefficients, is provided only if you give a waterline. Metacentric 
heights and righting arms are given only if you enter an angle of heel or pitch.

LOFTSMAN's output includes hull area and volume and their centroids, 
together with deck area. The deck area is the area enclosed by the second-to-
last tangent moldline, which under normal circumstances will be the gunwale 
or sheer line. It is a flat projected area, and does not take into account any 
curvature of the deck.

To obtain the waterline for a given displacement, enter the desired 
displacement alongside the button marked Find waterline for displacement = 
and then press the button. LOFTSMAN finds the waterline, if possible, within 
a tolerance ten times larger than the current default. Note that displacements 
are computed for fresh water, which weighs 62.2 lb/cu ft as opposed to 64 lb/
cu ft for salt water, and that the tons used are metric tons, which are equal to 
2,240 lbs.

To obtain the pitch angle for a given location of the longitudinal center of 
buoyancy (LCB), enter the desired LCB station alongside the button marked 
Find pitch angle for LCB = and then press the button. LOFTSMAN finds the 
pitch angle, if possible, within a tolerance a hundred times larger than the 
current default. Pitch angles are limited to 30 degrees.

Hull hydrostatics involves a large number of calculations, and can take a long 
time if carried out with small values of INCREMENT and STEP. These variables 
can be set to relatively large values, however, without significant loss of 
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precision, and LOFTSMAN automatically does so. In fact, these calculations 
have traditionally been carried out for only ten stations along the hull. You 
can enter any values you wish; the defaults are 1/80th of the overall length for 
longitudinal spacing, and 1/300th of the total length for vertical spacing.

Hull offsets, together with certain other data, may be written to a text file in 
the format required by MICHLET, a widely-used program for calculating wave 
resistance. All output for MICHLET is metric, except hull offsets and sinkage, 
which are presented as fractions of the total hull depth. Although MICHLET 
analyzes only the submerged portion of the hull, LOFTSMAN records offsets 
for the complete hull together with a value of sinkage that places the waterline
at the correct location. For the purpose of the MICHLET file fragment only, 
"draft" is defined as the vertical difference between the lowest and highest 
point on the hull, displacement is the total volume of the hull (not just the 
submerged portion), and length is overall length, not waterline length. 

To create the MICHLET hull data input file fragment, click on Michlet in the 
hydrostatics output display form and give a file name. The resulting file is 
automatically provided with the extension "MHD," for "Michlet Hull Data."  
The date and time of its creation is written at the top of the file for record-
keeping purposes; it should be removed when the fragment is incorporated 
into a MICHLET input file.  

Developable surfaces

Surfaces that can be generated by bending a flat sheet are called developable 
surfaces. They are commonly used in the construction of simple plywood-and-
fiberglass boat hulls. The shapes of the flat sheets determine the final shape 
of the boat. LOFTSMAN will produce patterns for certain developable surfaces,
provided that the surfaces are such that any normal (ie vertical) cross-section 
through them is a straight line.

A developed surface will be a strip between two moldlines. Typically, the 
moldlines for a simple hull will be the keel line (or bottom centerline), the 
chine or the line separating the bottom from the sides, and the sheer line or 
gunwale, which will be the joint between the sides and the deck. Although 
such a hull may not have a deck or may have only a partial deck, it is 
desirable for purposes of lofting to provide a deck. Thus, there will be three 
strips in a basic hull: bottom, side, and deck, numbered 1, 2, and 3.

Select
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Body > Pattern

The origin or 0,0 point is arbitrarily placed at the most forward point on the 
pattern. Patterns  may be plotted in scale or full size. By plotting on heavy 
paper, cutting out the patterns, and joining them with tape, the shape of a 
hull can be verified with a few minutes' work.

Patterns produced by LOFTSMAN may not be strictly developable, but may 
require some twisting of the flat material. Twisting is required when a given 
strip, viewed in cross-section, has different slopes at different points along the
length of the hull. Depending on the material, twisting may or may not be 
possible. The practicability of a design should be tested with a model made of 
a material comparable in stiffness to the one that will be used on the full-scale
hull.
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8. Wing lines

General appearance

To view a wing, select

Wing > Lines

LOFTSMAN displays the axis line, break ribs, leading and trailing edges, and 
spars, if any. The spars shown are those listed in the .WI file; their shear webs
are always vertical, and therefore do not necessarily reflect the true wing 
structure. They are intended only to give a general sense of the wing geometry.

Immediately to the right of the toolbar button captioned Primary wing lines is 
another captioned All wing lines. It displays the geometry of all currently 
loaded wing files, not just the primary one.

"Ribs" and "spars"

LOFTSMAN defines a rib as the line of intersection of the wing surface with 
any plane that intersects both the leading and trailing edges, and the upper 
and lower surfaces at all points between them. Any rib fitting this definition 
can be treated as though it were an airfoil section, and can be stored as 
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an .SD file – that is, a group of 59 normalized points with cosine spacing.  
Ribs can also be defined in a local coordinate system or as two-dimensional 
"true views."

Sections lying in planes that do not fit the strict definition of ribs are 
generically called "spars" and consist of arbitrary numbers of pairs of upper- 
and lower-surface points at buttline or waterline intervals selected by the 
user.

What LOFTSMAN calls spars may actually be ribs in the structural sense; for 
instance, LOFTSMAN would call the spanwise ribs of a strake or dorsal fin 
spars. The rib/spar distinction is just LOFTSMAN's shorthand for sections 
roughly parallel to the line of flight (ribs) and those roughly normal to it 
(spars).

Since "spars" lie more or less at right angles to "ribs," the specified rotations 
are different. All spars have Y and Z rotations specified, and X rotation 
unspecified.

In the following, the word "buttline" is used to mean something like "spanwise 
offset." In fact, for vertical surfaces, which are defined in LOFTSMAN as 
surfaces having a dihedral angle of more than 45 degrees, the correct term 
would be "waterline," not "buttline." In any case, dimensions are given in the 
coordinate system of the .WI file; that is, they are measured along the 
orthogonal axes, not along the wing axis line or some other wing reference 
system axis.

Defining sections

To obtain a rib or spar, you must define the plane in which it lies by supplying
five numbers. Three of them fix some point on the cutting plane, and the other
two fix the cants or rotations of the cutting plane in space.

Since the .WI file contains a reference spanwise axis line (defined by the axis 
points of successive breaks) and default panel rib angles, in most cases the 
user need only enter one number -- a buttline or, for vertical surfaces, a 
waterline -- to get a rib. It is usually necessary to supply more complete 
information to define a spar, since no meaningful spar information is included
in the .WI file. (The "spars" in the .WI file are for illustrative purposes only; 
they are not considered to be actual parts of the wing structure.)
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The anchor point

The first three numbers defining a cutting plane are the coordinates of some 
point in space that lies in the plane. This "anchor point" need not be inside 
the wing, though it usually is. In fact, unless there is some structural 
requirement that a certain point lie on a rib, it is convenient to define rib 
locations by the buttline or waterline at which the cutting plane intersects the
axis line. LOFTSMAN can then supply the two missing coordinates 
automatically. 

Cants

The remaining two numbers represent the angles or "cants" of the rib plane 
with respect to two of the three orthogonal reference planes. (Two cants fully 
fix a plane; it is not necessary to define a third. The three orthogonal reference
planes are the X plane or fuselage station plane; the Y or buttline plane, 
which is usually the plane of symmetry; and the Z or waterline plane. 
"Orthogonal" simply means that they are all at right angles to one another and
parallel or normal to the axes of the global coordinate system.)

Again, once you have specified a buttline LOFTSMAN uses the panel rib
angles from the data file to locate the rib unless you specify some other cants.

Rib angles are described in terms of the line of intersection the rib plane 
makes with one of the orthogonal reference planes. The angles are specified 
according to the conventions of a right-handed coordinate system. This means
that if you hold your right hand in hitchhiking position, the direction your 
fingers curl represents a positive rotation when your thumb is pointing in a 
positive (increasing) direction along any axis of rotation. The label (X, Y, or Z) 
given to an angle is the name of the axis about which the rotation occurs.

For example, if your thumb points aft along the airplane's centerline, your 
fingers curl in the direction of a left roll; that is, a counterclockwise rotation 
as seen by the pilot is positive, and a clockwise rotation is negative. Therefore,
a rib in a starboard wing that tilts outward, so that its upper edge is farther 
outboard than its lower edge, has a negative cant about the X axis.

Another example: suppose that the ribs of a swept fin are installed at a right 
angle to the spar, so that their leading edges are higher than their trailing 
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edges; since the Y axis increases to the pilot's right, if he pointed his right 
thumb in that direction his fingers would curl in the "pitch-up" direction. 
Therefore, the ribs have a positive rotation about the Y axis.

Defining ribs

Like normal sections and slices of bodies, ribs can be defined  singly or in 
groups. (Unlike normal sections, however, several ribs at arbitrary stations 
cannot be defined at once.)

Select

Wing  > Rib

You can now set up parameters for either a single rib or for a series of slices.

Single ribs

There are two ways to define a single rib. You can accept the default cants 
given as "Panel rib angles" in the .WI file, or you can specify a different set of 
cants.

At the top of the dialog box are three radio buttons marked Default, Canted, 
and Break.

Default provides the “panel rib angles” given in the .WI file as rib angles for 
the panel in which the rib is located.  You only need to supply a buttline (for 
generally horizontal surfaces) or waterline (for vertical ones) along the wing 
axis to locate the rib.

Canted allows you to select cants other than the default ones. You must enter
three coordinates for the anchor point, and two cants. If you enter a cant for 
an axis that does not require a cant (eg, a Y cant for ribs in a horizontal wing),
LOFTSMAN ignores it.

Only for canted ribs is it necessary to provide all the coordinates of an anchor 
point. For break and default ribs, you only need to give the BL (or, for a 
vertical panel, the WL) of the point at which the axis pierces the rib. 
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Break returns the break rib nearest to the station you specify, precisely as it 
is defined in the .WI file. You do not have to know the exact location of the 
break to get a break rib; just give a BL or WL that is closer to the break you 
are interested in than it is to any other break.

True view returns a set of 2D coordinates representing the true outline of the 
rib. Stations are measured from the leading edge, beginning with zero.

Profile returns a true view in normalized format; that is, the chord is 1.0 and 
surface offsets are given as fractions of chord. The rib is saved as an .SD file.

Reverse point order lists points lower-surface-first.  By default, LOFTSMAN 
orders points upper-surface-first, beginning and ending at the trailing edge.

First half only and Second half only return half of the rib, typically required 
for meshing one side of a vertical surface. The point order for wing ribs is 
highly likely to be upper-surface first, but for vertical surfaces the point order 
depends on how the rib cants are defined. To be sure that you are getting the 
desired set of points in the desired order, inspect them with List before saving 
or keeping them.

Multiple ribs

For multiple ribs, click on the Slices button. Step sets the spacing of slices. 
Closely-spaced opaque ribs create the appearance of a three-dimensional solid
object. To display ribs over only a portion of the span, set Start and Stop to 
the appropriate values – LOFTSMAN will know whether you mean BL or WL.

To reverse the order in which multiple ribs are listed, make the outboard rib 
the Start.

Other rib options

Points sets the number of stations along the chord line at which surface 
coordinates will be specified. The default is 30, and this spacing should be 
used unless there is a reason (such as a certain mesh density) to use another.
.SD files use 30 points along the abscissa. Ribs are always defined with full 
cosine spacing of points.

Show solid determines whether ribs appear opaque or transparent.
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Surface offset allows you to shift the rib outline inward or outward, for 
instance to allow for skin or mold thickness. A positive value shifts the 
surface inward.
Offsets for ribs do not take into account surface slope due to wing taper, and 
those for spars do not take into account slope in the buttline plane due to 
section shapes. These corrections, which are usually negligible, can be made 
by the user by slightly altering the specified offset thickness. Local surface 
slopes can be obtained by selecting

Body > Information > BL/WL

Rib coordinate output formats

LOFTSMAN saves rib data in four possible formats:

1. 3D aircraft coordinates. This is the basic description of any rib. Positions of 
points along the rib may be expressed in terms of the three-dimensional 
aircraft coordinate system. Plain and DXF files are in this form.

2. True view. Two-dimensional coordinates are presented in full size; the 
leading edge of the airfoil is placed at the origin of the coordinate system. This
description is used to make tooling and to produce certain drawings.

3. 2D aircraft coordinates. The rib is projected upon one of the orthogonal 
reference planes and full-size coordinates are given. Select Side, Top or Front 
in the Save dialog. Do not confuse orthogonal views with True views. 
Orthogonal views do not produce the actual shape of the rib, but only its 
appearance when viewed from front, side, or top. 

4. Normalized coordinates. Ribs may be saved as .SD files or listed with two-
dimensional coordinates expressed as percentages of chord. Incidence 
information is discarded. 

Normalized coordinates may be used as input for airfoil analysis programs. To
further manipulate SD files, select Edit > Profile. Airfoils may be modified in 
various ways: inverted, order of coordinates reversed, number of stations 
changed, trailing edges de-cusped or reflexed, leading edges drooped, and two-
dimensional sections distorted to provide aerodynamically comparable 
sections for three-dimensional bodies of revolution.
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Defining spars

The word "spar" is used here not in its structural sense, but only to 
distinguish between generally spanwise sections and ones that lie in a 
generally chordwise orientation, which LOFTSMAN calls "ribs." The precise 
distinction used by LOFTSMAN is that a rib must intersect both the leading 
and the trailing edges at some point, even beyond the ends of the panel. Part 
(or all) of a rib may lie beyond the wing tip or inboard of the root rib. Spars are
limited to the spanwise extents of the defined panel, and may or may not 
intersect a leading or trailing edge. If a spar intersects both leading and 
trailing edges within the span of the panel, it is a rib, not a spar.

The consequence of these definitions is that the great majority of possible cuts
through a wing are ribs. In tapered wings, however, all sections whose angle 
of sweep is at the same time less than or equal to that of the leading edge and 
greater than or equal to that of the
trailing edge must be defined as
spars.

When the geometry of a physical
spar is such that it could be part of
a rib by the above definition, it can
be computed as a rib. The advantage of computing it as a spar is that it is 
automatically truncated at the wing limits, and coordinates are evenly spaced 
at intervals selected by you (by setting the STEP). 

To compute a spar, select

Wing  > Spar

LOFTSMAN prompts you for the defining plane, and then computes its 
intersection with the wing surfaces at regular spanwise steps.

For spars, the two rotations you must specify are the Y and the Z. Y controls 
the tilt of the spar web with respect to the vertical; a spar whose shear web 
lies in the FS plane has an Y value of zero. Positive values of Y move the upper
edge aft and the lower edge forward.

The Z rotation determines the sweep of the spar. A spanwise spar 
perpendicular to the plane of symmetry has a Z rotation of 90 degrees. Larger 
angles produce positive sweep (tip forward) and smaller ones produce negative
sweep. For spars in vertical surfaces, Y controls sweep and Z controls the 
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rotation about the vertical axis (which as a practical matter is virtually never 
used).

If a spar intersects a leading or trailing edge, detail will be lost at the end of 
the spar if the STEP is too large. You can improve definition by limiting the 
definition of the spar to an increasingly narrow spanwise band with Start and 
Stop, and reducing the size of Step.

True view, as with ribs, causes the spar to be presented as 2D coordinates of 
its actual shape, with the zero station at the inboard end.

Wing geometry

Select

Wing  > Information > Geometry

Calculated values defining the wing are shown. You can subsequently use File 
> Print or File  > Save. The saved file has the extension .GEO.

Dihedral angle is measured at the leading edge, not at the axis line. Average 
values and Centroid of Lift are weighted with the effective area of each panel, 
which is calculated by integrating chordwise strips 1 inch or 25 mm wide. 
Spanwise lift distribution is also factored into the weighting by adjusting the 
chord of each strip to represent the average of the true geometric chord and 
the chord of an elliptical planform of span and area equal to those of the 
complete wing.

To obtain overall areas and aspect ratios, generally horizontal surfaces are 
extended to BL 0.0 with lines perpendicular to the direction of flight; vertical 
ones end at the base rib.
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Wing section data

To obtain parameters for a wing section with default cants at a given station, 
select 

Wing  > Information > Section data

LOFTSMAN also reports a cross-sectional area and a perimeter ratio. The area
is that of the default rib unless the current values of START and STOP limit the
area under consideration. The perimeter ratio is the ratio of the perimeter of 
the section to its chord; the average of the perimeter ratios of the root and tip 
sections can be multiplied by the projected area of the wing to obtain an 
approximation of its wetted area.

Information will be displayed only if the requested station is within the wing.

Points and slopes on wings

To obtain the WLs of wing upper and lower surfaces for a given FS and BL, 
select

Wing  > Information  > WLs/slopes

The slopes given are in the BL plane.

The same procedure can be used to get the BL corresponding to a given FS 
and WL on a vertical surface.

Tank volumes

Internal tankage  is assumed to be bounded by vertical ribs and spars. Spars 
need not follow ruled lines -- that is, they may be at different percentages of 
chord at different buttlines -- but ribs are assumed to lie parallel to the plane 
of symmetry. If a tank is bounded by canted ribs or spars, you have to 
approximate its shape. You can define up to ten segments in a tank. They 
need not be contiguous, nor do they need to represent physically isolated 
volumes.
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Tank information can be either listed or printed. Printed output is 
accompanied by a summary of the geometry of the tank as you entered it.

Select

Wing  > Information > Tanks

LOFTSMAN asks for the number of tank segments you will be entering, and 
whether you will be specifying the positions of tank walls as fractions of chord
or with actual dimensions. Fraction of chord is the default, and values must 
be entered as decimal fractions, not percentages: 50% of chord is .50, not 50. 
If you retrieve geometry information from a file, it appears as defaults.

LOFTSMAN then prompts you for the four walls surrounding each tank 
segment and for the skin thickness. If the thickness of the top skin differs 
from that of the bottom, average them. 

LOFTSMAN initially solves for total tank volume (for one wing). It then 
inquires whether you would like to rerun, and if so whether you would like to 
get the volume for full or partial fuel. If you select partial fuel, LOFTSMAN 
prompts for the coordinates of some point on the fuel surface and the tilts in 
pitch and roll, if any, of the tank.

LOFTSMAN reports not only the volume of tanks but also the centroid of the 
volume, which corresponds to the center of gravity of the fuel in the tank. 
Weight is not reported, since it depends on the density of different fuels. The 
moment of inertia of the fuel about an X axis passing through the airplane 
center of gravity is reported in normalized form; multiply it by the total weight 
of fuel to convert to a real value.

The coordinates of the center of gravity can be entered in the Settings > 
Constants dialog, and are stored in build files. Tank geometry information may 
be saved in a file with a TNK extension and retrieved for future use. Results 
may also be printed, along with the geometry.

If you wish to save the current geometry and results, LOFTSMAN prompts for 
a file name and asks whether you wish to save spanwise loading information 
in a separate file. If you wish to create this file, you must specify the width of 
the strips for which loads are obtained. LOFTSMAN offers the current STEP as 
the default.

Load information is stored in tabular form in three columns that contain the 
inboard buttline of the strip, the outboard buttline, and the weight of the fuel 
in that strip in normalized form, that is, as a fraction of the total weight. The 
file has the same name as the TNK file but a SFD (spanwise fuel distribution) 
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extension instead. This information can be used to apportion bending relief for
stress calculations.
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9. Intersections

Body intersections

LOFTSMAN will find all lines of intersection between two bodies. Select

Body > Intersection > With second body

LOFTSMAN requests the name of a .LFT file whose intersection with the 
current file(s) you want to find. The body represented by the name must be a 
single (ie non-compound) body. 

When listing, saving, or printing intersections, LOFTSMAN separates groups 
of points with empty lines. Each group represents all or part of a line of 
intersection between two bodies; occasionally, LOFTSMAN may break a single 
line into two portions because it has failed to find an intersection at some 
point. Unless otherwise specified, only intersections with the starboard side of
the primary body are reported.

Points along the line of intersection may be spaced in various ways. When the 
line is of interest for its own sake, the Fixed step option should be selected; 
the value of the STEP can be set from within the dialog.

To obtain a single point, enter the FS of the point and then select Edit  > List/
Edit.

Other spacings, including various kinds of cosine spacings, equal-interval 
spacing, and spacing to match another line’s, are provided for the purpose of 
setting up bounded-region meshes. For more information, see the sections on 
meshing. When cosine or equal spacing is selected, you must provide the 
number of points desired.
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Editing incomplete intersections

In some cases, for instance when a bulge such as a cowl cheek emerges from 
the side of a larger body, LOFTSMAN does not locate the foremost and/or 
aftmost point of the intersection. If the precise point is required, it can be 
located by progressively shrinking the INCREMENT and narrowing the fore and 
aft limits until the required precision is achieved. For meshing, however, a 
simpler approach is to view the intersection in profile, move the cursor to the 
likely position of the missing point, and click on the middle mouse button or 
thumbwheel. The location of the selected point on the model surface is stored 
on the Windows clipboard, and can be inserted in the intersection listing in 
the List/Edit form.

Wing-wing intersections

To obtain the lines of intersection of the current wing with another, their axes 
must intersect when viewed along the X axis. Select 

Wing  > Wing/wing intersection

Intersection lines are numbered 1 to 4, 1 being lower surface of primary with 
lower surface of secondary, 2 lower surface of primary with upper surface of 
secondary, 3 upper surface of primary with upper surface of secondary, and 4 
upper surface of primary with lower surface of secondary. “Upper” and "lower" 
are defined in terms of a horizontal starboard wing. Wings in other positions, 
such as vertical fins, should be visualized as starboard wings rotated about 
the X axis according to the right-hand rule. Thus, the starboard side of a 
vertical fin is its lower surface.

Optionally, intersections may be extended to include a section of the primary 
file ahead of or behind the intersection, or both. The extended intersection 
may then be used as one edge of a bounded region mesh.

To mesh intersecting panels individually, make the wing containing the panel 
to be meshed the primary wing. Select the surface (Upper or Lower) of the 
secondary wing to which the desired panel is adjacent, and check Mesh panel.
The bounded-region dialog form appears, with the appropriate selections and 
defaults already supplied. You may change them if you wish. LOFTSMAN will 
already have saved the wing-wing intersection line at one end of the panel to 
be meshed, and will have placed its filename in one of the boundary-line edit 
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boxes. The other boundary is the break rib at the end of the panel. The 
“primary” wing is meshed; to switch to the other, go to File > Set primary.

You can replace the Break rib file with a different file if you wish. For example,
when meshing the panel between fuselage horizontal stabilizer on a cruciform 
tail, you might first obtain the intersection between the fuselage and fin, save 
it, and replace the Break rib filename in the dialog with it.

To mesh the complete assembly, in most cases it is possible to use Mesh all. 
LOFTSMAN will present the dialogs for all patches in succession; normally 
you need only click OK for each one.

Intersections of bodies and wings

Select

Body > Intersection  > With wing

You may choose between Default spacing, Fixed step, Single FS and Match 
line. Default spacing locates the points along the intersection to coincide with 
the cosine-spaced stations of wing ribs. Fixed step places points at intervals of
the INCREMENT. Match line places points at stations coinciding with the X 
coordinates of points in a named file. 

Portions of the wing surface that do not penetrate the body are projected to 
the plane of symmetry. LOFTSMAN normally returns the intersection on the 
side of the body nearer to the tip of the wing. To obtain the intersection on the
opposite side, select Far side.  You can choose to display only one surface of 
the intersection, and, if you are getting only one surface, you can set the order
of points; these choices are useful in setting up meshes.

Calculations of intersections between bodies and curved wing panels are 
relatively slow. They can be accelerated by setting the INCREMENT to a larger-
than-usual value, say one inch rather than 0.1.

In order for the intersection of a curved wing panel and a body to be properly 
defined, the inner break on the wing panel must be wholly within the body. If 
it is necessary to extrapolate a new inboard break in order to fulfill this 
requirement, LOFTSMAN will do so provided that the innermost segments of 
all seven moldlines defining the curved panel are straight. It is not possible, 
for obvious reasons,  to extrapolate from an entirely curved panel.
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If LOFTSMAN is unable to find all of the points along the intersection line, it 
will ask whether you want it to interpolate the rest. Usually this operation 
produces satisfactory results, but if interpolated points do not lie sufficiently 
close to the model surface LOFTSMAN may be unable to use them for 
meshing. 

Wing root fillets

Wing root fillets can be created for wing-body combinations having a well-
defined intersection along their entire length. The procedure will work only for
ruled wings, and will not work for wings whose surfaces are outside or  
tangent to the top or bottom of the body.

The fillet consists of a series of conic arcs tangent to the body and the wing. 
Each arc lies in a plane normal to the adjacent surface of the wing, at a 
station corresponding to a point along the wing-body intersection. Intersection
points in turn coincide with the number and spacing of points used to define 
the wing section.

For fillets extending past the trailing edge, two styles are provided, called 
“convex” and “concave”. The names refer to the shape of the trailing edge of 
the fillet in plan view. The classical type of fillet is “concave”, that is, tangent 
in plan view to both the fuselage side and the wing trailing edge. The “convex” 
fillet is more like an afterbody, its trailing edge at approximately a right angle 
to that of the wing.
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Convex fillet

Concave fillet

Fillet shape is controlled by seven parameters that are stored in a file having 
the same format as an LFT file, but a WRF (Wing Root Fillet) extension and the
word "Fillet" on a line following the version date. Each of the six parameters 
varies from the leading edge to or beyond the trailing edge of the intersection 
just as if it were a moldline or control line in a body loft. All except the K 
Factors are in coefficient form, normalized to the X axis component of the root 
intersection chord.

The parameters and their abbreviations for editing purposes are:

Top wing width (UW) The distance from the wing-body intersection 
line to the tangency of the fillet arc with the wing's upper surface.

Top body width (UB) The distance from the wing-body intersection 
line to the tangency of the fillet arc with the body above the wing.

Top K The K factor of the fillet arc above the wing. This 
may range from zero to 1.0.

Bottom wing width (LW) The distance from the wing-body intersection 
line to the tangency of the fillet arc with the wing's lower surface.

Bottom body width (LB) The distance from the wing-body intersection 
line to the tangency of the fillet arc with the body below the wing.
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Bottom K The K factor of the fillet arc below the wing. This 
may range from zero to 1.0.

Mid line height (MID) The distance from the projected median line of 
the root intersection to the median line of the portion, if any, of the fillet that 
extends aft of the trailing edge of the wing. Between stations 0.0 and 1.0 
(representing the leading and trailing edge points of the root intersection) the 
Y value is zero; this parameter is used only to control the camber of the 
portion of the fillet extending behind the wing trailing edge..

The first Fore end value in each control line must be 0.0. For fillets that do 
not extend past the trailing edge, the final value must be 1.0. For fillets 
extending past the trailing edge, final values must be greater than 1.0. For 
example, a fillet extending 15 inches behind the trailing edge of a wing whose 
root chord is 50 inches would have a maximum X axis dimension of 1.30 in 
the WRF file.

A reflexed or drooped afterbody is indicated by a curve in the MID control line 
aft of station 1.0. Aft of the trailing edge, the UB and LB offsets are measured 
from the MID line. 

To create a fillet, load the body and wing files and select

Wing  > Root fillet

Select the desired WRF file. To create or edit one, click on Create/Edit fillet 
control lines. A generic fillet file, GENERIC.WRF, is supplied with LOFTSMAN 
and may be used as a starting point. 

Fillet control lines are edited in the same way as body or wing control lines 
and moldlines. In general, fillet radii increase aft, beginning with a small but 
finite value at the leading edge. An afterbody may terminate in a point, or the 
UB and LB lines may remain more or less parallel or gently diverging. If they 
do not converge to a point, the tail of the afterbody blends into the fuselage 
side.

Points per section is the number of points used to define each fillet arc. If the 
fillet will be used as part of a mesh, this value controls the number of 
chordwise strips or panel rows in the fillet. The number of chordwise stations 
in the fillet is controlled by Station count at Settings >  Constants.

Afterbody stations is the number of points in the extension, if any, of the fillet 
aft of the trailing edge of the wing. Stations are automatically given a half-
cosine spacing with the denser end near the wing. The number must be larger
than 2.
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Click OK to generate the fillet. When you save a fillet as a patch, two files with
the same name as you have given to the fillet file, but with the extensions WTL
(wing trim line) and BTL (body trim line), are also saved. They permit you to 
define the adjacent bounded regions for wing and body or wing root meshes. 
When using a WTL file as one end of a wing bounded region, you must check 
Match both or Match inner to ensure that the wing mesh nodes exactly match
those of the fillet.

A “convex” fillet is saved as a single folded patch, oriented like a wing patch. A
“concave” fillet is stored in the same orientation, but as top and bottom halves
of a series of strips one panel wide. When a concave fillet appears in a CMARC
input file,  upper- and lower-surface fillet patches should be placed in 
different assemblies; otherwise unrealistic pressures will appear on triangular 
panels at the trailing edge.
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10. Manipulating airfoils

Viewing and Comparing Profiles

Select Wing  > Profile > Display from SD file. Repeated calls overlay normalized 
profiles for comparison.

Generating NACA 4- and 5-digit Profiles

NACA’s 1930s-era 4- and 5-digit profiles were produced by simple 
mathematical procedures that allow infinite variation between the standard 
coordinate sets found in Theory of Wing Sections. 

For 4-digit sections, eg 2412, the first digit is the maximum height of the 
mean line above the chord line in percent of chord, and happens to coincide 
closely with the minimum-drag lift coefficient (in tenths). The second digit is 
the location of the maximum mean line height in tenths of chord. The two 
final digits are the thickness ratio.

For 5-digit sections, the nomenclature of which was evidently designed to 
confuse, the first digit is two-thirds of the design lift coefficient in tenths, the 
second and third are the location of the highest point on the camber line, 
doubled and expressed as a percentage of chord, and the last two digits are 
the thickness ratio. Thus, a 23012 has a design lift coefficient of 0.3, its 
maximum camber height is at 0.15c, and its thickness ratio is 12 percent.



3.67

Modifying .SD Files

LOFTSMAN permits you to perform certain operations on .SD files. Select

Edit  > Profile

The name of the requested .SD file is provided as the default name of the 
destination file. In order to avoid accidentally overwriting the source file, the 
extension is changed to .MOD. You can type in any name you wish.

The dialog provides ten options in four general categories:

Format changes

1. Invert. An inverted section, identical in thickness distribution to the given 
one, is produced. (Inverted sections are sometimes used for horizontal tail 
surfaces.)

2. Reverse. Normally, the stations in an .SD file begin at the trailing edge, 
proceed forward along the upper surface, and return to the trailing edge via 
the lower surface. LOFTSMAN will accept files listed in the reverse order,  and 
most operations will be unaffected; but the fuel tank volume calculations will 
return invalid results. This command simply reverses the order in which 
stations are listed, leaving the section unchanged. CMARC and VSAERO 
expect wing section input in the reverse of LOFTSMAN's order, but 
LOFTSMAN automatically reverses point order when it generates a patch.

3. Eppler. The section is saved in a format that can be edited directly into an 
input card for the Eppler airfoil analysis code. The coordinates are not altered.

4. Station count. A new .SD file is created with the same shape as the given 
one, but a different number of stations. The usual application of this function 
is to standardize files provided by the user in order to make them compatible 
with LOFTSMAN, which normally uses 30 stations along the abscissa, spaced 
according to a cosine distribution. The given file need not have a cosine 
distribution, need not have the same number of upper- and lower-surface 
points, and may contain any reasonable number of points; it must, however, 
have an .SD extension and format, as described in Section Two of this 
manual, and the coordinates must be normalized (ie the chord must be 1.0).

5. Create .SD file from points. An .SD file is produced from a plain listing of 
any number (greater than 5) of 2D coordinates. They need not be normalized, 
but they must begin and end at the trailing edge. Airfoil data files from the 
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huge archive prepared by Michael Selig of the University of Indiana at Urbana-
Champaign can be read as though they were plain coordinate lists (see 
http://amber.aae.uiuc.edu/~m-selig/ads.html).

Solid bodies

6. Perform exponential deformation. In order to preserve the laminar 
characteristics of 2D sections when they are used to provide the outline of a 
3D body, the section may be modified. The method used here involves several 
steps.

First, each point is assigned a value that is the ratio of its distance from the
chord line to the greatest distance of the surface from the chord line. Thus, for
a symmetrical section of 12% thickness, the greatest distance would be .06 
and a point whose distance was .03 would be assigned a value of .5. 

Next, the value of each station is raised to the 3/2 power. Thus, the value 
of .5 becomes .3535, whereas the maximum semi-thickness remains 1.0.

Finally, each value is multiplied by the actual semi-thickness to produce 
the new ordinate. The point whose value was originally .03 is now .3535 x .06,
or .02121.

This operation can be performed on asymmetrical airfoils, and exponents 
other than 3/2 can be used. The result, which is a section having the same 
thickness as the original but steeper ramps fore and aft, is saved as an .SD 
file.

7. Create body of revolution. A .LFT file is created for a body of revolution 
having as its profile the positive surface from a specified .SD file.

Shape adjustments

8. T/C ratio. A new .SD file is created in which all ordinates are multiplied by 
the ratio between the thickness of the original file and the desired thickness. 
This is not an aerodynamically reliable way to alter an airfoil unless the 
change in thickness is quite small -- of the order of 10% of the section 
thickness or less.

9. T.E. thickness. A wedge, tapering in thickness from zero at the leading edge
to the difference between the current value and the requested one at the 
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trailing edge, is summed with the airfoil thickness distribution. In this way a 
section with a finite trailing edge thickness can be given a sharp trailing edge, 
or vice versa, with minimal adverse effects upon its aerodynamic 
characteristics. (CMARC, Pmarc-12 and VSAERO require that airfoils have 
zero trailing edge thickness, but during meshing airfoils having finite trailing 
edge thickness are modified by pulling the upper and lower trailing edge 
points together halfway between them.)

10. Stretch leading or trailing edge. The portion of the airfoil before or after the
points of greatest upper and lower surface thickness is elongated. The Factor 
is the ratio of the new full chord length to the original. A negative value of the 
Factor indicates that the leading edge will be extended; otherwise, the trailing 
edge. The airfoil is renormalized after modification. Airfoils modified in this 
way are useful for dorsal fins, strakes, and elongated leading edges at wing 
roots. 

11. LE droop or TE reflex. The chord line of the airfoil, forward or aft of a 
specified station (Start X/C),  is bent into a circular arc of a Radius specified 
in terms of the chord length. The starting station is a fraction of chord; if it is 
less than 0.5, the leading edge is drooped; otherwise the trailing edge is 
reflexed. The airfoil is renormalized after modification.

To bend the leading edge upward or the trailing edge downward, make the 
radius negative.

Note that these shape changes are not performed in an aerodynamically 
sophisticated way, but rather in the way they might be executed on the shop 
floor in order, for instance, to tailor a wing-fuselage intersection. They do, 
however, produce fair and smooth sections.

Dimensionalization

12. Convert normalized coordinates to real. A .RIB (plain coordinates)or .DXF 
file is produced with the chord and leading edge coordinates requested.

A number of options are provided. Either all of the section or one surface 
only can be expanded. Section spacing can be the default cosine arrangement 
or regular intervals. If you select regular intervals, you must specify two 
intervals, a smaller one that is used within 0.1c of the leading edge, and a 
larger that is used elsewhere. The point count for cosine spacing is the default
set in Settings  > Intervals.
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11. Designing flaps

Introduction

LOFTSMAN creates airfoil sections for trailing-edge control flaps and high-lift 
devices, using the main airfoil section to provide the exposed portions of the 
flap section. Two basic types of section geometry are available. In one, circular
arcs centered at a hinge point are used to form the nose of a section, 
presumably that of an aileron, rudder, elevator or trim tab. Flaps designed in 
this manner may bear little resemblance to airfoil sections, but are suitable 
for control surfaces where a small, constant gap is desired between a main 
surface and a plain flap.

The second type of section is a proper airfoil section, and is suitable for a 
Fowler or single-slotted flap and for some Frise ailerons. 

The LOFTSMAN procedure is three-dimensional; that is, it produces a 
complete surface defined by at least two breaks at different buttlines. It 
creates the required .SD files, a .WI file containing the geometry of the flap 
panel, and an .FG (Flap Geometry) file containing a description of the 
parameters that generated the file in the first place. .FG files are placed in the 
same directory as .WI files.

If you load an .FG file when the current main wing is not the one for which 
the flap was originally defined, LOFTSMAN warns you. If you wish to 
continue, however, you can.

The purpose of the flap definition routines is to define the geometry of flaps, 
ribs, and so on. External-hinged flaps may be meshed for CFD analysis; a 
separate routine is provided for combining wing and flap and for providing a 
smooth cove for analysis purposes (see Slotted flap, far below). Internal-hinged
flaps, however, have no relation to meshing. LOFTSMAN provides a separate 
flap-meshing procedure (see Deflected flap) that does not require definition of 
a complete flap; it merely deflects a portion of the wing between chordwise and
spanwise limits and provides a continuous trailing edge for wake attachment. 
Generally, however, it is simpler to simulate a flap with panel tilt for analysis 
purposes. Panel tilt is discussed in the DWT/CMARC manual.
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Naming of flaps and sections

When you first invoke this procedure, LOFTSMAN prompts for a name. This 
will be the name of the flap .WI and .FG files. Break sections within the flap 
file, which are stored as separate .SD files, are given the flap name with a digit
added to indicate the break position along the flap, beginning with zero. Thus,
for a three-break .WI file called MYFLAP.WI, the root section file will be 
MYFLAP__0.SD, the intermediate section MYFLAP__1.SD, and the outboard 
end MYFLAP__2.SD.

Aerodynamic characteristics of flap sections

Computational analysis of flap sections is quite complex, since they operate in
a flow field distorted by the nearby wing. Two-dimensional panel methods, 
such as the Eppler airfoil analysis code, are not useful for analyzing slotted 
flaps. CMARC will analyze slotted flaps with reasonable accuracy, however, 
although an inviscid analysis misses the subtleties of boundary layer behavior
in the slot and therefore is not a reliably good predictor of optimal slot 
geometry. Designers not having the complete PSW design package (or a two-
dimensional multi-element airfoil analysis code) will have to satisfy 
themselves with Abbott and von Doenhoff's helpful observation (Theory of 
Wing Sections, p. 213) that the best flap sections are the ones that look like 
good airfoils.

No aerodynamic analysis of control surfaces is usually performed, the main 
consideration in design being mechanical fit. PSW will analyze the 
performance of deflected control surfaces, however.



3.72

Flap types

Four flap types can be produced.

1. External hinge or tracked. The flap will
be an airfoil section based on conic
curves. Flap movement is arbitrary; it
may be controlled by a single hinge,
normally external to the airfoil, or by rollers in tracks.

2. Surface hinge with offset. A piano-type
hinge is assumed. The hinge is offset from
either the upper or lower surface by some
small value (which may be zero). A positive
value indicates an offset inward, that is,
below the surface. The surface opposite the
hinge forms a segment of a circle with the
hinge at its center. A straight line completes the section, passing behind the 
hinge at a distance equal to the offset. The user provides the hinge FS and the
offset; LOFTSMAN provides the hinge WL or BL (for vertical surfaces).

3. Offcenter internal hinge. The hinge line is
located within the flap. The nose is formed by
a fair curve joining the exposed upper and
lower surfaces. The user initially defines the
flap chord and balance ratio; nose shape
parameters can then be modified.

4. Centerline hinge. The nose of the flap is
a circular arc tangent to both surfaces
with the hinge at its center. The user
supplies only the FS of the hinge, and
LOFTSMAN computes the WL.

Hinge points defined during the initial
design process are located at the outboard ends of the flap. These need not be 
the intended locations of the physical hinges. Once the panel and its travel 
have been designed, the locations of real hinges are determined by linear 
interpolation.
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Intermediate breaks

Flaps, like wings, may have intermediate break ribs. Hinge lines are initially 
defined by the outermost breaks; end breaks must therefore be defined before 
intermediate ones. Later, the positions of hinges can be changed.
 
For all hinged flap types, the hinge line must be straight; therefore, once the 
end breaks have been designed, the locations of the hingeline at intermediate 
breaks follow automatically. Some parameters of intermediate breaks can be 
altered, but the hinge position cannot.

Intermediate breaks on centerline-hinged and surface-hinged flaps are subject
to an additional constraint: the hingeline location must be consistent with the
nature of the flap. Thus, for a centerline-hinged flap both surfaces must be 
tangent to the same arc centered on the hingeline. For a surface-hinged flap, 
the hingeline must be at the correct distance from one surface. LOFTSMAN 
uses the TOLERANCE to determine whether or not a section meets the relevant 
requirements. If it does not, LOFTSMAN displays a warning message and asks
if you want to continue. 

In the case of External hinge/track flaps, airfoil sections are designed first and
their travel geometry is established later.

Rib cants at breaks are identical to those of the corresponding breaks, if any, 
on the main surface. If a flap break is defined where there is no main surface 
break, the cant is the default X-axis or Z-axis rotation for the break's position 
on the main surface. This may be changed later by editing the .WI file for the 
flap.

General procedure

Load the .WI file for the main wing surface. Then select

Wing  > Flap

and choose the type of flap desired.

In the dialogue box, enter a name for the flap. (You can create a flap without 
entering a name, but if you then save it with a Save rather than Save as 
command, it will be saved with the name TEMP.)  
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Next, enter the stations of the inboard and outboard sections that will be used
to define the hingeline(s) of the flap. Enter upward and downward travel 
limits; upward deflections are negative, downward positive. 

Internal-hinged flaps

The initial flap-definition dialog, which appears when you select Wing  > Flap, 
then File > New, offers three types of internal hinges.  As soon as you end the 
dialog, a complete flap is created using the parameters that you specified, as 
well as some default values. You can accept the flap as it is, or modify it in 
various ways.

In some cases, a flap extends across a panel break in the wing. Usually, the 
change in wing geometry represented by the break will need to be reflected in 
the flap geometry. You can define a break at a new spanwise station by 
selecting Define flap > Add break. 

Hingeline locations are stored as percentages of flap chord in the .SD file for 
each break rib. The flap chord line is defined as the longest straight line that 
can be drawn intersecting the leading and trailing edges of the flap. The 
incidence of the flap chord line with respect to the wing chord line is therefore 
arbitrary.

When a flap section is displayed on the screen, it can be deflected by placing 
the mouse cursor at the trailing edge, pressing the left mouse button, and 
moving the mouse. The current deflection is continuously reported at the right
end of the status line at the bottom of the screen.

Centerline hinge

This is the normal option for non-surface-hinged control surfaces, especially 
rudders. Initially, you must supply an approximate hingeline location as a 
fraction of wing chord. 
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Surface hinge with offset

Normally, this option would be used for a piano hinge whose outer 
circumference can be flush with or close to the wing surface. Only one arc 
length needs to be given (the one opposite the hinge) along with the FS of the 
hinge and the distance of the hinge centerline from the surface.

Because all flap profiles are stored as 59-station cosine-spaced lists, a small 
chamfer may appear in screen displays at the corner of the flap section near 
the hinge. This is an artifact of the spacing of the points defining the flap. In 
reality, the front face of the flap would be a straight line intersecting the wing 
surface on which the hinge is located. 

Offcenter internal hinge

This arrangement is analogous to the centerline hinge, except that the hinge 
is not necessarily centered, and the flap may have an aerodynamic balance. 
Initially, the nose shape is roughly elliptical, but it can be modified in various 
ways.

Accepting a break

When you are satisfied with the flap design at a spanwise station, select

Define flap > Accept this break

The current form of the flap is saved.

Deleting a break

To discard a break that you have already defined, select 

Define flap > Delete a break

Select the break to discard from the list displayed. The breaks defining the 
hinge line cannot be discarded, and are not included in the displayed list.
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Editing internal hinge flaps

Colored dots indicate handles that can be grabbed and dragged to move or 
modify the flap.

The hinge point can be moved fore and aft and, in the case of offcenter hinges,
vertically as well. To move the hinge without changing the flap profile, hold 
<Ctrl> while dragging the hinge. Sections may be thickened, and may be 
rotated by dragging the trailing edge. The shape of the nose of an offcenter-
hinged flap can be changed by dragging handles on the shoulder of the upper 
and lower curves and moving the leading edge up and down. To change the 
deflection limits, select 

Define flap > Change parameters

Upward deflections are negative.

Thickened sections

Some designers like to increase the thickness of control flaps in order to 
improve flow attachment. After internal-hinged flap sections have been 
designed they can be thickened by dragging the thickening handle. Note that 
this procedure does not produce a satisfactory result for surface-hinged flaps, 
since it expands both the upper and lower surfaces.

Setting cove lip locations

Initially, LOFTSMAN places the cove lip at the point of tangency of the flap 
and the wing. To move the lip to a more realistic location, place the cursor at 
the desired location and press the left and right mouse buttons 
simultaneously.
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Editing external-hinge and tracked flaps

The aim is to produce an airfoil section some portions of which coincide 
exactly with those of the wing. When one does this by hand, one simply fairs 
in the missing curves by eye. In lieu of the draftsman's splines and French 
curves, LOFTSMAN provides an airfoil of variable shape that it blends with the
main section at points that can be selected by the user.

Select 

Define flap > Edit a break

Colored dots indicate handles that can be dragged with the mouse to modify 
the flap in various ways.

To change the flap chord or the nose camber, drag the nose point of the 
nested flap fore and aft or up and down.

To change the thickness of the forward portion of the flap, use the handles 
midway between the nose and the blend points or lips.

To change the points at which the flap profile becomes tangent with that of 
the main element, drag those points.

The cove lips are indicated by small crosses (“plus signs”). To move them, hold
the [Ctrl] key while dragging the mark. The grid associated with the upper-
surface lip has intervals of one percent of chord and is intended as an aid for 
positioning the deflected flap in accordance with published slot-shape data.

Always save between operations by clicking the OK  button on the toolbar or 
by selecting

Define flap > Accept this break

Using the Morph

The “Morph” is a NACA 4- or 5-digit profile that can be shaped and distorted 
in a number of ways to provide the forward portion of a flap profile. It is a 
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more versatile way of defining the profile than the default method using 
conics.

After choosing a break to edit, select

Define flap > Use Morph

The outline of the profile appears with several handles and, in the lower left 
corner of the screen, a “distortion box.”

To move the entire profile, place the cursor anywhere within it, press the left 
mouse button and drag.

To change incidence, grab the trailing edge handle.

To move fore and aft, use the leading edge handle.

To change thickness, use the handle on the upper surface.

To change both the amount of camber and the location of maximum camber, 
use the handle on the median line.

The two handles on the distortion box change the thickness distribution in a 
linear way; the left handle thickens the nose, the right the tail.

To form a profile, bring the upper and lower surfaces of the Morph into 
contact with the main element surfaces. Then select

Define flap > Blend Morph
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You can accept or reject the resulting profile.

A flap profile created by using the Morph can no longer be edited using the 
conic handles. It can only be modified means of the Morph.

When you accept a Morph shape and then begin to edit a different break 
using a new Morph, the new Morph will initially appear with the same shape 
parameters as you accepted for the previous break. Any Morph profile may be 
saved as an SD file, for example to use as a vane for a double-slotted flap.

Kinematics of tracked flaps

A tracked flap normally has at least three aerodynamically optimized settings 
-- nested, takeoff, and landing -- but intermediate positions can be added to 
help to define the flap travel. The path followed by the flap between stages is a
circular arc unless the flap angle is the same at two successive settings, in 
which case it is a straight line. Each arc is defined by a virtual hinge point 
and start and end flap angles. Only single-slotted flaps are supported.

To adjust the position of a deflected flap at a hinge break, drag either its nose 
point or the associated hinge point. (In some cases the hinge point may be off-
screen.) Adjust the flap deflection by dragging the tail end of the section. The 
angle is reported in the status line at the bottom of the screen.

The maximum deflection of the flap cannot be changed by dragging the 
trailing edge. To change it, select 

Define flap > Edit break parameters

To add an intermediate angle and nose position, select 

Define flap > Add a stage

Enter the desired angle, then drag the new profile to the desired nose location.
If you enter an angle larger than the present maximum deflection, it becomes 
the new maximum deflection and no new profile is added.

When you are at least temporarily satisfied with a break geometry, select

Define flap > Accept this break
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Changes in flap positions and angles at hinge breaks are extrapolated to all 
breaks.

Defining roller tracks

Each break of a tracked flap is provided with two rollers and their associated 
tracks. The rollers have a default diameter of 1/2 inch. The tracks may be 
moved around by dragging the dots at their fore ends. Their shapes 
automatically change as they move. Obviously, it is desirable that the rollers
 be fairly widely spaced, and that tracks be free of sharp kinks and protrude 
from the wing as little as possible, if at all.

Propagating section parameters across breaks

The general shape and camber of a break profile are controlled by its conic 
parameters. Optionally, you can cause all break profiles to have the same 
conic parameters. After defining the parameters for one profile, select 

Define flap > Match profile shapes

To align leading edges of breaks so that they form a straight line, select

Define flap > Align leading edge

The leading edges of non-hinge breaks are adjusted to align them with those 
of the hinge breaks.

Deleting a flap

To erase from the flap directory the WI, FG and flap (not wing) SD files 
associated with a particular flap, first load the flap, then select

File > Delete all files for this flap
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SD files in the standard profile library are not affected.

Meshing a slotted flap

Select

File  > Save patches

If you check Create IN file, LOFTSMAN creates a ready-to-run CMARC input 
file for the complete wing. Otherwise, only a single PCH file containing both 
flap and wing patches is produced.

Another option for meshing a wing and flap whose geometries have already 
been defined is to select Mesh > Wing  > Slotted flap. See the instructions for 
meshing slotted flaps in the Meshing functions section (14) below.

Limitations on precision

LOFTSMAN's flap-kinematics procedure is not a strictly three-dimensional 
one. It defines flap sections and travel paths at various spanwise stations as 
two-dimensional true views. This is satisfactory for most purposes, but leads 
to small inaccuracies if the axes of flap rotation are not approximately normal 
to the XZ plane, as occurs, for example, when the rear spar and trailing edge 
of the wing are strongly swept.

Wing taper can also produce distortions, because the radii of flap path 
segments at the outboard end may be smaller than at the inboard end. As a 
result, the actual flap movement describes a conical rather than cylindrical 
surface, and includes a small spanwise component. In practice, these effects 
are minor, and LOFTSMAN ignores them. Spanwise motion due to a conical 
geometry is more easily compensated for by tolerance in the flap rollers than 
by adding out-of-plane curvature to the tracks.

It should be borne in mind that because of the thinness of upper slot lips and 
of the flaps themselves, flexing due to flight loads will change slot geometry. 
There is also uncertainty about the optimal slot geometry for given wing and 
flap sections. Consequently, it is pointless to strive for extreme precision in 
slot lofting.
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12. Lines and points

Interpolation and Extrapolation

To find any point on a 2-dimensional line defined by two other points, select

Misc > Lines and points > Inter/Extrapolate

Enter the coordinates of the defining points and the X coordinate of the 
desired point. LOFTSMAN supplies the Y coordinate. If you wish to supply the 
Y coordinate yourself and get the X in return, click on Priority Y.

A point may also be interpolated upon a curve, provided that the curve does 
not double back upon itself. The interpolated point may optionally be added to
the points defining the curve, or the curve may be truncated at the point.

Finally, a group of rays defined by two 3D coordinate lists (for example, two 
airfoil sections in a ruled wing) may be projected upon any orthogonal plane. 

Intersection

You can find the intersection of two 2-dimensional lines, defining them either 
by pairs of points or by the point-slope method.

Up to 10 intersections of two filed curves may be found. The curves may be 
two- or three-dimensional, but both must be of the same type. 

Select

Misc > Lines and points > Intersections > Filed lines
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Rotation

To rotate a 2- or 3-dimensional line, select

Misc > Lines and points > Rotate

For 2-dimensional lines, supply two coordinates of the center of rotation. For 
3-dimensional lines, supply the coordinates of one point on the axis of 
rotation and, in the fields captioned Vector, the offsets of a second point with 
respect to the first. Note that the offsets are relative to the first point, not to 
the origin. The angle of rotation follows the right-hand rule, and should be 
given in degrees.

Translation

To translate a 2- or 3-dimensional line, select

Misc > Lines and points > Translate

Enter the offsets in each axis. A blank field is taken as a zero offset.

Reflection

Points in a two- or three-dimensional file may be reflected about any 
orthogonal axis.

Reversal

To reverse the order of points in a file, select

Misc > Lines and points > Reverse

The new file has a .REV extension.
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Area of a filed polygon

To get the area enclosed by a filed list of points, select

Misc > Lines and points  > Area

The file is assumed to contain 2D coordinates; LOFTSMAN reads only the first
two coordinates in each line of the file. In addition to area, it reports the 
perimeter and the centroids of the area and the perimeter.

If the last point in the filed list does not coincide with the first, LOFTSMAN 
closes the polygon.

This procedure may not be reliable for very slender or oddly-shaped polygons.

Point distribution

The spacing of points defining a 3D line may be changed to various standard 
types, or made to coincide with the distribution of points on another line.

Spacing may be referenced to any of the three orthogonal axes, or may follow 
the curvature of the line. Following the line (Arclength) is the default.

Spacing options include Self similar. Use this option when changing the 
number of points in a line, if you want to preserve the existing pattern of point
spacings.

Get frames

Given a series of previously defined cross-sections,  LOFTSMAN finds the 
closest approximation in the form of a B-type body. See Creating a model from
given cross-sections in Section 6, Editing objects.
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Parallel

Given a filed line of 2-dimensional coordinates,  LOFTSMAN creates and files a
parallel line offset from the original line by a given distance. A positive offset 
produces a parallel line on the right side of the original line, as seen by an 
homunculus strolling along the line from the start toward the end.
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13. Plotting and screen printing

Any screen display that can be zoomed, rotated, or redrawn can also be 
dumped to a graphics printer. Select

File  > Print screen

Note that there are two buttons with printer icons in the toolbar. The one with
the gray background prints numerical data, such as lists of computed 
coordinates. The one with the yellow background is the screen print button.

LOFTSMAN can also plot single lines or multiple lines from the current wing 
or body or from files, using either a printer or a plotter; but it will not 
duplicate arbitrary complete screen displays, as a CAD program would. The 
purpose of plotting is to produce dimensionally accurate outlines of parts 
rather than general depictions.

For plotting objects larger than a sheet of paper, LOFTSMAN allows you to 
select portions that will fit on a sheet, and optionally marks each sheet with 
ticks to facilitate assembling the complete picture.

When you select File  > Plot, a dialog appears containing several options:

Scale. You can enter either a fraction or a whole number, but 
LOFTSMAN will not plot larger than full size; a whole number is converted 
into its reciprocal. Thus, if you enter 4, LOFTSMAN plots at one-quarter 
scale. Enter 1 to print full size.

Tick spacing.  If you do not want ticks added to the plot to aid in registering 
it with another sheet or in taking dimensions from it, clear the check box. 

Plot from file.  The points to be plotted come from a file rather than from the
screen. The file name you enter should include the extension; for example, a 
filed rib will have a .RIB extension, a normal cross-section .CS, a 
moldline .ML, and so on. Some types of filed output, such as patches, cannot 
be plotted.
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Label plot.  LOFTSMAN adds to the plot a standard label indicating what 
the thing plotted is. Otherwise the label is omitted.

Plotting area. LOFTSMAN obtains the dimensions of the default plotting 
area from LM.INI on startup. If you set other values, they become the new 
defaults.

Correction factors If the plotter or printer does not produce precisely the 
right horizontal or vertical dimensions, empirical correction factors may be 
applied to each axis. These can be obtained by dividing a desired dimension 
by the actual measurement on the plot.

After you make your choices, a rectangle representing the plotting area 
appears on the screen; diagonal crosshairs and a half-size inner frame are 
provided to help in positioning it when all or part of the outer frame lies 
outside the screen. To position the frame, drag it with the mouse while 
holding down the left button. To rotate the frame 90 degrees, hit R or r or 
click the right mouse button. When you are satisfied with the framing, hit 
<Enter> to execute the plot. Note that if you rotate the frame, you must also 
change the orientation of the page in the printer or plotter driver to match.

When the plot is complete, LOFTSMAN presents a new frame slightly 
displaced from the preceding one. Images of the preceding frames remain on 
the screen to help you to tile a large plot. If you wish, you can continue to 
position the frames and make plots until you have plotted all of an object too 
large to fit on a single sheet. 

To terminate the plotting procedure, hit <Esc>. 

Some plotter drivers allow you to send the stream of plotter commands to a 
disk file rather than directly to the plotter. This function, which under DOS 
was handled by LOFTSMAN, is now the province of the printer driver. If it is 
available, a Plot to file option will appear in the print preparation dialog.



3.88

14. Meshing functions

Paneled normal sections of bodies

To make a wireframe model or mesh of a body, cross-sections must be 
converted to polygons of a certain number of faces, and their vertices then 
connected by longitudinal lines. The most primitive meshing operation, 
therefore, is the conversion of a cross-section into a polygon having a specified
number of faces. LOFTSMAN will perform this operation on cross-sections 
singly or in groups.

Select

Body > Paneled normal

For a single section or several sections irregularly spaced, click on Specified 
station(s) and enter in the FS box the stations of one or more sections.

For multiple equally-spaced sections, click on Slices and enter the desired 
interval between sections in the box captioned Step.

Filed sections may also be paneled. Click on Filed section and type or select a 
file name. The Strips option is not valid in this case, since there is no 
information about the body of which the filed points represent a cross-section.
Forced nodes may be used, however.

Paneling and INCREMENT size

To arrive at the locations and spacing of vertices, LOFTSMAN uses a 
procedure in which curves are approximated by straight lines and points 
along them are arrived at by interpolation. The accuracy of this method is 
enhanced by setting the INCREMENT (in the Settings > Constants dialog) to a 
small value, such as 0.01 inch. If the INCREMENT is too large, longitudinal 
lines connecting vertices may sometimes be wavy.
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IMPORTANT

A small value of the INCREMENT is needed for converting small sections to 
polygons. The basic requirement is that the number of points defining the 
section with the current INCREMENT, before paneling, should not be smaller 
than the number of vertices of the paneled version. If it is, degenerate or 
distorted sections or seemingly random spiky lines may appear, especially at 
the nose and tail of a body where sections are small. This applies to all types 
of body meshes. If errors occur in a mesh where the cross-sections are small, 
reducing the size of the INCREMENT will most likely correct them.

Panel bunching

LOFTSMAN sets the lengths of the segments of a paneled section using an 
algorithm which increases the number of panels in areas of smaller radius of
curvature in the section plane and decreases the number in less sharply 
curved areas. The degree of "bunching" of panels is controlled by a 
dimensionless parameter called BUNCH. The default value of BUNCH is 1.0. You
can set BUNCH at zero to make all panels the same length or select values 
greater than 1.0 to exaggerate bunching. The useful range of values is 
between zero and about three.

           Bunch = 0.0                            Bunch = 1.0                            Bunch = 3.0

Paneling options

Several styles of paneling may be selected.
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Automatic. Lengths of sides are automatically adjusted in proportion to a 
fractional power of the radius of curvature.

Strips. Lengths of sides are automatically adjusted, but some vertices always 
coincide with moldlines. You set the number of faces in each strip.

Forced nodes. Similar to Strips, except that rather than using moldlines, you 
preselect the locations of certain vertices and the numbers of sides between 
vertices.

Strips

At the Panels prompt, enter the number of panels in each strip, counting 
clockwise from bottom center, and separating the numbers by commas 
without spaces. For symmetrical bodies, it is only necessary to enter data for 
one side.

If you provide fewer numbers than there are strips, the last number you enter 
is applied to all the remaining strips. Thus, if you have a half-section with 
four strips (ie 5 moldlines) and you enter 3,5,4 at the Panels prompt, the arc
between M1 and M2 will be broken into 3 panels, that between M2 and M3 
into 5, and those between M3 and M4 and M4 and M5 (the top centerline) into
4 each.

The purpose of this option is to preserve moldlines when they represent visible
breaks in the surface (eg, the chines of a boat hull) so that the mesh does not 
chamfer the breaks.

Forced nodes

Nodes are the vertices or corners of the polygon. You can control the location 
of individual nodes and the number of panels between selected nodes. If you 
select the Forced nodes option LOFTSMAN prompts for up to five nodes whose
location you can set.

In each case, you first enter the number of sides between the preceding node 
and the one you are defining. On the next line, you enter the Y and Z 
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coordinates of the node. It is not necessary to define the bottom center or top 
center points, but you must enter the number of nodes in the segment ending 
with the top center point.

Obtain the exact coordinates of the desired nodes beforehand, using  Misc > 
Body info > BL/WL. If you enter coordinates of a point that does not lie on the 
perimeter of the section, LOFTSMAN finds the point on the section nearest 
that point, which may differ slightly in WL or BL from the point you intend.

If you want no panels between two forced nodes, you can enter either 0 or 1 
for the panel count; in either case LOFTSMAN will insert a straight line 
between them.

For symmetrical bodies, LOFTSMAN prompts for forced nodes on the 
starboard side only. For asymmetrical bodies, LOFTSMAN prompts for both 
sides.

Meshing bodies

A mesh consists of a series of paneled normals whose vertices are connected 
by longitudinal lines. In order to make a mesh, you must specify the same 
information as for a paneled normal, and, in addition, the longitudinal 
spacing of sections and the fore and aft limits of the mesh.

Spacing options

LOFTSMAN provides five basic options for automatic longitudinal spacing of 
sections in a mesh. Two provide equally spaced sections, while the three 
others use a so-called cosine spacing.

Cosine spacing places points close together near one end or both ends of the 
specified range, and farther apart elsewhere. The spacing of wing section 
coordinate stations in an .SD file is an example of a cosine spacing with 
compression at both ends.

Equal intervals causes sections to be placed at equal distances from one 
another. You specify the number of intervals you want. If you want a mesh 
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divided into ten segments or bands, it will consist of eleven equally-spaced 
sections.

Fixed step causes sections to be separated by the STEP, which you can set 
through the Settings > Constants form or in the mesh definition dialogs. 
Sections will be equally spaced, but unless the length of the body happens to 
be exactly divisible by the STEP, there will be an uneven step between the 
aftmost station and the one just before it.

Spacing options other than Fixed step are available in LOFTSMAN/P only.

Cosine Compression Coefficient

You can adjust the degree of compression at the ends of a cosine spacing with
the CCC or Cosine Compression Coefficient. The CCC must have a value 
greater than zero, and may be greater than 1.0, which is the default. The 
smaller the value, the less compression occurs, the greater, the more.

To set the CCC select the Settings > Constants form.

Meshing a body segment

To mesh all of a body or a portion between two stations, select 

Mesh > Body > Body segment

or

Body > Segment mesh

Rows is the circumferential panel
count for the half-body, or, in the
case of a non-symmetrical A-type
body, for the entire body.

Columns is the longitudinal panel
count.
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Fore limit and Aft limit set the starting and ending stations of the mesh.

Increment does not directly affect the format of the mesh; but since the 
process of locating node points involves some approximations of curved arcs 
by straight chords, excessively large values of the INCREMENT may lead to 
waviness in the longitudinal lines of the mesh. It may also happen, in forming 
patches (see Chapter 16, below), that section point counts will vary if the 
INCREMENT is too large. As a general guideline, the INCREMENT should at least 
be smaller than half the smallest non-zero panel edge length in the mesh.

Step is the distance between sections when Fixed step longitudinal spacing is 
used.

Bunch controls the shrinking and expanding of panel dimensions as a 
function of circumferential curvature. If BUNCH is zero, all panels have the 
same width. The default is 1.0; larger values exaggerate the compression of  
the mesh in areas of tight curvature.

Column spacing controls the longitudinal spacing of sections. 

Row spacing offers a choice of Automatic or Strips. If you select Strips, the 
mesh will be adjusted to preserve moldlines; if you select Automatic, meshing 
disregards the positions of moldlines. Automatic is the more usual choice; 
Strips might be used, for example, to preserve the chines of a boat or seaplane
hull.  To preserve other types of lines, such as intersections between two 
bodies, use a Bounded region mesh rather than a Body segment.

If you select Automatic, enter in Rows the number of circumferential panels. 
For Strips, enter a series of numbers, separated by commas, representing the 
number of panels in each successive strip. If you enter fewer number than 
there are strips, the rest of the strips will get the last number in the list.

Start row and Stop row can be used to mesh a selected group of panels.

By default, the starboard side of the body is meshed. To mesh the port side 
select Port. This is normally unnecessary, since sides can be conveniently 
mirrored in the CMARC input file.

Portions of a compound body that are not in contact cannot be meshed in a 
single operation. They must be meshed separately up to the point at which 
they meet, and thereafter can be meshed as a single body.
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15. Meshing for CMARC or VSAERO

Basic body and wing meshing functions are described in the preceding 
section. The following functions produce formatted meshes for Pmarc-12, 
CMARC and VSAERO input files. They are available only in LOFTSMAN/P.

Automatic meshing

LOFTSMAN has a limited ability to mesh complete geometries, including 
bodies and wings, and to directly create ready-to-run CMARC input files 
complete with wakes. 

Select

Mesh  > Create 

LOFTSMAN prompts for a fuselage row count, a wing chordwise point count, 
and starting and ending X-axis stations on the model. Default values are 
provided. If multiple wings are present, chordwise and spanwise panel spacing
are proportional to those used for the largest wing. Spanwise spacings can be 
overridden, however, if you check the box captioned Prompt for wing spacings.

If you check Verbose, various prompts will appear, for instance asking 
whether you want to provide root fillets for wings for which a fillet definition 
file is present. If Verbose is unchecked, default actions are performed 
automatically. 

Right-click to view a pop-up menu of options. Select the first one, Auto mesh. 

Most arrangements of a single or compound body and one or more wings 
(including fins, ventrals, etc) can be automatically meshed, provided that 
wings do not intersect one another, even inside the body. Intersecting wings 
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must be meshed separately. The innermost break ribs of all wings must be 
located entirely within the body.

Automatic meshing cannot deal with multiple bodies that do not intersect, for 
example a fuselage and a wing-mounted engine nacelle. In such cases, split 
the wing between the bodies and mesh the body+wing assemblies separately.

When generating a wake, LOFTSMAN starts at a wingtip, continues to the 
fuselage side, and then follows panel edges until reaching the aft end. In cases
where the body does not converge  aft to a point, a message appears to warn 
the user to add the circumferential wake segment required to bring the wake 
to the plane of symmetry. 

Each chordwise panel edge in an auto-meshed wing is generated as constant 
fraction of the straight-line distance from each point in the wing root to the 
corresponding point in the wing tip. As a result, the root intersection's 
deviations from the XZ plane propagate spanwise, fading out toward the tip. In
some instances, such as swept wings with highly distorted root intersections 
or wings with complicated planforms and several midspan breaks, the 
resulting mesh may be excessively distorted. In those cases it is advisable to 
model the wing as a short stub ending with an orthogonal section. The 
balance of the wing can be meshed separately and edited into the IN file.

LOFTSMAN also provides a large repertory of meshing tools for situations that
cannot be handled automatically.

Transition meshes

To create a transitional mesh between any polygonal section and any other 
polygonal section of the same number
of vertices, first save or keep the fore
and aft sections. The sections may be
paneled normal or paneled Z-hinged or
Y-hinged oblique, and will usually
contain forced nodes (if they are
normal sections and don’t include
forced nodes, then there is no reason
to use this procedure; use Mesh > Body
> Body segment instead).

Then select

Mesh  > Body > Transition
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Give the names for the fore and aft sections and the number of panels to be 
inserted between them. Select a spacing type, and, if you have selected Fixed 
step, be sure that the default step is the one you want. 

Wing roots

When a wing meets a body,
panel nodes should coincide
along the  intersection.
LOFTSMAN will automatically
generate panelings around such
an intersection. The intersection
itself may be defined either as a
filed line or by reference to the
wing file; it may be complete or
partial, and the body may
extend beyond the wing at either
end or both ends, or at neither.

The mesh consists of up to four regions:

The fore transition extends from the fuselage nose, an arbitrary station or 
previously filed section ahead of the wing back to the station of the wing 
leading edge.

The aft transition extends from the station of the wing trailing edge to an 
arbitrary station or previously filed section behind it, or to the fuselage tail 
end.

The root lower region extends from the bottom centerline of the body up to the
under surface of the wing, and from the wing’s leading edge to its trailing 
edge.

The root upper region extends from the wing upper surface to the top 
centerline of the body.
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The fore and aft ends of the transition regions can be specified either as 
stations, in which case a default paneling is used, or as files, in which case 
the user can force nodes or specify a starting or ending section taken from 
another patch.

Select 

Mesh  > Body > Wing root

The dialog presents a number of choices and requests several parameters. The
radio-button choices are:

One side/Both sides/Between These terms concern the spanwise 
location of the body or bodies with respect to the wing. Usually, a fuselage is 
on the plane of symmetry and at the inboard end of the wing. Body sections 
normal to the airplane's longitudinal axis are used for meshing. This is the 
One side case.

When the body is a boom or nacelle and the wing passes through it, vertical 
panel edges are rotated about the Z axis to align them with the spanwise 
panel edges on the wing. In this case, the Both sides option should be used. 
In addition to meshing the body, LOFTSMAN creates two new wing files 
representing the inboard and outboard panels. 

Between provides for a situation in which bodies are located at different 
spanwise locations along a wing, as might be the case with a fuselage and a 
boom, tip tank or engine nacelle. Both bodies are loaded simultaneously, and 
the facing sides are meshed. If the wing panel does not extend beyond the 
outer body (eg a tip tank) the outboard side of the outer body is also meshed. 
If the wing passes through the outer body, LOFTSMAN creates two new WI 
files which duplicate the geometry of the original wing but divide it at the 
plane of symmetry of the outer body. The outer side of the outer body, and the
outboard wing panel, can be meshed by loading only those files and meshing 
them in the usual way, using the Both sides option for the body in order to 
ensure that its sections coincide with those of the inboard side.

Mesh around/Mesh through. If you select Mesh around, the mesh breaks at 
the leading edge and the paneling is carried around the root like a river 
flowing around an island. The mesh is
distorted but preserves proportional
spacing. This type of meshing can
produce poor  neighbor relations
between panels at the leading edge,
particularly with thick airfoil sections,
where the inflection is large and
abrupt.
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Mesh through, on the other hand, leaves the paneling undistorted. The root 
may eclipse some mesh nodes, and the remaining nodes are connected to 
points along the root section. This method may produce a few small triangular
panels adjacent to the root, but they will have a less detrimental effect on 
computational analysis than the
sudden inflection at the leading edge
that occurs with the Mesh around
technique.
You must specify the total number of
rows of panels in the mesh. If you
wish, you can also specify the number
of panels you want "before" the wing intersection at the leading and trailing 
edges. “Before” refers to the order in which coordinates are listed, namely 
clockwise as seen from the front, starting at the bottom center. Normally, 
however, you should enter zero for the "before" values and LOFTSMAN will 
automatically apportion the panels into two streams.

By checking Keep leading edge as or Keep trailing edge as, you can “keep” the 
section at the leading or trailing edge of the wing for later use. For example, a 
fuselage with tandem wings requires a transition mesh between the trailing 
edge of the fore wing and the leading edge of the aft wing. This transition 
mesh can be created by the root meshing routine if the section at the far end 
of the transition zone has been saved in advance. Sections are kept only when
the root mesh is saved, not when it is merely displayed. If you do not specify a
filename but you do check either of the “keep” options, LOFTSMAN will use 
“le” and “te” as default filenames.

Checking Keep upper patch edge and/or Keep lower patch edge causes 
LOFTSMAN to save those edges with the section spacing used for the root 
mesh. If you do not specify a filename but you do check either of the “keep” 
options, LOFTSMAN will use “up.ml” and “lo.ml” as default filenames.

Checking Split aft transition along WSL causes the regions above and below 
the  line emanating from the wing trailing edge to be saved as separate 
patches. This is required for a "cape wake" (see below).

When a wing root mesh involves a curved wing panel, the innermost rib of the 
wing must be located within the contours of the fuselage. This requirement 
does not apply to ruled wings.
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Bounded regions on bodies

Enter

Mesh > Body > Bounded region

A "bounded region" is a patch whose upper and lower edges are defined by two
lines that are usually portions of moldlines or of the intersection between two 
bodies or between a body and a wing. They may either have been saved 
beforehand or
interactively
identified. The
points in the two
files need not be
identical in
number or
station, but the
two lines should
start and end at
the same
stations.

The spacing of
bands within the meshed region can be set either with the usual cosine and 
equal spacings, or may be made to match the spacing of either the upper or 
the lower boundary line or both.  

If you select Match both, you must also select either Adjust lower or Adjust 
upper. These options determine at 
which edge of the patch the 
triangulated transition strip will be 
inserted. The bulk of the panel 
mesh will match the point count 
and distribution of the end opposite 
the one at which the adjustment 
occurs. For instance, if you are 
meshing a region between vertical 
and horizontal stabilizers with 23 
points along the vertical stabilizer 
root intersection with the fuselage 
and 20 points along the horizontal 
tail root intersection, you would 
most likely select Adjust upper. The 
result would be a patch meshed 

with 20 chordwise points except for the final strip at the base of the vertical 
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stabilizer, which would be triangulated to connect to the vertical stabilizer 
mesh and would be stored as a second patch in the same patch file.

The basis of the decision to match the fuselage meshing to the horizontal 
rather than the vertical tail might be the fact that for most analyses the lift 
coefficient of the vertical tail is zero or quite small, and so panel mismatches 
between it and the fuselage will be less significant than panel mismatches 
between the horizontal tail and the fuselage might be.

Match both is an extremely useful option, but it usually requires some 
manual editing of the intersection lines by way of preparation, to ensure that 
their starting and ending stations coincide. If, as is usually the case, it is 
necessary to replace a point in the intersection list with one at a different 
station, use Body >Intersection > With wing, Single FS = to obtain single points 
on the intersection line.

If both the upper and lower edges of a bounded region lie on the body's plane 
of symmetry, and the body's plane of symmetry lies on the negative side of the
XZ plane, then the port rather than the starboard side is meshed.

Creating bounded region patches interactively

The complete model, including all bodies and wings, should be loaded. Select

Mesh  > Create

LOFTSMAN asks for a girthwise panel count for the fuselage. The default is 
20. After you accept the default or enter a different number, LOFTSMAN 
displays the model with all wing-body intersections and with vertical body 
cross-sections at the fore and aft ends of each wing-body intersection. To 
create a patch within any of the quadrilateral regions formed by these lines 
(triangular regions are treated as quadrilaterals with one zero-length side), 
right-click to obtain the menu, select Select body region, and left-click on a 
region. It is also possible to select the lower, upper, fore and aft edges by 
clicking on the appropriate lines and then selecting Make patch. The bounded
region dialog appears and allows you to specify row and column counts and 
spacings. Flow around meshing is used, and it is up to the user to ensure that
point counts and spacings on neighboring patches match.

Boundaries that are not moldlines or wing-body intersections, and vertical 
cross-sections at any location, may be added and used as patch edges. For 
example, to preserve the intersection of a bubble canopy and a body, first 
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obtain and save the intersection line (Body > Intersection > With second body). In 
the drop-down menu, select Import a filed line and give the filename. 
Similarly, a body cross-section can be added by selecting Add a section, 
clicking at the approximate location of the desired frame and then (optionally) 
entering the precise FS.

To mesh a wing from the wing-body intersection (if any) to the tip, select 
Select wing region and left-click on the wing.

If you want to change the parameters of the selected region, you can first hit 
<Esc> to discard the currently displayed patch, then return to the bounded 
region dialog, which will retain the previous information.

To delete a previously created patch, use Delete patch on the pop-up menu. 
Patches on bodies can be identified in any view; patches on wing, however, 
must be identified in an orthogonal view, that is, top or bottom for horizontal 
surfaces, port or starboard for vertical surfaces.

Patches created interactively can be saved singly or all together.

Surface grid from 4 edges

It is sometimes necessary to mesh in an oddly-shaped region already 
surrounded by existing patches. In this case, you must first save or keep the 
four edge point lists, using Edit > Patch > Modify by command, Get edge #. Then 
select Mesh > Body > Surface grid from 4 edges and supply the names of the edge
files. 

LOFTSMAN produces a grid that matches the edge points and conforms to the
surface contours. The grid density matches the higher point count in each 
edge pair.
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Wing/body wake mesh

The commonly used method of defining a wing/body wake in the CMARC 
input file is to specify a wake separation line and then, using a single &SECT1
line with INMODE = -1, to shift a copy of it about twenty chord lengths 
downstream to fix the aft limit of the wake mesh. CMARC then interpolates a 
mesh with the row count and spacing that you specify. The resulting "flat" 
wake gives sufficiently accurate results in almost all cases.

This approach does not work for fuselages whose sides run parallel, because 
some wake panels would have zero area, or for those whose sides diverge aft of
the wing root, because longitudinal wake lines parallel to the centerline would
intrude into the fuselage. It may also fail when the model is yawed. In these 
cases, LOFTSMAN can be used to define a wake mesh to replace the default 
mesh that would otherwise be generated by CMARC.

The reason this limitation exists is that the leading edge of the wake patch 
extends from the wingtip to the tip of the tail. A wake patch edge running 
along a parallel-sided fuselage produces zero-area panels, which are not 
permitted, while a fuselage that expands behind the wing results in wake 
edges that penetrate the body, also forbidden. The wakes defined by 
LOFTSMAN to deal with these situations is remapped in such a way as to 
provide finite-area wake panels alonside a parallel-sided or expanding 
fuselage.  

If a defined wake mesh is required, it is supplied automatically during Auto 
meshing. At the same time, a file called WAKEn.WSL is created for each wing 
on the model that requires a defined wake, n being the ordinal number in 
cases where several wings require defined wakes.

Wakes defined during auto meshing use default values for the wake definition 
parameters. If you wish to change those values, select

Mesh  > Wake > Create Wake from WSL points

The ensuing dialog prompts for the following items:

WSL file Enter the name of the file containing the wake separation line 
points. This file, which has a WSL extension, may be created during auto-
meshing of a model, extracted from a model in POSTMARC (see POSTMARC 
documentation for instructions), or created from a set of patches that 
minimally includes all edges of the wake. The point order may begin at the 
wingtip or at the aft end of the wake, typically on the plane of symmetry.
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Label Enter an optional name that will appear in the .IN file after the
&WAKE1 line.

Aft end FS Enter the aft limit of the wake mesh. If you leave zeroes, it will
be placed 20 chord lengths downstream.

Rows Enter the desired number of wake rows; the default is 20.

Downwash If you wish the wake sheet to deflect upward or 
downward with respect to the waterline plane of the model, enter a value in 
degrees. A positive value depresses the wake mesh below the wing plane. The 
downwash angle is, for all practical purposes, the negative of the angle of 
attack at which the case will be run.

Yaw Angle If the wake is being prepared for a yawed case, enter 
the yaw angle in degrees. Nose-left yaw is positive.

Column squeeze Wake columns can be exponentially compressed in the 
spanwise axis in order to keep the body side of the wake from spreading too 
far spanwise. Because excessive expansion of the body wake distorts the 
results, it is desirable to keep the body portion of the mesh as close to the 
body side as possible. This usually requires an entry in the range of 2.0 to 3.0.
If the body sides diverge aft of the wing, however, smaller values may be 
required to prevent the wake filaments from crossing one another or intruding
into the fuselage. 

Port wake LOFTSMAN tests the order of wake separation line 
points to ensure that they run centerline-to-wingtip. To ensure that no 
mistake is made here, you must inform LOFTSMAN if the wake you want to 
generate lies on the left (port) side of the body. 

Cape wake The "cape" wake is an alternative type of predefined 
wake that is useful for afterbodies of convergent-divergent shape. Its use 
requires several steps, which are described in a separate section below.

When you click OK, the wake mesh appears on the screen. (If no mesh 
appears, the reason is most likely that the screen is not properly scaled. Select
Body > Body lines and generate the wake again.)
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The wake separation line is highlighted in order to make it easier to check for 
crossing of wake filaments. If there is any doubt about possible crossings, 
zoom to inspect them more closely.

When you are satisfied with the wake mesh, select

File  > Save > Save current result

Check Patch and CMARC. The mesh will be saved in a .WAK file with the 
name you specified.

The WAK file must now be edited into the .IN file. Be sure your &WAKE1 line 
calls for a rigid wake -- that is, IFLXW=1. The &WAKE2 lines, which define the
wake separation line, are already present in the .IN file. LOFTSMAN's wake 
mesh definition, which omits the separation line, comes immediately after it, 
replacing the default &SECT2 line.

Wakes generated by LOFTSMAN cannot be time-stepped. If the wake 
separation line requires a non-standard wake in the first place, time-stepping 
it downstream is sure to produce a collision of the wake and the body.
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Cape wake

The cape wake differs from the standard type of CMARC wake in that its 
leading edge (side 1, viewed from above) is attached only to the trailing edge of
the wing, while the inboard side of the wake (side 2) is attached to the side of 
the body. The inboard edge of the wake coincides with the same row of panel 
edges on the body side as a wake separation line would. Neighbor relations 
must be explicitly cut along that line; CMARC does this automatically for a 
conventional wake, and LOFTSMAN does it for auto-generated wakes. The 
purpose of the cape wake is to avoid the extreme compression of panels that 
occurs along the fuselage side with the standard wake geometry, and also to 
permit attaching a wake to a convergent-divergent, or extremely divergent, 
fuselage.

Neighbor relations can be most conveniently cut by splitting any patches 
crossed by the wake separation line along the line and placing the two 
resulting patches into different assemblies. Patches may be split using 
LOFTSMAN's patch editing options (Edit > Patch > Modify). When LOFTSMAN 
creates a cape wake, patches are automatically split as needed.

Diaphragms

The word "diaphragm" is used here to refer to a
cross-sectional barrier within a duct. Such
barriers are used by CMARC to simulate flow
conditions through jet engines, cowlings, etc.

The inner surface of a duct is modeled by
LOFTSMAN in the same way that an outer
surface would be. When meshing a diaphragm,
load the inner surface .LFT file or files only; do
not attempt to combine the inner and outer surfaces of a nacelle or other duct
into a compound body.
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A diaphragm consists of a single patch with three (or more) rows and as many 
columns as are produced by the basic points defining the perimeter of the 
duct throat. The full patch definition consists of only two sections. The first is 
the perimeter of the diaphragm; the second is its center and consists of as 
many repetitions of the same point as there are points in the perimeter. A 
rectangular patch maps to a circular or semicircular diaphragm thus:

To create a diaphragm patch, select

Mesh > Body > Diaphragm

The circumscribing section can be defined either as a station in the current 
body or else as a filed set of coordinates. LOFTSMAN prompts for the FS, the 
number of rows, and the number of panels in the perimeter. Symmetrical 
sections whose plane of symmetry is at BL0.0 are depicted as half-sections; all
other sections and diaphragms must be fully developed. Diaphragms may only
be saved as patches, not as DXF or plain files.

The radio-button choices Inlet and Outlet control the patch reversal flag IREV 
in the CMARC input file. IREV should be -1 for forward-facing diaphragms (ie 
inlets) and 0 for aft-facing ones.

Flow around inlets can be realistically modeled by specifying appropriate 
velocity ratios on inlet diaphragms. Because CMARC does not provide a 
means of containing exhaust plume flow, however, an outlet velocity greater 
than that on neighboring exterior panels may produce unrealistic effects even 
if a cylindrical wake is provided to contain the exhaust. Outlet velocities 
should therefore be set equal to that of the free stream or, alternatively, 
diaphragms can be omitted altogether and the full length of the duct modeled,
allowing air to flow through as though there were no engine in the duct.

To assure constant velocity across in inlet diaphragm, assign it to a separate 
assembly in the input file; this has the effect of preventing pressure and 
velocity averaging across the perimeter of the diaphragm.



3.107

True internal-flow models require inlet and outlet diaphragms to establish the 
rate of flow. For numerical reasons, these patches may not contain any 
triangular panels. For rectangular patches this requirement is easily met, but 
for ones of more complex shape LOFTSMAN provides an option for isolating 
the triangular panels in an island in the center of the diaphragm. The island, 
which is defined as a separate patch, can be made arbitrarily small by setting 
its radius as a fraction of the radius of the complete diaphragm. Neighbor 
relations should be severed between the diaphragm and its surroundings in 
the .IN file; this is most easily done by associating the diaphragms with a 
different assembly than the islands and the rest of the duct.

If detached objects are defined within an internal-flow model, it appears that 
the no-triangles rule may be ignored.

Propeller disk

A propeller may be simulated as a disk with specified inflow and outflow 
velocities. VSAERO includes specialized routines for simulating a propeller 
wake, which include definition of a “jet wake” to insulate the surrounding free 
stream from the higher velocities within the slipstream. CMARC does not 
provide this feature, and will not produce reliable predictions using a prop 
disk. 

The propeller disk is automatically joined to the surface of the body at a 
specified station on the
spinner. In order to ensure a
perfect joint, either the spinner
mesh should have a seam
(between two patches) at the
propeller plane; or the user
should edit the spinner patch
to ensure that the coordinates
of the inner diameter of the
prop disk and those of the
corresponding station on the
spinner are identical; or the X
coordinate of a suitable station
on the spinner mesh should be
used as the fuselage station of the prop disk. The spinner at the propeller 
station should be round or nearly so.
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The disk model consists of two patches in the shape of a flattened doughnut. 
They touch at their inner and outer edges, and form a cross-section 
resembling a thin lens. The selection of a mesh density is up to the user; a full
cosine spacing is used in the radial direction.

To generate a prop disk, first load the data file(s) for the body or nacelle and 
then select

Mesh  > Body > Prop disk

Supply the information requested in the dialog box. Note that the radius of the
propeller, not its diameter, is wanted. The number of sectors should be twice 
the circumferential panel count on the half-body, so that the prop and spinner
nodes coincide. The same INCREMENT should be used for the prop disk mesh 
and for the body mesh.

LOFTSMAN will automatically generate starboard and port sides of the prop 
disk if the plane of symmetry of the body is not at BL0.0 and/or the body is 
identified in the .LFT file as non-symmetrical. Otherwise only the starboard 
side is generated.

Hull meshing

Meshing a hull  below a given waterline is a special case of meshing a 
bounded region of a body. 

First, save or keep the waterplane intersection line on the hull (Body 
>Waterplane) as a "plain" file. LOFTSMAN will provide a ".WPL" extension for 
the file.
 
Next, save or keep the keel line. Select

Body > Body lines

Select the keel line, which will normally be "M1" (that is, the first moldline 
counting from the bottom). If you save it, it will have a file extension of ".ML". 

If you wish to verify the appearance of the lines, you can import them (File  > 
Import object).
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Now select

Mesh  > Wing  > Bounded region

Set the mesh density and panel spacing type. In this instance, both lines will 
have been saved as points at closely spaced intervals, and so the option of 
matching one or the other of the lines will not apply.
 
For Lower boundary enter the name of the keel line file, including the 
extension. For Upper boundary, enter the name of the waterplane intersection
file. Number of rows is the circumferential panel count between the keel and 
the waterplane.

Because LOFTSMAN normally assumes bilateral symmetry, waterlines for 
heeled cases, which typically hook back upon themselves at the stern, will not
mesh properly unless you manually edit them to remove the reversal of 
direction. 

Wing segments

Wing meshes are analogous to body meshes. You can mesh an entire wing, or 
a segment between two buttlines, by selecting

Mesh  > Wing  > Spanwise segment

or

Wing > Segment mesh
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Reverse section order causes sections to be ordered from tip to root rather 
than from root to tip. This order is appropriate for vertical tails, which can be 
thought of as horizontal starboard wings that have undergone a positive 
rotation of 90 degrees. Since the points on the starboard surface are listed 
from leading edge to trailing edge -- that is, in reverse -- in order to match the 
order of sections on the fuselage, the section order on the vertical surface 
must also be reversed to cancel the first reversal and produce a surface that is
right side out.

Note that the chordwise panel count refers to only one surface, but the mesh 
will wrap around and return to the trailing edge, including both upper and 
lower surfaces. Thus, a mesh for which you specify ten chordwise panels will 
actually have twenty panels in all.

Note also that the breakdown into spanwise panels does not take in to 
account any intermediate geometry breaks in the basic wing definition (ie in 
the .WI file). To force panel breaks to coincide with geometry breaks, either 
panel the wing in separate segments or use the Draft meshing option instead.

To panel a wing in separate segments whose ends coincide with the break 
ribs, check Mesh panel # and use the up and down arrow buttons to select 
the number of the panel. Panels are numbered from the innermost to the 
outermost, beginning with 1. Panels must be meshed one at a time.

Wing bounded regions

To create a mesh of a wing segment that is bounded by lines not lying in the 
buttline plane, you must first save the bounding lines in the same way as for 
a bounded region of a body. In this case, however, the bounding lines will run 
generally chordwise. 

The most common example of a wing bounded region is a full or partial wing 
with a wing-body intersection at its root. The Use station […] + current body 
root option provides a shortcut for this situation. When this selection has 
been checked, it is not necessary to provide previously defined inboard and 
outboard rib file names. LOFTSMAN obtains the root intersection line and the 
default rib coordinates at the spanwise station you specify. The tip station is 
provided as the initial default. If it has been replaced by another value and 
you would like to restore the tip value, delete the value in the edit field; 
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LOFTSMAN will replace it with the tip station. LOFTSMAN will also use the tip
station as the default if you specify only an inner boundary.

If you set Skew secs to a non-zero value, the sections nearest the wing root 
will be adjusted to provide equal panel widths. The default is 2, which 
provides three columns of adjusted panels.

Sometimes the shape of the wing-body intersection, or the dihedral angle of 
the wing, is such that Skew secs does not provide a usable mesh. In such 
cases, enter 99 for Skew secs or check Skew all.. LOFTSMAN will space 
sections proportionally across the entire span of the requested region.

When a body, such as a nacelle or a tail boom, is not on the plane of 
symmetry, the Use station […] + current body root option meshes the portion 
of the wing on the side of the boom or nacelle on which the given end station 
lies. If the end station is beyond either tip, the tip is used.

When a curved wing is meshed with the Use station […] + current body root 
option, the innermost rib of the wing must lie within the contours of the body.
This restriction does not apply to ruled wings. 

To enter a spanwise station rather than a file name in the Inboard edge or 
Outboard edge field, precede the station with a pound sign, eg #14.275.

Reverse section order causes sections to be ordered from tip to root rather 
than from root to tip. This order is appropriate for vertical tails, which can be 
thought of horizontal starboard wings that have undergone a positive rotation 
of 90 degrees. Since the points on the starboard surface are listed from 
leading edge to trailing edge, that is, in reverse, the section order must also be
reversed to produce a surface that is right side out.

Reverse point order causes section points to be listed upper-surface first. If 
the bounding edges of the patch are ribs, they should be saved with normal 



3.112

point order; if you specify Reverse point order both for the ribs and for the 
patch, the end ribs will come out in the default order while the intermediate 
ones remain reversed.

You can also reverse section and point order, or swap rows and columns in 
order to re-orient panel numbering, using Edit > Patch on the main menu.

Normally, Starboard side of vertical panel should be checked for vertical 
surfaces on the place of symmetry, since only half of the surface needs to be 
defined.

Special point spacings can be produced by matching an inboard or outboard 
line or both. Typical situations calling for this treatment might be T-tails and 
wing panels between a fuselage and a winglet. In such cases, you must 
construct and save or keep the inboard and/or outboard sections or 
intersections before generating the mesh for the wing panel.

If you check Match both, you must also select either Adjust inboard or Adjust 
outboard. These options determine the end of the panel at which the 
triangulated transition patch is created. The bulk of the panel mesh will 
match the point count and distribution of the end opposite the one at which 
the adjustment occurs. For instance, if you are meshing a T tail with 15 
points along the fin’s intersection with the fuselage and 14 points, differently 
spaced, at its intersection with the horizontal stabilizer, you would most likely
select Adjust outboard. The result would be a fin meshed with 15 cosine-
spaced chordwise points except for the strip immediately below the horizontal 
surface, which would be triangulated to connect to the horizontal’s 
intersection with the fin and would be stored as a second patch in the same 
patch file. You would create the portion of the fin above the horizontal 
stabilizer, if any, by a similar operation.

For meshes between boundaries that are closely spaced, for instance between 
a fuselage and a nacelle, on a boundary-layer diverted between a fuselage and 
an inlet duct, or on a pylon between a wing and a body or nacelle, it may be 
preferable to select Interpolate between boundaries. Whereas a normal 
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bounded region mesh uses default sections with adjustments only at the 
ends, an interpolated mesh uses proportional spacing between end points for 
all sections. The specified boundaries must  have the same number of points. 

Bridging between patches

A patch may be created to fill a gap between two existing patches. The 
bridging patch is mathematically interpolated; its intermediate points do not 
necessarily lie on the lofted surface. Bridges are useful for joining winglets to 
wings, for creating generic fillets, and in other cases where surface contours 
are arbitrary or undefined or have a minor influence on the CFD analysis.

Select

Mesh > Wing  > Bridge between patches

Select the desired patches and the edges to be joined. Edge point counts must
match, and you cannot bridge one edge of a patch to another edge of the same
patch. If the relationship of the patches is such that the upper surface of one 
is continuous with the lower surface of the other, check Invert for one of them.

This procedure is in the wing mesh menu because its most frequent 
application is to wing panels; but it may be used with any type of patches. 
Bridges may be inserted between two wing patches, between wings and 
bodies, or between body patches.
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Skeleton wing patch format

CMARC allows you to interpolate sections for both dimensions of a patch; that
is, you can enter one set of basic points and instruct CMARC to spline it and 
interpolate a new set of panel corners with a different spacing or point count. 
This facility is useful for wing patches, not only because it produces a patch 
description that is quite concise, but also because it allows you to define a 
wing in a general way and then to redimension its mesh by means of small 
adjustments in the CMARC input file. To change the spanwise paneling, edit 
TNPS (in the &SECT1 lines); for chordwise paneling, edit TNPC (in the 
&BPNODE lines). Note that because TNPC, rather than the basic points given 
in the section files, determines the chordwise panel count, the full 30-station 
break rib definitions can be used. 

To use the abbreviated format for wing patches or bounded regions, select Use
skeleton format for wing in the Save dialog. If you do not anticipate wanting to
change the chordwise panel count later, you can set the desired number of 
chordwise panels in the mesh definition dialog. Alternatively, you can use the 
full 30 chordwise stations and edit the patch later to change the panel count. 
In general, it is a good idea to use the largest foreseeable chordwise panel 
count when defining an abbreviated patch; but there is no need to define more
points than the largest number you anticipate using.

When you intend to save a wing bounded region mesh using the skeleton 
format, check Use tip and current body root. Only the full exposed semi-span 
can be meshed in skeleton format. 

Spanwise panels are allocated to segments between wing break ribs in 
approximate proportion to the segment span. Equal spanwise panel spacing is
used except in the extreme inboard and outboard segments, which have half-
cosine spacing, or if the wing has only one panel, in which case the spacing is 
full cosine. Chordwise spacing is always full-cosine.

The abbreviated patch format has a break point in the middle of the section 
definition, just after the leading edge point. This allows you to select different 
panels counts on upper and lower surfaces. You can add more breaks if you 
want to change the mesh density locally, for instance ahead of a flap slot. 
Consult the CMARC documentation for more detail about patch input. 

The main disadvantage of the brief format is that it is impossible to edit 
individual points manually, because the basic points given in the patch listing
are not the points that are actually used in the analysis. To obtain the actual 
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points, you have to consult the .OUT file after a geometry-only run. 
Furthermore, the skeleton format is also incompatible with the automatic 
input file assembly functions (Edit > Patch > Assemble).

A tip patch is automatically provided. It has a flat cross-section and is three 
panels wide. The value of MAKE in the tip patch is 1, meaning that the tip is 
attached to patch number 1. If this is not correct, the value of MAKE must be 
changed.

Deflected flap

A patch can be made of a surface or segment of a surface with a deflected 
sealed plain flap.

Select

Mesh  > Wing > Deflected plain flap

You must provide locations of the
flap hinge line, inboard and
outboard buttlines (or waterlines, if
the surface is vertical) and an
angular deflection. A positive
deflection is trailing-edge-down on a
starboard horizontal surface. You
must also define the desired mesh
density.

In order to simplify both wake definition and blending of the mesh with its 
neighbors, LOFTSMAN optionally does not deflect the endmost ribs of the flap.
The Align inboard and Align outboard options permit you to control the use of 
this feature. The triangular filler elements created at the end sections do not 
significantly affect lift, stability, or roll late calculations.

By checking Use stabilizer defaults, you can choose to align the inboard end 
of the flap (that is, hold the end rib undeflected) but not the outboard end. In 
addition, LOFTSMAN uses the intersection of the surface with the current 
body as the inboard boundary of the mesh. 

Section order may be reversed for vertical surfaces.
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Plain-flapped segments always receive full-cosine spanwise and chordwise 
spacing. The chordwise spacing is modified to make a series of panel edges 
coincide with the hinge line. 

CMARC provides an alternative method of simulating a deflected flap, namely, 
mathematically tilting the panels corresponding to the flap area. Up to 
deflections of about 15 degrees, this technique provides good accuracy and is 
more convenient than meshing a deflected flap with LOFTSMAN.

Slotted flap

LOFTSMAN meshes an existing slotted flap by modifying the wing section to 
simulate the cove vacated by the flap as it deflects. The exact shape of the 
cove surfaces is not important, since the slot flow probably does not adhere to
them in any case; but it is necessary that the lower-surface entry and the 
upper-surface lip be at the appropriate chordwise stations, and that the 
interior surface of the upper lip form a reasonably shallow angle with the 
outer surface and that it be thick enough to avoid confusing CMARC, which 
does not like paper-thin surfaces.

To mesh a slotted flap, first define a flap using the flap definition procedures 
described in that section of the manual. Make the wing the current and 
primary .WI file. Then select

Mesh  > Wing  > Slotted flap

and select the flap WI file.

Supply the following data:

Upper lip x/c Enter the fractions of the wing chord, for both inboard 
and outboard ends of the flap, at which the upper surface lip is located. 

Lower lip x/c Enter the fractions of the wing chord at which the lower
surface lip is located.

Lip locations are stored in the .SD files for the airfoil sections defining the 
flap. When you specify a flap file name LOFTSMAN gets the lip location 
information and places it in the appropriate edit fields. Usually you will be 
able to leave these items unchanged.
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Flap panels chordwise Enter the desired number of rows of panels in 
the flap patch. As is the case for a wing, this is the number of rows on one 
surface only.

Flap panels spanwise Enter the number of columns of panels over the 
complete width of the flap.

Wing panels (full chord) Enter the number of panel rows used for the full 
wing chord on portions of the wing neighboring the flapped section. 
LOFTSMAN selects a lesser number of rows in the truncated section in order 
to facilitate the transition between patches.

Flap nose X, Y Enter the location, in percent of wing chord with 
respect to the slot upper lip, of the flap leading edge in its deflected position. 
The initial default is one percent of chord below the upper lip and one-half of 
one percent of chord ahead of it.

Flap deflection Enter the desired flap deflection in degrees.

Supply inboard transition If this option is checked, LOFTSMAN extends the
inboard end of the wing panel a short distance and supplies transitional 
paneling to reconcile the distorted paneling of the flapped portion with the 
standard paneling of adjacent portions of the wing, using the current default 
number of stations. The spanwise station of the end rib is modulo the current 
value of the STEP.
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Supply outboard transition As above, but outboard.

Mesh complete wing If you check this option, the two previous ones 
are automatically checked. Loftsman meshes not only the flapped portion of 
the wing but also the panels lying inboard and outboard of it. If body files are 
currently loaded, the inboard panel terminates at the wing root intersection. 

Yaw angle If the model will be analyzed in a yawed attitude, the 
width of the transition at the downwind end of the flap is adjusted to ensure 
that as wake filaments are convected downstream they do not penetrate the 
model surface. Positive yaw is nose left.

Click OK to create the patches. If you checked Mesh complete wing, two Wing 
Bounded Region dialogs will appear, one after the other. The first is for the 
inboard panel, the second for the outboard. You may adjust the spanwise 
section counts, but not the chordwise point counts.  

LOFTSMAN displays the wing and flap patches in the relative positions you 
specified. They can be saved in the usual way. When saving, don’t bother to 
provide a label; LOFTSMAN labels slotted flap patches as it sees fit.

Once the patches have been added to a CMARC input file, the flap patch can 
be repositioned by assigning it to a separate assembly or component, and 
using the translation and rotation facilities provided in the input file.

Spacing of wing sections

Two special techniques can be used to improve the accuracy of CMARC's 
analysis of wings. One is to omit the wingtip patch. The other is to increase 
the density of meshing near the tip.

If a tip patch is specified, unrealistically high velocities and low pressures 
occur in wing panels adjacent to the tip. This is especially true of 
semicircular-section tips. Because the tip patches are small, these errors do 
not seriously distort the accuracy of the overall pressure analysis. 
Nevertheless, they can usually be eliminated by removing the tip patch 
altogether. So long as the tip is not close to another portion of the airplane, 
this will not cause any difficulty.

CMARC also tends to predict unrealistically high values of the Oswald span 
efficiency factor e when a standard cosine spanwise spacing of sections is 
used. Its accuracy can be improved by increasing the density of paneling near 
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the tip. For example, a wing might be paneled in two patches, the inboard one
having 80% of the semispan and 15 or more panels with cosine spacing, and 
the outboard one having another 10 panels with equal spacing or half-cosine 
spacing compressed at the outboard end. The density of section spacing can 
also be adjusted by changing the Cosine Compression Coefficient (CCC) in the
Constants submenu.

Calculations of induced drag coefficient and e are also influenced by 
chordwise paneling. Because the orientation of the computed lift vector is 
affected by the surface normals of panels near the leading edge, these must be
sufficiently closely spaced to produce a good match to the real leading-edge 
shape. Dense leading-edge spacing is also needed for ice-accretion studies.



16. Editing patches

Viewing patches

Patch files, and patch information from Cmarc input (.IN) files, may be viewed 
by importing them. Select

File  > Import object 

Patches may be displayed transparently or as opaque surfaces. Use 

Settings > Options

and check or uncheck Opaque meshes.

Modifying patches graphically

Terminology

Editable points in meshes may be described as either nodes or points. Nodes 
are corner points in the current working patch or on an edge of a neighbor 
patch. Points are highlighted locations along an imported line, such as an 
intersection, a patch edge or a shared edge.

 

Starting

The LFT and/or WI files for the body and/or wing corresponding to the patch 
to be edited must be loaded in order to provide 3D locations for surface 
points. In the case of wings, if several WI files are loaded the one underlying 
the patch being edited must be the primary wing file. Select File > Set primary
to change the primary file.



 

Select 

Edit  > Patch > Modify graphically

LOFTSMAN presents a profile view with a black background. Only four views 
can be used for patch editing: starboard or port side, and top and bottom. 
Zooming is possible but panning is not.

Some actions can be performed either by hitting keys or by selecting from a 
pop-up menu. Right-click to see the menu. The menu disappears when you 
make a selection or left-click anywhere outside it.

LOFTSMAN allows you to make any changes you like, including illegal ones. It
is up to you to avoid creating zero-area or overlapping panels or perpetrating 
other violations of patch and panel logic.

Selecting a patch to edit

Right-click and choose Select working patch from the menu. If only one patch 
is displayed, it is automatically selected. If more than one patch is displayed, 
place the cursor over the desired patch and left-click. The working patch is 
the only one in which you can make changes.

If you are using a top or bottom view, edges and nodes in the working patch 
that would normally be hidden by the body are not displayed. If another patch
is aligned with the working patch, however, its edges and nodes continue to 
be visible and may be confusing. To declutter the view, select Hide patch while
in a side view and click on the patch you want to hide. Afterwards, you can 
click Unhide to make that patch visible again.

Moving nodes

To move a node, place the cursor over it so that a highlight appears. Press the 
left mouse button and drag the node. The highlight disappears while the node 
is being moved.

To allow only horizontal or vertical movement (for example to keep a node on a
section plane while moving it vertically),  hold the x or y key while dragging 
the node. Do not hit the x or y key before pressing the left mouse button.

To move all nodes within a column proportionally to the one you are dragging,
hold <Ctrl> while dragging the node in profile (not top or bottom) view.



To move all nodes within the patch proportionally to the one you are dragging,
hold <Shift> while dragging the node in profile (not top or bottom) view.

In order for nodes to remain on the model surface, the underlying LFT and/or 
WI files must be loaded. If they are not, node positions cannot be defined in 
three dimensions.

Joining nodes within the patch

To make a node coincide with another node, drag it to the vicinity of the target
node. Release the left mouse button while keeping the node highlighted and 
either hit 'a' (lower case) or right-click and select Snap to node from the pop-
up menu. The highlighted node snaps to the location of the nearest node.

If the nodes are sufficiently close together to start with, it is not necessary to 
move the highlighted node. Just highlight it and snap.

Importing a line to match

To import a pre-existing set of points, such as an intersection, right click and 
select Import edge or line. The points are highlighted

Selecting a patch to match

Right click. From the pop-up menu, select Select neighbor and then click on 
the patch.

Identifying a shared edge to match

Right click. From the pop-up menu, select Select common edge and then click
on any point on the common edge between the working patch and the selected
neighbor. The points on the neighbor's shared edge are highlighted.



Joining nodes to an imported line or patch edge

A point must be highlighted to be eligible for attachment.

To make a patch node coincide with a highlighted point on an imported line or
a neighboring patch edge, drag the node to the vicinity of the target point. 
Release the left mouse button  while keeping the node highlighted and either 
hit 'Shift-A' (uppercase) or right-click and select Snap to point from the menu.
The highlighted node snaps to the location of the nearest edge point on the 
neighbor patch.

If the nodes are sufficiently close together to start with, it is not necessary to 
move the highlighted node. Just highlight it and snap.

Splitting a patch

Patches may be split into two patches along a row or column. 

Right-click and select the appropriate option from the menu. Select the row or
column where the break should occur by placing the cursor on any node 
along that line, so that the highlight appears. 

After the split occurs, you must select a new patch to edit by clicking on it.

Adding a row or column

A row or column is added by splitting an existing one, not by extending the 
boundaries of the existing patch.

Right-click and select the appropriate option from the menu. Then left-click 
anywhere in the row or column you want to split. A new set of nodes is 
interpolated halfway between the existing ones.

Deleting a row or column

Right-click and select the appropriate option from the menu. Then highlight 
any node in the row or column you want to delete and left-click.



Adding links to a transition patch

Adding a link increases the number of points in a row or column. It can be 
done only with patches that consist of a single row or column, and is intended
to make transitional strips between patches having different point counts.

The usual situation is that two neighboring patches have a common edge but 
different point counts. The transition strip must first be split off from the 
patch with the smaller number of edge points. Links are then added from the 
side of the strip on which the split occurred to a node or point on the neighbor
patch or line.

To begin, add a row or column to the transition patch in the panel where the 
new link will be. Then attach one end of the new panel edge to the desired 
node and the other one to the neighbor node or point.

Undoing an action

To undo a change, hit 'u' or right-click and select Undo from the menu. You 
can undo up to 10 past changes in the currently selected patch. Once you 
have selected a new patch you will not be able to "undo" back to the previous 
one, so unless you are infallible it's a good idea to save frequently, and in 
particular to save an edited patch before selecting another one to work on. 

Saving

If you use the "Save results" icon on the toolbar, the File > Save > Save 
current result option on the main menu, or the Save all option on the pop-up 
menu, all patches displayed on the screen will be saved in a single file.

To save only the currently selected patch, right-click and select Save selected.

Stopping

To terminate editing, hit right click and select Quit. When you leave patch 
editing, the changes you have made remain on the screen and can still be 
saved. If you do not erase the screen, you can also resume patch editing to 
make further changes.

All patches left on the screen after patch editing has been terminated are 
treated as a group. It is no longer possible to erase them one at a time with 
<Esc>, and if you save them they are all saved together in one file.



Modifying patches by keyboard commands

Select

Edit  > Patch  > Modify by command

LOFTSMAN offers a number of options:

Reverse point order Reverses the order of points within each section. 
This is one method of reversing a patch.

Reverse section order Reverses the order of sections within the patch. 
This is another method of reversing the patch.

Swap row/col Allows you to identify longitudinal point chains 
on fuselage, or spanwise ones on wings, as sections. This is often helpful 
when manually reconciling the edge of one patch with that of another whose 
sections are differently oriented.

Swap col/row Reverses the effect of the preceding command.

Delete row(s) Deletes the rows indicated by the user. The 
numbers (counting from 1) of the first and last rows in the group to be deleted
should be entered. If only one number is entered, then all rows from it to the 
end of the patch will be deleted, unless the number is 1, in which case only 
the first row will be deleted. 

Delete column(s) Deletes the columns indicated by the 
user. The numbers (counting from 1) of the first and last columns in the 
group to be deleted should be entered. If only one number is entered, then all 
columns from it to the end of the patch will be deleted, unless the number is 
1, in which case only the first column will be deleted.

Split at row Breaks a single patch into two patches at the 
row specified. The break falls after the row you name, which becomes the last 
row of the first patch. If you check "For control surface," three patches are 
created, with the same number of rows removed from each end of the original 
patch.

Split at column Breaks a single patch into two patches at the 
column specified. The break falls after the column you name, which becomes 
the last column of the first patch.



Get edge # Saves the points along an edge as a list of 3D 
coordinates. Edge numbers run counterclockwise according to CMARC 
conventions.

Replace edge Replaces one edge of a patch with a filed line, for
example an intersection with a vertical fin. The spacing of the new edge points
can match that of the patch or that of the filed line. If the spacing selected is 
that of the filed line, the end points of the filed segment, and the number of 
points in it, must match those of the patch edge to be replaced.

Mirror about BL Creates a copy of the patch reflected 
about a specified buttline plane.

Double density Doubles the number of rows and columns in a 
patch. The number of straight line segments in the edges remains unchanged,
and the interpolated lines terminate on the original edges. Thus, a patch 
whose density has been doubled after the fact differs along its edges from one 
that was defined at the higher density in the first place.

Translate X, Y, Z Shifts the patch by the specified amounts.

Rotate deg Rotates the patch about an axis specified by 
Origin and Vector, where Vector represents offsets relative to Origin.

Matching or reconciling patches

To join neighboring patches with different point distributions along the mating
edges, it is necessary to amputate the row or column of panels nearest the 
joint and to replace it with a patch containing a single column of panels, 
triangulated as necessary to connect all the mismatched points.

Select

Edit  > Patch  > Match/Reconcile

The setup dialog asks for the names of two patch files and the numbers of the 
adjacent edges. The first patch you name is the one that will be modified; the 
second will remain unchanged. If the point counts are the same, the points 
from one patch edge are simply copied into the other. If the point counts are 
different, an additional patch, consisting of a single row or column and 
containing some triangular panels, replaces the edge row or column in the 
patch to be edited.



The revised mesh is displayed. If you decide to save it, and the point counts 
were different, the destination file will contain two patches: the truncated 
version of the original file, and the triangulated insert.

The operation performed in this way is similar to the one that occurs when 
you select Match both when creating a wing or body bounded region.

Combining patches

Several patches in separate files may be combined in a single file. Select 

Edit  > Patch  > Combine

Make multiple selections by holding the <Ctrl> key while clicking on file 
names. Then provide a name for the new file. The new file name may be the 
same as that of one of the original files.

If in the patch selection step you select a single PAL file name (see Saving a 
patch list below) instead of a PCH file, the files listed in it will be combined in a
single patch file.

Merging Patches

Two patches having identical row and/or column counts and a common edge 
may be merged into a single patch. Select

Edit  > Patch  > Merge

Make one or more selections by holding the <Ctrl> key while clicking on file 
names. Then provide a name for the new file. The new file name may be the 
same as that of one of the original files; if it is, the original file will be renamed
with a BAK extension.



Assembling patches into input files

LOFTSMAN provides a limited ability to assemble ready-to-run CMARC input 
files automatically. This is the most convenient way to prepare and run patch 
assemblies to check geometry (with the –g command-line switch). 

Once one or more patches have been created and filed, select

Edit  > Patch  > Assemble

Click on Add patches to select patch files from any directory and place them 
on the patch list. (Hold down the <Ctrl> key after the first entry to make 
multiple selections from a single directory.)

Set any of the variables that you wish to change; in some cases the defaults 
are completely arbitrary. Variables not listed in the dialog must be manually 
edited once the .IN file has been created.

Next, highlight some or all patches on the patch list for inclusion in the file.



Include wakes is selected by default. Unless you uncheck it, wakes will be 
created for all flying surfaces.

Finally, click on Create/Save and give a file name. LOFTSMAN creates an 
input file that will run without further modification. 

You can end the procedure by clicking on either OK or Cancel. If you select 
OK, all data in the dialog, including the names of those patches that you 
highlighted, will still be present the next time you call for it. If you use Cancel,
default values are restored, patch names are discarded, and the dialog returns
to its initial state.

Saving a patch list

As a project comes to include a large number of patch files, you can save their
names and retrieve the entire list later. Patch file names are saved in an .SD-
style file format; the file name has a PAL extension, for Patch Assembly List. 
To create a patch assembly list file, select 

Edit  > Patch  > Assemble

Highlight the file names you wish to include and click on Create list file. Give 
a file name. A .PAL extension will be automatically added and the file will be 
placed in the current “miscellaneous” directory.

To retrieve names from a PAL file, click on Get from list file and select a file. 
All of the patch file names in the file will be added to the scrolling patch list.

All of the patches in a patch list may be displayed simultaneously. Select

Display  > Show patches from list

Select the Patch list (*.pal) file type and pick the file you want to display.

Automatic creation of Cmarc input files

In many cases, LOFTSMAN will automatically assemble an input file, using all
currently loaded components of a compound body and all currently loaded 
wings, without your having to create, retrieve or select any patches.



Select

Mesh  > Create

and then click on Auto mesh in the popup menu.

LOFTSMAN saves the complete patch list in a file called AUTOMESH.PCH, 
located in the current directory. It is overwritten each time this procedure is 
used. You have the option, however, of converting the patch file into a Cmarc 
input file. AUTOMESH.PCH contains only patch definitions; wakes are added 
when the IN file is created.

When a body alone is present, LOFTSMAN sizes the mesh in relation to the 
specified number of panel rows. When a wing is present, the mesh density is 
proportional to the default number of chordwise points used to define the 
wing section, but can be adjusted by changing the row count at the prompt.

Automatic meshing can be used for most configurations having distinct wing-
body intersections. It will not work for multiple bodies that are separated in 
space, such as an outboard nacelle or tip tank and a fuselage. Such 
configurations should first be subdivided by breaking the wing between 
bodies, and the resulting portions meshed separately.

A CMARC input file for a generic single-panel wing, formatted to permit simple
changes in scale, taper, twist, mesh density and other parameters by editing 
the IN file, can be created from within the wing editing menu. First, however, 
you must discard any currently loaded wing data. Then select

Edit  > New wing

Set parameters as desired and then click Create generic CMARC input file. If 
you want to be able to edit the wing geometry subsequently, check Make WI 
file too. This option applies only to creating a generic input file; if you are 
setting up a new wing geometry for editing, a WI file is automatically created.

Making Cmarc input files from displayed patches

LOFTSMAN will automatically assemble an input file using patches displayed 
on the screen

Patches my be imported by name or generated. Click the “Save results” icon 
on the toolbar or select File > Save > Save current result. Click on Cmarc IN. 



Manipulating the IN file

When a CMARC input file (.IN) file has been assembled or altered by manual 
editing, patches can be renumbered and wake and some other references 
reconciled to the new numbering. Select

Edit > Patch > Renumber IN file

Patches can be extracted from an IN file and saved separately. Select

Edit > Patch > Explode IN file 

For CMARC analyses involving roll or sideslip, both sides of the model must 
be defined in the IN file. Normally, LOFTSMAN creates half models.

CMARC provides a shortcut for making files bilateral. Using a text editor, 
replace all instances of IPATSYM=0 with IPATSYM=1. This has the effect of 
creating a mirror-image of each patch. The mirrored patches are given the 
ordinal number immediately following that of the original, with the result that 
CMARC now sees patches 1, 2, 3, and 4 as 1, 3, 5 and 7, etc. This change 
requires manually renumbering patches in wake definitions and adding port 
side wakes. As a final inconvenience, CMARC does not process roll rotations 
properly in files that have been bilateralized this way.

LOFTSMAN provides two methods of bilateralizing an IN file. In both, port side
patches are explicitly defined, port side wakes are generated, and wake patch 
number references are reconciled. Files created this way and given roll 
rotations will process correctly in CMARC.

If an IN file is created from existing patches using Edit > Patch > Assemble, 
check Mirror all patches to produce a two-sided model. Models produced with 
Mesh > Create > Auto mesh are always half models.

To convert a half model to a bilateral one, select

Edit > Patch > Make IN file bilateral 

The new file is given the name of the old one with _BI appended to it.



 17. Assembling CMARC input decks by hand

Surface breakdown

In general, a patch should be defined for each region of the model surface that
has a distinct set of edge conditions. Before defining patches, examine the 
model geometry to identify such regions.

Consider this hypothetical tail-prop aircraft:

From inspection it is clear that the wing and wing root meshing procedures 
will take care of everything from the nose back to the station at which the 
leading edge of the vertical fin intersects the fuselage.

The empennage, however, is more complex, and consists of several distinct 
regions. These are:

 The three flying surfaces, namely the upper vertical fin, the horizontal 
stabilizer, and the lower vertical fin or ventral. All of these intersect the 
fuselage at different leading and trailing edge stations.

 The fuselage surface between the leading edge of the fin and the leading 
edge of the ventral, bounded at its upper edge by the fin-fuselage 
intersection.



 The fuselage surface between the leading edge of the ventral and the 
leading edge of the horizontal stabilizer, bounded at its upper edge by the 
fin-fuselage intersection and at its lower edge by the ventral-fuselage 
intersection.

 The fuselage surfaces between the leading and trailing edges of the 
horizontal stabilizer. One of these lies between the fin and the horizontal, 
the other between the ventral and the horizontal. In each case, the trailing 
edge of the horizontal surface lies slightly aft of the trailing edge of the 
vertical. The line of intersection between the fuselage and the vertical panel
must be extended aft along the top or bottom waterline in order to coincide
in extent with the intersection of the horizontal stabilizer with the fuselage.

 The fuselage and propeller spinner aft of the trailing edge of the horizontal 
stabilizer.

All three of the flying surfaces are meshed as wing bounded regions, with the 
Use tip & current body root option. In this case, the ventral and horizontal 
stabilizer have 20 panels, and the fin has 25.

All of the fuselage panels adjacent to flying surfaces are meshed as body 
bounded regions, generally using the Match both option to allow for the 
bounding intersections having different numbers and spacings of panels. The 
panel lying between the fin leading edge station and the ventral leading edge 
station, however, uses Match upper, because the spacing along the bottom of 
the fuselage is undefined.

The spinner patch is meshed as a transition. It cannot be meshed as a plain 
body segment because the panel spacing in the section at the trailing edge of 
the horizontal stabilizer is distorted by the stabilizer.

As this example illustrates, each set of distinct edge conditions defines a 
separate patch. As a general rule, a larger number of simple patches is 
preferable to a smaller number of complex ones in an input file.

Building the .IN file

The best way to create an input file manually is to begin with an existing one 
and insert new patches into the place of the existing ones.. (Be careful to use 
Save as rather than Save, and to give the new file a different name; otherwise 
you will overwrite the original file.) So long as the last section in the last patch
you have inserted has the TNODS=5 code (rather than TNODS=3), all 



subsequent patches will be ignored even if you do not erase them. Wakes can 
be suppressed by setting IDWAK=0. 
 
Section Four includes an example of meshing a body and incorporating it into 
an input file.

When you have copied one or more patches, test the input file by running it 
through CMARC with the –g switch on the command line. This process 
produces an output file containing only the geometry, which can be displayed 
in POSTMARC. Use View > Solid Colors to make the color of the “negative” sides
of panels different from that of the “positive” sides. If a patch shows negative 
color on the outside of the model, it is reversed. A quick but inelegant fix for 
patch reversal is to set IREV=-1.0 for that patch. Alternatively, you can 
change the point or the section order (but not both). LOFTSMAN provides 
switches for reversing point and section order on vertical wing panels, which 
are the ones most likely to come out reversed, and also procedures for 
reversing existing .PCH files.

POSTMARC’s method of eliminating hidden lines sometimes allows small 
pieces of the inner skin to show through the outer in irregular shingled 
patterns. As you rotate the model, these spurious displays of inner surface 
move around. A reversed patch, however, is quite obvious, since a large, 
clearly defined rectangular array on the model surface appears in the negative
color, and remains unchanged regardless of the viewing angle.

When CMARC encounters TNODS=5, it stops looking for section and patch 
definitions and begins looking for a wake definition. You can therefore debug 
an existing geometry that does not execute properly by moving TNODS=5 from 
patch to patch, starting with the first, and examining each step in POSTMARC
until the failure occurs.

Patch order

Patches can be assembled in random order in an input deck, but it is 
preferable, if only for convenience in reading the file, to keep them in a 
sequence corresponding to their physical location, ie nose-to-tail. On the 
other hand, it is inconvenient to go through a file to edit wake definitions each
time the patch count changes, and so a case can be made for putting all lift-
producing surfaces at the start of the file, where their patch numbers will not 
be affected by changes elsewhere.

When adjoining patches are created using different values of the INCREMENT, 
they will not match perfectly. (Misalignments of this type appear along 
circumferential lines, not longitudinal ones.) If this happens, find the 



matching sections (which, if the patches are arranged in order, will be close 
together in the file), erase one set of coordinates, and copy the other set into 
its place. It is easier, however, to create all sections with the same value of the
INCREMENT in the first place.

Some manual editing will be necessary to prepare most input files for panel 
method analysis. In particular, the user must insert the code  (TNODS=5) 
indicating the last section of the last patch, since unless LOFTSMAN 
assembled the file it has no way of knowing which patch is the last.

Input file patches may be renumbered using Edit > Patch > Renumber IN file.

Wakes

Once you have defined the model, you must add a wake to any surface 
expected to produce lift. In practice, only objects with clearly defined trailing 
edges lend themselves to easy wake definition. It is possible to define wakes 
on objects such as ellipsoids of revolution, but doing so requires suppositions 
about the probable location of the stagnation line and the form of the wake.

In MIN.RAW, IDWAK is zero. Change it to 1. Define the wake separation line 
according to the instructions in the CMARC documentation. Specify the type 
of wake desired (rigid or time-stepped, and initialized or self-generating). Set 
NODEW=5 on the final wake section definition. Define and debug one wake at a 
time.

For models with a defined port side, port wakes must be defined in the same 
way as starboard ones; there is no facility similar to IPATCOP for wakes. To 
clarify the panel numbering on the port side, display the model in 
POSTMARC, zoom in on the region of interest, and hit <Shift-P>. The patch
and panel number of each panel will appear in the middle of the panel.

Wakes are automatically added in the Mesh > Auto and Edit > Patch > Assemble 
procedures.

Two-sided models

Two-sided models are required when the geometry is asymmetrical about the 
XZ plane or when the yaw angle is non-zero. The steps required when 
converting a one-sided model to a two-sided one are:



1. Set RSYM=1.

2. For each mirrored patch (normally all of them), set IPATSYM=1. Note that 
the mirrored copy occupies the next position in line after the original in the 
patch numbering. 

2. Correct values of KWPACH in the original wake definition to reflect the 
revised patch numbering. 

3. Create wakes as needed for the port side. Port side wakes should be 
continuous with their starboard-side counterparts. A wing wake, for 
instance, might begin at the port wingtip and progress inward to the 
fuselage, aft to the tail tip, then forward on the starboard side to the wing 
root and out to the tip. Change the patch edge and line count values as 
necessary in the wake definition to reflect the inverted point numbering 
order on the port side. For instance, on the port side sections are ordered 
fore-to-aft, but points are arranged top to bottom. Use <Shift-P> in 
POSTMARC to display panel and patch numbers and understand which 
way they're ordered

4. Test the geometry by running CMARC in geometry-only mode and then 
displaying it in POSTMARC. If you have set the positive and negative solid 
colors to different values, any reversed patches will be apparent.

5.  You may have to make the wake rigid; it is often impossible to time-step a 
yawed model because as the wing wake is carried downstream it intrudes 
into the fuselage on the upwind side. Wake intrusions can sometimes be 
avoided by using very small yaw angles (such as .01 degrees); otherwise, 
use LOFTSMAN’s wing-body wake generating function to produce rigid 
yawed wakes, and edit them into the input file.



18. Aircraft performance estimation

Since some aircraft design decisions involve “what if?” questions about 
performance, LOFTSMAN includes a procedure for estimating performance 
and for viewing the effects of various kinds of changes. LOFTSMAN uses 
classical performance equations together with some empirically-based 
approximations to estimate the performance of broad classes of engines and 
propellers.

The performance estimation procedure does not attempt to draw configuration
information from current data files; you must enter the required information 
yourself. All values are in English units; speeds are miles per hour.

To begin performance estimation, select

Misc  > Performance

To quit, you can click either OK or Cancel. If you click OK, the current 
variables are saved and will appear the next time you return to the procedure 
during the current run. If you leave LOFTSMAN and return, on the other 
hand, the default values will be displayed.

You can make the current set of values the defaults for future runs of 
LOFTSMAN by clicking Save new defaults. To return to the current defaults 
after making changes, click on Restore defaults.

Defining the powerplant

Select propeller or jet. (Jets performance is simulated rather generically.) For 
props, select constant-speed or fixed pitch propeller, and naturally-aspirated 
or flat-rated powerplant. Flat-rated powerplants include both those that are 
supercharged and those that are derated at sea level. In either case, power is 
assumed to be constant up to a specified critical altitude, and then to 
diminish in proportion to ambient density. A standard atmosphere is assumed
in all cases. Flat rating and a fixed-pitch propeller are not a valid combination.



Selecting methods

In the box labeled Methods you can choose to allow LOFTSMAN to estimate 
propeller efficiency, span efficiency, and specific fuel consumption (SFC), or 
you can set these items manually.

Flight conditions

Only one flight condition can be varied, namely altitude. This is a density 
altitude in the ISA Standard Atmosphere.

Aircraft characteristics

Five aircraft characteristics can be varied: weight, wingspan, wing area, 
equivalent flat plate area, and span efficiency. (Span efficiency may be 
estimated by LOFTSMAN or set by the user.)

Equivalent flat plate area is the product of the parasite drag coefficient and 
the wing area. Another way of looking at it is as an equivalent area of 
something having a drag coefficient of 1.0. Representative values are 1.0 to 
1.5 for the smallest, cleanest Formula One racers; 3.0 to 7.0 for single-engine 
general aviation aircraft, and around 90 to 100 for a Boeing 747.

Span efficiency is a correction factor due to finite aspect ratio and departures 
from ideal spanwise lift distribution; it influences induced drag, and is 
theoretically 1.0 for elliptical wings without bodies. In the absence of other 
information, values in the neighborhood of 0.75 to 0.8 are typical of many 
aircraft.



Powerplant characteristics

Propeller efficiency and SFC (specific fuel consumption) may either be 
estimated by LOFTSMAN or set by the user. Cruising prop efficiencies for 
constant-speed metal propellers are around 0.85; wood props seldom exceed 
0.75. SFC (pounds of fuel used per hour per horsepower) is 0.4 for the most 
efficient gasoline engines properly leaned; 0.45 to 0.55 are more typical values
achieved by average pilots. RPM and compression ratio affect the calculation 
of SFC by LOFTSMAN; otherwise they are unimportant. 

Propeller design speed is the true airspeed at which the propeller achieves its 
peak efficiency; if it is not known, assume the 65% power cruising speed for 
the airplane for which the propeller was designed. Critical altitude is the 
highest altitude at which a supercharged engine can achieve its rated power; 
for general aviation gasoline engines typical values are 16,000 to 20,000 feet. 
Turbine engines, unless flat-rated, and naturally aspirated reciprocating 
engines have a critical altitude of zero.  

Breguet characteristics

The "Breguet Range Equation" is used to calculate the theoretical maximum 
range of an aircraft. For various reasons the predicted values are likely to 
exceed those achieved in real life, but they are nevertheless a reliable way of 
comparing the ranges of different aircraft. The equation operates on only four 
variables: prop efficiency, SFC, the airplane lift-drag ratio (which is 
independent of weight), and the ratio between the starting and ending 
weights. The weight ratio is entered in LOFTSMAN as a "fuel fraction," that is, 
the fraction of the takeoff weight that is consumed (as fuel) during the course 
of the trip. Note that neither flight altitude nor the absolute size or weight of 
the aircraft enters into the calculation.

The Breguet Endurance Equation is used to calculate the greatest length of 
time an airplane can remain aloft.

Because prop efficiency and SFC vary throughout the flight, Calculate SFC 
and Calculate prop efficiency should be unchecked, and the user should 
manually enter suitably pessimistic values.



Maximum speed

The maximum true airspeed speed attainable at the maximum power available
at the specified altitude (but not more than the specified horsepower) is 
continually displayed.

Tabulated results

When you click on Tabulate, the following items are displayed for twenty 
airspeeds, beginning with a speed entered beside the Tabulate button:

TAS True airspeed
IAS Indicated airspeed
Drag Total air resistance
ThpReq Thrust horsepower required for level flight at this speed
PropEff Propeller efficiency
BhpReq Brake horsepower required
PctPwr Required percentage of rated power
Par/Ind Ratio of parasite to induced drag
SFC Specific fuel consumption
FF Fuel flow
SpRange Specific range
V*mpg A figure of merit combining speed and economy
BhpAvl Brake horsepower available
ThrAvl Thrust available
ROC Rate of climb
AOC Angle of climb
AOG Zero-thrust glide angle (degrees)
Sink Zero-thrust sink rate
L/D Lift-drag ratio
Q Dynamic pressure
Cl Lift coefficient
Cd Total drag coefficient referred to wing area
e Oswald span efficiency factor
Unit RN Reynolds Number per unit of length



Takeoff performance

LOFTSMAN estimates takeoff performance by calculating thrust, rolling 
resistance and aerodynamic drag at intervals of 0.1 second. The results are 
tabulated at intervals of one second. Rotation is assumed to begin at the 
stalling speed; induced drag gradually increases until the liftoff speed is 
reached and lift is equal to weight. The calculation is a matter of simple 
physics and ought, in principle, to be straightforward and reliable. 
Unfortunately, uncertainty about powerplant characteristics, and especially 
propeller performance, can lead to disparities between prediction and reality.

Curve fits and rules of thumb are used to approximate powerplant 
characteristics. Some of these characteristics, such as propeller performance, 
have a powerful effect on takeoff distance, and so if a particular real airplane 
does not closely match the program's underlying assumptions, attempts to 
match calculated performance to published values from the POH may be 
frustrating. Nevertheless, the effects of runway gradient, surface condition, 
wind and rolling CL are accurately calculated and can be used to study the 
influence of those variables.

To initially match calculated results to handbook performance, the easiest 
approach is to vary the propeller Ct/Cp until the correct takeoff distance is 
found. 







Section Four

The following examples are intended to be read at the computer, and all 
the indicated commands entered. They will acquaint you with some of 
LOFTSMAN's commonly used commands and capabilities.

Case One: A Spinner

This example demonstrates the use of some of LOFTSMAN's display and 
editing commands.

The file SPINNER.LFT contains one of the simplest possible lofted shapes: a 
body of revolution with one curve segment and a constant K Factor.

To load it, start LOFTSMAN. Select File > Discard current, then File > Open. Load
SPINNER.LFT.

To inspect the body, select

Body >Normal section(s)

and click on OK.

To view the spinner from different angles, hold down the left mouse button while 
moving the mouse about. Releasing the mouse button will set the new view.
 
To get a better sense of the exact shape of the spinner, select

Display > Clear
Body > Lines

and accept ALL, which is the default.

Now hit ‘z’ to see a top view of the spinner. (‘x’ gives a front view, ‘y’ a side 
view. Capital (shifted) letters show the opposite side.) 



The nose of the spinner may appear polygonal rather than rounded, because 
the default step size of 1 inch is too large for curves of small radius. If so, 
select

Settings  > Constants

and enter 0.1 at Step.

Now select

Display > Clear
Body > Lines 

To change the spinner’s shape, select 

Edit > Body lines

and choose mb.

LOFTSMAN displays the Maximum Buttline curve and its segment frame. 
Select

Segment  > Curvature 

Move the mouse cursor to a point near the middle of the spinner profile, press
the left button, and drag the line to a new location.

The contour is generally parabolic. Another common spinner type has a small 
radius at the nose and a gentler arc farther aft. To obtain this effect you need 
more detailed control over the contour than a single frame gives you. Select

Segment  > Split

If there were more than one segment in the line, you would identify the 
segment that you want to split by clicking on it. In this case, however, 
LOFTSMAN automatically splits the only available segment. The curve itself is 
unchanged.

When a line consists of more than one segment, it is desirable to ensure that 
the radius of curvature of the line varies in a continuous way across the 
segment break. Select

Display > Radii on/off

A graph of radius of curvature appears superimposed upon the line display. It 
will allow you to observe the effect of your edits on line continuity. 



To have a small radius at the nose and a larger radius for the rest of the 
contour, you need to move the segment break point closer to the nose.

Select

Tangent  > Rock

Move the mouse cursor to the break point between the two segment frames, 
press the left mouse button, and drag the break point toward the nose of the 
spinner. Note that as the tangent moves forward, the continuity display 
develops a break.

You can adjust the shape of the nose in various ways. Try changing the 
Curvature of the fore segment by selecting

Segment  > Curvature

and dragging the line inward or outward as before.

Select

Tangent  > Slide

Put the mouse cursor on the tangent point and move it up and down.

Select

Tangent > Pivot

Put the mouse cursor at one end of the tangent line and rotate it.

Another type of spinner has a pointed nose. To get this shape, a single frame 
is sufficient, but its first leg must not be vertical. To start with, select 

Segment  > Delete

Again, if there were more than two segments, you would select the one you 
want to delete by clicking on it.

To make the nose pointed, select

Corner  > Drag

Move the mouse cursor to the corner of the segment frame, press the left 
mouse button, and move the corner around. You may wish to experiment 
again with the Segment > Curvature control as well.

To make the Top Waterline match the Max Buttline, use



Line  > Copy to

For the Bottom Waterline, which has the same shape but opposite sign, use

Line  > Copy mirrored to

To save what you have done, select Body > Save or Body > Save as. It’s a good 
idea to save frequently. To end the editing procedure, select

Display > Done

NOTE: When you edit the current data set, the original file remains 
unchanged until you save the changed version. You can do this either from 
the editing window or after returning to the main window.

Case Two: A Business Jet

This example provides some insight into alternative methods of producing 
more complex shapes.

A business jet fuselage has been lofted in several ways. The first, which is the 
simplest, is in BJET1.LFT. It treats the windshield as a continuous part of the
body loft. In the second, which is in two files, BJET2.LFT and BJETWS.LFT, 
the fuselage and windshield are lofted separately and a wing root fairing is 
added by reshaping the BK moldline. The third version involves a different 
treatment of the wing root fairing, this time by lofting it as a separate body 
(BJETTUB.LFT).

Because this is a large body, set the STEP to 2 inches and the INCREMENT to 1 
inch.

To see the profile of the basic fuselage, first discard the current data file, then 
clear the screen and load BJET1.

Select 

Body > Lines

Pick All.

This is a simple body to loft because all segments are bounded either by 
straight lines or by the nose or tail. The frame for each segment is created by 
drawing straight lines tangent to the segment at its ends and recording the 



coordinates of the ends and of the crossing point. On the segment of the TW 
between FS106 and FS140, the corner of the segment frame is determined by 
the coordinates of the straight lines lying before and after this segment. This 
is an example of a situation where you can let LOFTSMAN find the corner for 
you by entering *,* in place of a pair of coordinates.

Since the pressurized fuselage will be of circular section, BK and TK are both 
0.7071 for the entire length of the fuselage.

Hit ‘p’ for a perspective view, then select

Body > Normal section

The windshield is rather flat. To display its horizontal contours, enter

Display > Clear
Display > Rotations > Orthogonal  > Top

Body > Contours > Top WL

Note that ‘z’ is a shortcut for the rather cumbersome Display > Rotations > 
Orthogonal > Top.

The Contours display reveals that the windshield is quite blunt. This is the 
case because it was lofted as a bent-up piece of the top of the nose, not as a 
separate streamlined body. Windshields and canopies can be lofted as 
separate bodies to eliminate this bluntness.

The easiest way to streamline the windshield of our jet is to create a new data 
file, extending the TW moldline of the nose from FS79 aft to just short of 
FS140 with a straight line, and connecting this line to the existing one at 
FS140. The point of this change is to preserve the shape of the fuselage ahead
of the windshield and aft of it, while deleting the windshield itself. The new 
windshield will be partly buried within the new fuselage.

The files BJET2.LFT and BJETWS.LFT contain these modifications.

Select

File > Current data

and change BJET1 to BJET2. Clear the screen, restore a perspective view, and
display sections and body lines.

Note that in order to avoid a vertical moldline segment, which would give the 
TW moldline two different values at the same station, the upright segment of 
the TW at FS140 is actually slightly tilted: its bottom end is at FS139.99.

Select File  > Current data and type BJETWS on the second line.



BJETWS.LFT is subject to two requirements: it must have a streamlined front,
and its aft end must precisely match, and blend into, the fuselage.

The issue of blending is important. In some cases, such as a bubble canopy 
emerging from the top of a fuselage, blending the canopy with the fuselage is 
not a concern; in other cases, for instance when a windshield must blend into 
the roof and sides of the cabin, you must ensure that the slopes of moldlines 
shared by two bodies match at the FS where they meet. For two bodies to 
match seamlessly, all of the corresponding moldlines must flow together 
seamlessly as well.

In this example, blending is easy because all lines at the aft joint between 
windshield and fuselage are straight and parallel fore-and-aft lines. It is 
sufficient that the aft segments of the windshield moldlines also be parallel to 
the axes and that the TW, MB, WW, and TK moldlines of the windshield be 
identical to those of the fuselage at FS140. 

The requirement that the moldlines be identical at the blend point implies 
that the inserted body must have the same WW as the original one. If this is 
inconvenient, for example because you want the sides of the windshield to 
slant outward, both bodies should be lofted as A-type rather than B-type, and 
a moldline placed in the main body at the bottom edge of the windshield at 
FS140.

The windshield "body" does not need a finite lower half, since it is buried in 
the fuselage in any case; so we make its BW moldline coincide with its WW 
moldline. The BK can have any value.

The streamlining of the windshield is controlled by the Curvature of the MB 
line, which has been set at .68. To compare the contour of this windshield 
with the earlier one, select

Display > Clear
‘z’

Body > Contours > Top WL

This is the two-body version of the canopy. Now select

File > Discard current data
File > List current data files

and type BJET1 on any line. (Alternatively, you can use File > Open for this 
step.) Then select

Display > Linecolor
Body > Contours > Top WL



The next modification our jet needs is a wing root fairing or "tub." One 
approach is simply to modify the BK control line. BJET2 has this 
modification; you can examine the control line by making BJET2 the body 
data file, clearing the screen, and selecting

Body > Lines

and choosing bk.

A second approach to the wing-root fairing, and one that gives better control 
of its shape, is to loft it as a separate body. This permits us to reduce its 
volume somewhat by making it narrower, and also allows us to find the line of
intersection of the fairing and the circular hull, which may be useful later.

The first question is how wide to make the fairing. Let's say that by inspecting 
the fuselage and the thickness of the wing root, we conclude that the fairing 
only needs to go up to WL23.0, which means that it will be about 68 inches 
wide.

BJETTUB.LFT contains a first cut at a root fairing. To examine it in place, 
load BJET1 and BJETTUB on any two lines. Then

Display > Clear
Body > Normal section  [OK]

To get the lines of intersection between the fairing and the cylindrical hull, 
enter, select File > Body data and remove BJETTUB from the list. Then select

Body > Intersection > With second body

and give BJETTUB as the name of the second body.

Occasionally, as in this example, LOFTSMAN will fail to find an intersection 
point at a certain station, and a spike representing a spurious point appears 
in the displayed line. These faults must be manually edited out of any saved 
or printed listings. Sometimes reversing the roles of  “current body” and “body
intersecting with” helps.

Case Three: Defining a Simple UAV Fuselage

The following example describes the creation of a cylindrical fuselage with 
ogive nose, boat tail, and an aft air intake above the body. Since the main 
body is of cylindrical cross-section, it can be defined as a B-type geometry. 
The air intake is defined as a separate body and the two are then combined.



With no body data file loaded in LOFTSMAN, select

Edit  > New body

Set the desired fore and aft limits and diameter, and specify Teardrop as the 
body type. (Actually, it is of little importance which type you choose, since 
they are easily transformed from one to another.)

In this example, the fore and aft limits will be the default 0.0 and 100.0, and 
the diameter will be 15.0. The units should be set to inches. 

Select BW as the moldline to be edited.

Move the tangent point (Tangent > Drag or the "Drag tangent" button) at 
FS30.0 forward to FS15.0, keeping the same waterline (-7.5).

Move the corner point of the nose frame aft to FS4.0 by selecting Corner > Drag
or by using the "Drag corner" button. Keep the waterline.

(Henceforth, just the menu choice will be named. Pop-up labels define the 
buttons, which are provided for most operations. Note also that you actually 
set the coordinates of a point in the dialog that pops up after each action; you 
don’t need to drag to the precise point.)

Select

Body  > Save as

and save the geometry. The first save in defining a new body must be done 
using the menu; thereafter, save using the blue floppy-disk icon.

Select

Corner  > Remove

and click on the corner of the aft segment.

Select

Tangent  > Drag

and drag the aft end of the aft segment to FS100.0,WL-7.5.

Save by clicking on the blue floppy-disk icon.

Select
Line > Copy mirrored to

TW
Line > Copy mirrored to



MB
Display > Select line

MB
Segment  > Split

Left-click on the aft segment.

Select

Corner > Add

and click on the aftmost segment.

Drag the aft tangent point of the aft segment to FS100.0,BL0.0.

Drag the corner of the aft segment to FS80.0,BL7.5.

Drag the tangent point between the middle and aft segments to FS65.0,BL7.5.

Save by clicking on the blue floppy-disk icon.

The basic body is now defined. Select

Display > Done

to return to the main screen and inspect the model.

To develop the intake, first select

File > Discard current data

(When developing a new body, there must be no other body currently loaded.)

Again pick Teardrop, and set the fore and aft limits and diameter. We will use 
70.0, 100.0, and 10.0. Select MB to edit.

Drag the tangent point between the fore and aft segments to FS71.0,BL5.0.

Drag the corner of the aft segment to FS85.0,BL5.0.

Select

Body > Save as

and give the file a name.

Drag the fore tangent point of the fore segment to BL4.7. Save by clicking on 
the blue floppy-disk button.



Select the TW to edit.

Select

Line > Drag

and drag the TW moldline upward to put the middle tangent point at WL12.0.

Drag the aftmost tangent point to WL7.5.

Drag the foremost tangent point of the fore segment to WL11.7.

Save.

Select WW to edit.

Split the segment into two.

Add a corner to each segment.

Drag the fore tangent of the fore segment to WL10.0.

Drag the corner of the fore segment to FS 77.0,WL10.0.

Drag the corner of the aft segment to WL0.0.

Select

Tangent > Align

and click on the tangent point at FS85.0.

Save.

Select BW to edit.

Drag the fore tangent point of the fore segment to WL8.8.

Drag the aft tangent point of the aft segment to WL-7.5.

Drag the tangent point between the fore and aft segments to FS80.0,WL4.0.

Drag the corner of the fore segment to FS76.0,WL8.5.

Drag the corner of the aft segment to FS90.0,WL-7.5.

Align the middle tangent point.



Split the fore segment.

Drag the corner point of the foremost segment to FS70.0,WL8.5.

Drag the aft tangent of the foremost segment to FS71.0,WL8.5.

Drag the corner of the second segment to FS74.0,FS8.5.

Align the tangent at FS79.0.

Save.

Leave the editing screen by selecting Display > Done. 

Select

Body >Body lines > All
Body >Normal section(s)

File > Open

Load the body file that you created previously.

Select

Display > Clear.
Body > Normal section



The following examples apply to LOFTSMAN/P only.

Case Four: Wing root and wing mesh

Delete the current files and make C1 the current body file. When you load 
C1.LFT, C1.WI is automatically loaded as well.

Select

Mesh  > Body > Wing root

A dialog box appears. For the time being, simply accept all of the defaults and 
click on OK.
 
LOFTSMAN produces the mesh. Obviously, it is excessively dense in the 
region of the wing and insufficiently dense in the fore and aft "transition" 
zones, which by default extend all the way to the nose and tail of the body.

Clear the screen and repeat the process, but this time make the "Number of 
wing panels" 20 rather than 30, and make the numbers of panels in the fore 
and aft transition bands, say, 20 and 25 respectively.

The proportions of the panels are more reasonable now. Select

File  > Save

Give C1BODY as the name, and select Patch and CMARC. It is not necessary 
to provide a label in this case, because LOFTSMAN automatically labels all  
the parts of a wing root mesh. LOFTSMAN will attach a .PCH extension to the 
file name.

If the body being modeled has other protrusions than the wing, those body 
regions must be meshed separately. For example, if this body had a canard 
whose trailing edge was at FS 26.0, you would loft the forward portion of the 
body around the canard root, omitting the aft transition section (by setting the
number of aft transition bands to zero). You would, however, “keep” the body 
cross-section at the trailing edge of the canard, and use it as the forward limit 
of the fore transition zone when meshing the aft portion of the body around 
the wing root. For the purposes of this exercise, however, we will omit such 
complications.
 
In addition to adjusting panel spacing longitudinally, you can also control the 
circumferential distribution of panels. In the dialog box, Number of bands is 
the panel count from the bottom centerline to the top centerline. Bands below 
wing is the number of those panels between the bottom centerline and the 
wing root. If you give it a value of zero, LOFTSMAN will distribute the panels 
in a reasonable way. You can, however, force a denser paneling above or below
the wing if you wish.



To produce a wing mesh, select

Mesh  > Wing  > Bounded region

Use 20 panels chordwise to match the body mesh. It is not necessary in this 
case to provide inboard and outboard boundaries; instead, check Use 
station ... + current body root.

Save the wing as a separate patch called C1WING. (You could also append 
this patch to the body patch, but it is a good idea to keep separate patches in 
separate files.)

To view the patches, select

File  > Import object

and pick the patch file names in the file selection dialog.

Case Five: Constructing an input file for CMARC

Since the CMARC input file is a pure text file, it can be created (or modified) in
a text editor, normally by cannibalizing headers and footers from existing files 
(a number of sample files are provided), changing numerical data as 
appropriate, and copy/pasting patches. But once patches for the complete 
model have been created, it is usually more convenient to allow LOFTSMAN to
create input files.

Select

Edit  > Patch > Assemble

Press Add patches. A list of patch files in the current directory is presented; at
a minimum, it includes C1BODY.PCH and C1WING.PCH. Holding the Control 
key, select these two files. They appear in the file list window. Press Select all.

The various values and options can be added now or later. For the time being, 
leave the defaults in place. Press Create/Save input file.

The IN file can now be processed by CMARC, but until you enter the proper 
values for wing area, semispan, and so on, the integrated force and moment 
results will not be accurate.



Case Six: Meshing a Complete Airplane

The following description applies to an ONERA wind tunnel calibration model 
called M4. It is a simple low-wing subsonic airliner configuration, and does 
not include engine nacelles. The fuselage of the actual model has a blunt tail 
for mounting in a tunnel; this has been replaced in the LOFTSMAN model by 
a tapered fairing. POSTMARC can be instructed to omit the fairing from force 
and moment integrations.

This tutorial applies to manual creation of patches. In many cases, however, 
the entire model can be meshed automatically.

The paneling density is arbitrary. The following description provides a 
moderate-density model; larger or smaller numbers of panels can be used.

The geometric description of the model consists of four files: the fuselage LFT 
file, and WI files for the wing and the horizontal and vertical stabilizers. All 
these files, which are included among the examples, should be loaded.

1. Meshing the flying surfaces and wing root

Set the wing as the primary WI file.

Select



Mesh > Create

Click on OK.

Right-click, then select Get FS of section.

Click on the section at the leading edge of the vertical tail. Click on OK. The 
station is now stored on the Clipboard.

Right-click, and from the menu select Wing root mesh.

Set 20 columns and full cosine spacing in fore and aft transitions. Set 20 
rows.

Click OK.

Right-click and then left-click on Select wing.

Click on the wing, and in the dialog box click OK.

Right-click and then left-click on Select wing.

Click on the horizontal stabilizer, and in the dialog box click OK.

Right-click and then left-click on Select wing.

Click on the vertical fin, and in the dialog box click OK.



For each empennage surface, Loftsman adjusts the chordwise and spanwise 
mesh density in proportion to that of the wing.

2. Meshing around the empennage

Right click, then select Select body region.

Click on the area below the vertical fin and ahead of the horizontal stabilizer.

Set 20 rows and Match upper and click OK.

Now roll the aircraft to the left so that the area below the horizontal stabilizer 
is visible.

Right click and select Select upper edge. Click on the lower stabilizer root 
intersection. LOFTSMAN should acknowledge that the upper edge has been 
selected. If you do not get a confirmation, try again until you do.

Repeat the procedure for the lower edge (BW line), fore limit (leading edge of 
stabilizer root) and aft limit (trailing edge of stabilizer root).

Count the number of rows that will go below the stabilizer. There are 13.

Right click and select Make patch. Set 13 rows and Match upper. Click OK.

Roll the airplane to the right until the area above the horizontal stabilizer is in
view.

Right click and select Select body region. Click on the fuselage patch between 
the vertical and the horizontal stabilizers.

Set 7 rows, check Match both, and select Adjust upper. Click OK.

Right click, select Select body region, and click on the patch above the 
horizontal and behind the trailing edge of the fin.

Uncheck Match both and select Match lower. Click OK.

Right click, select Select body region, and click on the stinger.

Set 20 rows, 10 columns, and fore cosine spacing. Click OK



Right click and select Save all patches.

You now have complete coverage of the body. The patches do not yet match 
one another perfectly, but for a quick test you can assemble a model and 
analyze it.

5. Assembling and testing the model

Select

Edit  > Patch > Assemble

Click Add patches and import all of the patches you have created. Click Select
all. Then click Create/Save input file and save as TEST1.IN.

Open CMARC or DWT and run an analysis of TEST1.IN.

Open POSTMARC and load TEST1.BIN. Select

Display > Contour solid > Coefficient of pressure

Except for some minor pressure glitches where panel edges do not match 
perfectly in the empennage region, the analysis looks good. (The 



"Unreasonable Cp ..." warning in the CMARC log need not concern us at the 
moment.)

6. Correcting patch edge mismatches

The next step is to correct the mismatched edges in the input file.
 
The patches are currently somewhat randomly arranged. It is more convenient
to arrange them in order from nose to tail and, where patches are stacked 
vertically, from bottom to top.

Save the model as TEST2.IN, so that if something goes wrong you will still 
have your TEST1.IN file. 

Open the file in DWT's editor or in a text editor such as Windows Notepad. 
Rearrange the patches by cutting and pasting, and save the file. Then, in 
LOFTSMAN, Select

Edit  > Patch > Renumber IN file

Reload the renumbered file in your editor and search for TNODS=5. Change it 
to TNODS=3. Then go to the last section of the last patch in the file, which is 
the tip of the tail closure and looks like this:

&SECT1 STX=0.0, STY=0.0, STZ=0.0, SCALE=1.0, ALF=0.0, THETA=0.0, INMODE=4,
 TNODS=3, TNPS=0, TINTS=0, &END
 1000.000          0.000          0.000
 1000.000          0.000          0.000
 1000.000          0.000          0.000
 1000.000          0.000          0.000
 1000.000          0.000          0.000
 ...

Change the TNODS=3 in the SECT1 line to TNODS=5.

The mismatched panels will be at the leading and trailing edge stations of the 
HT, because the chord line of the HT does not fall on a panel corner point 
selected by LOFTSMAN's automatic spacing. Displaying the model in 
POSTMARC  in hidden line mode, you can double-click on a patch and find its
number displayed on the status line.

In POSTMARC, determine that the patch just ahead of the HT is Patch 11 and 
the HT itself is Patch 14.

The patch below the HT is 13. Copy the coordinates of the first section of 
Patch 13 into the Clipboard.. Go to the last section of Patch 11 and replace 
the first 14 points with the ones from the Clipboard. 



Perform the same operation on the seams between 11 and 15, 13 and 18, and 
17 and 18. It is also necessary to replace the corner point at the intersection 
of  15 and 17 with the nearby point from the most inboard section of 14. 
These corrections eliminate most of the pressure anomalies at patch edges.

7. Alternate Method

Another way to approach a simple configuration of this type is to use a wing-
root mesh for both the wing and the HT. In this case, the aft transition of the 
wing root mesh is terminated, and the fore transition of the HT mesh begun, 
at a convenient point between the wing and the HT, and preferably ahead of 
the leading edge of the vertical fin. This procedure quickly gives a good "flow 
through" mesh over the entire fuselage.

The problem is to integrate the vertical fin into it. It should be noted that for 
many functions, such as finding longitudinal stability derivatives, neutral 
point and elevator deflection needed to trim, the vertical fin does not even 
have to be included in the model. If, however, the VT is to be included, then 
the most straightforward approach is to graphically edit the patches that it 
intersects.

If the VT is sufficiently thin, it is sometimes possible simply to replace the 
topmost edges of the patches adjacent to the fin with the fin root intersection 
line, triangulating panels as needed.

8. The Much Easier Method

In this case, and with many more or less conventional configurations, it is 
possible to bypass all manual operations and allow Loftsman to mesh the 
entire model. Select 

Mesh > Create
Auto mesh

and see what happens.

Case Seven: Defining a Wake Separation Line

All wake definitions, including ones generated by LOFTSMAN, require a wake 
separation line or WSL. The WSL is defined in terms of patch edges. Panel and



patch edge numbering is explained in the Wakes section of the DWT/CMARC 
manual.

Each lifting surface has a WSL. In the case of two-sided models (necessary for 
analyzing sideslip cases) a single WSL can extend from wingtip to wingtip, or 
separate wakes can be defined for right and left sides, meeting at the plane of 
symmetry. A WSL for half the aircraft can proceed either from the wingtip to 
the tail or the other way.

The following examples make use of the ONERA_M4.IN model, which is found 
in the \examples\Cmarc_input_files subfolder. This is a fully-defined (that is, 
two-sided) model whose meshing is described, step by step, in Section 4 of the
LOFTSMAN manual. Before the WSL is defined, a "Geometry only" analysis 
must be run in CMARC or DWT, producing the POSTMARC input file 
ONERA_M4.BIN.

Note that in the following procedure the model must be displayed in 
POSTMARC, not in LOFTSMAN; LOFTSMAN does not read the CMARC input 
file, and does not have any way of knowing patch and panel numbers.

The horizontal stabilizer wake will be defined first, from tip to tip.

Each wake begins with a WAKE1 line followed by a "wake name" line whose 
default form in input files generated by LOFTSMAN is

&WAKE1 IDWAK=0 IFLXW=0 ITRFTZ=0 INTRW=1 &END
   NO WAKE

The significance of the flags is explained in the CMARC/DWT manual; for the 
time being, the line can be used in its default form, except that IDWAK must 
be 1 for the wake to be included in the analysis, and the name should be 
changed to something brief and descriptive like "HS WAKE".

Each segment of the WSL is defined by a WAKE2 line

Doubleclick on the right stabilizer. In the status line at the bottom of the 
screen, information about the patch and panel at the cursor is displayed. The 
right stabilizer is Patch 51, and, as is typical of lifting surfaces, its trailing 
edge is both edges 2 and 4 of the folded patch. The direction of edge 2 is from 
root to tip, and that of edge 4 tip to root. Since we are going from tip to root, 
we make KSIDE 4. Since the WSL lies at the edge of the patch, KWLINE  can 
be zero, which in this context always means "the patch edge". (It could also be
1, since the tip-to-root direction is that of side 4 of row 1, on the underside of 
the surface along the trailing edge.)

Because the WSL runs the entire length of the patch edge, KWPAN1 and 
KWPAN2 can both be zero, meaning, again, that the line runs from one edge of
the patch to the other.



So far we have

&WAKE1 IDWAK=1 IFLXW=0 ITRFTZ=0 INTRW=1 &END
    HS WAKE
 &WAKE2 KWPACH=51 KWSIDE=4 KWLINE=0 KWPAN1=0 KWPAN2=0 
NODEW=0 INITIAL=1 &END

This covers the trailing edge of the stabilizer. But the WSL has to continue to 
the centerline; otherwise a tip vortex is generated at the stabilizer-fuselage 
intersection.

Hit Shift-Y to display a starboard view. It may also be convenient to hide the
starboard stabilizer patch (View > Patch selection) so that it does not cover up 
the paneling immediately behind the trailing edge. Zoom in on the vicinity of 
the stabilizer and doubleclick immediately behind and below the trailing edge 
of the root intersection. The patch number is 53.

The panel edge (or "side") running fore-to-aft in this view is edge 2, that is, the
top edge of each panel. Doubleclick on the row in patch 53 whose upper edge 
coincides with the trailing edge of the stabilizer. POSTMARC reports that it is 
row 19. Again, the WSL segment runs from one edge of this patch to the other,
and so the next WAKE2 line looks like this:

&WAKE2 KWPACH=53 KWSIDE=2 KWLINE=19 KWPAN1=0 KWPAN2=0 
NODEW=0 INITIAL=1 &END

This completes the WSL for the starboard side of the model. To continue it on 
the port side, hit 'y' (lowercase) to display the port side of the model.

Patch columns on the port side are numbered in the same way as on the 
starboard, that is, generally front-to-back; but the numbering of rows is 
inverted, as if the starboard side had been rotated 180 degrees about the X 
axis. Patch edge numbering is also inverted; the lower edge is now 2 and the 
upper 4.

Since the port side is an image of the starboard that is created when 
IPATSYM=1 in each starboard patch, the sequential number of each port 
patch is one greater than its starboard sibling. Using the same method of 
identifying patches and patch edges with the cursor, the wake definition 
continues as follows:

&WAKE2 KWPACH=56 KWSIDE=4 KWLINE=11 KWPAN1=0 KWPAN2=0 
NODEW=0 INITIAL=1 &END
 &WAKE2 KWPACH=54 KWSIDE=4 KWLINE=11 KWPAN1=0 KWPAN2=0 
NODEW=0 INITIAL=1 &END



 &WAKE2 KWPACH=52 KWSIDE=2 KWLINE=0 KWPAN1=0 KWPAN2=0 
NODEW=3 INITIAL=1 &END

NODEW is 3 in the last segment, to indicate that this is the last segment in 
this WSL, but not the final WSL segment in the entire file, which would have 
NODEW=5 instead.

The leading edge of the wake is now defined. If INITIAL=0, the wake must be 
time-stepped at least 10 times to allow it to propagate and stabilize. If 
INITIAL=1, as is more often the case, the wake is defined as a patch to begin 
with, and three to six time steps are usually sufficient to converge to a stable 
solution. In either case, the trailing edge of the wake should be defined by 
placing a copy of the WSL about 10 to 20 chord lengths downstream and 
instructing CMARC to insert 20 or so panels in between. The closing 
instruction is:

&SECT1 STX=1200 STY=0.0 STZ=0.0 SCALE=1.0 ALF=0.0 THETA=0.0 
INMODE=-1 TNODS= 3 TNPS= 20 TINTS= 3 &END

The mean chord of the horizontal stabilizer is approximately 60 mm. STX, the 
downstream shift of the copy of the WSL, is 20 * 60, or 1200. For most wakes, 
the defaults can be used for the other values in the line.

To inspect the WSL, uncheck View > Hidden Line and check View > Wake 
Separation Line.

The WSL is displayed with colors alternating panel by panel. The WSL should 
not jump across a panel or across an empty space. It must always follow 
panel edges and proceed continuously, in either direction, from tip to tip (on a
two-sided model) or from tip to centerline or centerline to tip (on single-sided 
or, optionally, on two-sided models where each side's wake is defined 
separately).

Case Seven: Meshing a Slotted Flap

LOFTSMAN provides two avenues for lofting a wing with a slotted flap. Both 
provide the option of creating filed patches or a ready-to-run Cmarc input file. 
Their approaches to geometry definition are slightly different.

Method one: Mesh a pre-defined slotted flap



This is the simpler method. It assumes that the flap has already been defined 
(using the Wing  > Flap procedure), and is a ruled surface defined by two end 
breaks. This method might be used, for instance, to quickly investigate a grid 
of flap nose positions relative to a given cove lip.

First, load and display the wing file.

Select

Mesh  > Wing  > Slotted flap.

Pick the WI file for the flap.

A dialog appears. The values provided for inboard and outboard lip positions 
are those that were selected when the flap was originally defined. The flap 
nose offsets with respect to (“wrt”) the upper cove lip, on the other hand, are 
arbitrary default values and may be changed. The convention is the one used 
in Theory of Wing Sections: X and Y offsets of the flap leading edge from the 
cove lip, expressed as fractions of the main element chord.

LOFTSMAN generates a generic cove in the wing to accommodate the flap. The
mesh may comprise only the flap and the coved portion of the wing; those 
patches plus inboard and/or outboard transition strips that reconcile the 
meshing of the coved portion of the wing with the default meshing of the 
unflapped portions; or a complete wing, with panels inboard and outboard of 
the flapped portion, and with the inboard panel optionally terminating at the 
fuselage intersection.



To create a CMARC input file, check Make IN file. The IN file includes wakes 
for the wing and flap, and is ready to analyze.

Method two: Design flap geometry and create mesh

This is the method used to generate a flap in the first place. First, load and 
display the wing file.

To create a new flap, select 

Wing  > Flap

then

File > Create a new flap

Select the type of flap to be designed (External hinge or Tracked are the only 
options for a slotted flap). Plausible defaults are provided and can be accepted
for purposes of demonstration.

Click OK, then give a name for the WI, SD, FG and possibly IN files that will 
be created.

Select

Define flap > Edit a break

and select the first break station.

Initially, two distinct pairs of points coincide. They are the upper and lower 
surface tangent points, where the flap surface joins the main element surface, 
and the corresponding lips, which are the trailing edges of the flap cove.

To move a tangent point, hold the left mouse button while dragging the 
associated handle (the colored circle).

After you have moved the tangents to the desired locations, move the lips, 
which are indicated by plus signs, by holding the [Ctrl] key while dragging 
the lip marker. Obviously, the lip must be located forward of the 
corresponding point; how far depends on how thin and sharp the actual lip 
can be made.



When you move the upper-surface lip, a grid pattern moves with it. The grid 
squares are one percent of the main element chord length on a side. Drag the 
leading edge of the full-flap outline to a suitable position on the grid. 

For a tracked flap, an intermediate (takeoff ) position is shown. Move it to a 
desired location. Note that the track slots change shape to match the 
geometry. You can also drag the slots around to see, for example, whether 
they could be made to fit entirely within the wing.

Other adjustments are possible, but for the time being, select

Define flap > Accept this break

Repeat the procedure for the outboard end of the flap.

When you have defined and accepted both breaks, select

File > Save patches

Check Create IN file (the default).

Change the file name, if you wish.

You can select any flap deflection within the originally filed limits, and the IN 
file will have the flap in the proper position for that deflection.

When you click OK, two Wing bounded region mesh dialogs will appear, one 
after the other. Click OK on both, without changing the chordwise panel 
counts and spacings. 

LOFTSMAN creates an IN file with wakes for wing and flap. The file is ready to 
run in CMARC.
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